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Purpose and scope
The purpose of this guide is to help you successfully use the 9101 Handheld Spec-
trum Analyzer features and capabilities. This guide includes task-based instruc-
tions that describe how to install, configure, use, and troubleshoot the 9101 
Handheld Spectrum Analyzer. Additionally, this guide provides a description of 
Willtek’s warranty, services, license, and repair information.

Assumptions
This guide is intended for novice and intermediate users who want to use the 
9101 Handheld Spectrum Analyzer effectively and efficiently. We are assuming 
that you are familiar with basic telecommunication concepts and terminology.

Related information
Use this guide in conjunction with the following information:

Doc. no. M 295 004: Willtek 9101 Handheld Spectrum Analyzer – getting started 
manual

Willtek also offers a glossary on “Spectrum and network analysis” terms. The 
ordering number is SPEC/CT805/0703/EN.

Hardware-related changes
Please note that instruments with a serial number higher than 0104000 have 
slightly different key descriptions on the front panel. This manual uses the key 
descriptions valid at the time of writing; for newer units, please use the following 
translation table.

Table 1 New and old key assignments

Key description for units with 
serial number > 0104000 
(colored keys)

Key description for units with 
serial number < 0104000 
(grey and black keys)

MODE MEAS

PRESET PRE

CLR TRC SYS

PARAM ?

CENT FREQ

REF LEVEL

MKR MARK

ENTER
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Technical assistance 
If you need assistance or have questions related to the use of this product or call 
one of Willtek’s technical assistance centers. You can also contact Willtek by 
e-mail at customer.support@willtek.com.

Questions regarding the 9101 Handheld Spectrum Analyzer can also be directed 
to support.9101@willtek.com.

Conventions
This guide uses naming conventions and symbols, as described in the following 
tables.

Table 2 Technical assistance centers

Region Phone number Fax number

UK +44 (0) 20 8408 5720 +44 (0) 20 8397 6286

Europe, Middle East, 
Asia, Africa

+49 (0) 89 996 41 386
+49 (0) 89 996 41 227

+49 (0) 89 996 41 440

Americas +1 317 595 2021
+1 866 WILLTEK

+1 317 595 2023

Table 3 Typographical conventions

Description Example

User interface actions appear in this 
typeface.

On the Status bar, click Start.

Buttons or switches that you press 
on a unit appear in this TYPEFACE.

Press the ON switch.

Code and output messages appear 
in this typeface.

All results okay

Text you must type exactly as 
shown appears in this typeface.

Type: a:\set.exe in the dialog 
box.

Variables appear in this <typeface>. Type the new <hostname>.

Book references appear in this type-
face. 

Refer to Newton’s Telecom Dictio-
nary

A vertical bar | means “or”: only one 
option can appear in a single com-
mand.

platform [a|b|e]

Square brackets [ ] indicate an 
optional argument.

login [platform name]

Slanted brackets < > group required 
arguments.

<password>
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Table 5 Symbol conventions

Table 6 Safety definitions

Table 4 Keyboard and menu conventions 

Description Example

A plus sign + indicates simultaneous 
keystrokes.

Press Ctrl+s

A comma indicates consecutive key-
strokes.

Press Alt+f,s

A slanted bracket indicates choos-
ing a submenu from menu.

On the menu bar, click 
Start > Program Files.

This symbol represents a general hazard.

This symbol represents a risk of electrical shock.

NOTE

This symbol represents a note indicating related information or tip.

WARNING

Indicates a potentially hazardous situation which, if not avoided, could result 
in death or serious injury.

CAUTION

Indicates a potentially hazardous situation which, if not avoided, may result in 
minor or moderate injury.
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Safety warnings
This product is designed for indoor use. As exposure to water can damage the 
instrument it has to be protected against moisture when used outdoors.

WARNING

This is a safety class A equipment in accordance with EN 61326. It may pro-
duce radio interference affecting household equipment; the user may be 
forced to execute appropriate measures against radiation.

WARNING

Only use a 50 Ω N-type connector to connect to the RF IN port of the 9101. 
Use of any other connector may result in damage of the instrument.

WARNING

Do not cover the ventilation slits (at the bottom left-hand corner and on the 
top). Covering them may result in serious damage and fire.

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

WARNING

Operate the instrument within the temperature range from 5°C (40°F) to 
45°C (110°F) only. Operation outside this range will lead to invalid results.

Safety advice for the battery

Do not crush. Do not heat or incinerate. Do not short-circuit. Do not disman-
tle. Do not immerse in any liquid, it may vent or rupture! Do not charge below 
0°C (32°F) nor above 45°C (110°F). 

Battery usage

The battery is for use with the 9101 only. Willtek does not accept any liability 
for damage of the battery or other equipment if the battery is used with other 
electric or electronic equipment.
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Chapter 1 Overview

This chapter provides a general description of the 9101 Handheld Spectrum 
Analyzer. Topics discussed in this chapter include the following: 

– “About the 9101 Handheld Spectrum Analyzer” on page 2

– “What’s new in version 2.21” on page 2

– “Features and capabilities” on page 4

– “Options” on page 4

– “Physical description” on page 5

– “Maintaining your unit” on page 5
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About the 9101 Handheld Spectrum Analyzer
The 9101 is a lightweight, full-featured spectrum analyzer for many applications:

– Used in mobile phone repair to detect and locate faulty parts of mobile 
phones and components.

– Used in R&D labs for basic measurements and verifiying EMI clean circuits.

– Used in manufacturing to check and align the output of the unit under test 
(UUT).

– Used in the field to measure and verify base station emissions.

This rugged instrument is suitable for stationary and mobile usage and meets 
many application needs.

What’s new in version 2.21
Improvements:

– Frequency offset corrected for small span (< 200 kHz) and long sweep time 
(> 5 s)

– Displayed battery charge corrected, automatic battery voltage check and 
automatic correction of battery load during startup process.

– Automatic switch off from video trigger to free run implemented, when span 
is changed from zero span to span ≥ 100 kHz

– "Not loaded" will be displayed when no files (Limits, Channel settings) are 
loaded
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New in version 2.20 New features:

– External device compensation

– Impedance selection 50/75 Ω

– Low battery alarm

– Parameter screens

– Copying between traces A and B

– Marker To FStep function

– Measurement types Channel Power/ACPR/OBW within Channel Power and 
Spectrum Analysis modes

– Permanent demodulation

– Limit settings file displayed

– Simple limits

– Traces and settings can be transferred to the instrument

Improvements:

– Dynamic frequency button handling changed

– Various System Information menus modified

New in version 2.10 Parameter menu for channel power and spectrum analyzer mode implemented

System menu with time and date added

Automatic sweep time calculation optimized for sweep times below 24 ms

Filter transient time improved for combination of 200 kHz span and 10 Hz video 
bandwidth so that measurement is calibrated

Rework of IP address input

New in version 1.54 Redesigned user interface (colors, softkeys, graph)

New menu structure

AM/FM demodulation 

New frequency entry mode (Start/Span) (removed in version 2.20)

Channel power measurement application selectable with measurement mode 
key

Video trigger (positive, negative slope)

Number of single sweeps selectable

Limit lines (lines, fail count, fail beep, fail hold)
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Averaging

Frequency step functionality with cursor keys

New marker handling (absolute, relative, marker to highest peak)

Sweep counter

Battery management

Features and capabilities
Frequency range from 100 kHz to 4 GHz

Digital IF for accurate measurements

Auto mode for basic parameters

Four markers, up to three delta markers

Large and bright display

Small footprint, large front

Lightweight, high battery power

Remote control via RS-232 or LAN

Options
The following accessories are available:

Table 7 Accessories for the 9101 Handheld Spectrum Analyzer

Order number Description

M 248 640 1205 RF Probe 20 dB (includes N to BNC adapter)

M 886 097 Adapter N (male) to BNC (female)

M 886 098 Adapter N (male) to TNC (female)

M 205 011 Standard battery (rechargeable, 4 Ah)

M 205 012 High-capacity battery (rechargeable, 8 Ah)

M 860 389 12 V car adapter

M 860 388 Null modem cable

M 241 013 Soft carrying bag

M 248 633 9190 Demo Signal Generator
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Physical description
The 9101 Handheld Spectrum Analyzer is delivered with the 91xx Data Exchange 
Software which can also be ordered separately.

The user-accessible parts of the 9101 can be broken down into several sections:

– Front panel with large screen, softkeys, numeric, cursor and function keys.

– Connectors accessible from the top of the 9101.

– On/off switch, power supply connector and battery shelf.

– Handle which can be turned in steps so serve as a stand, allowing the 9101 
to be operated at an angle.

Maintaining your unit
Willtek seeks to permanently improve its products. Software updates are avail-
able on the Internet at www.willtek.com. For a detailed description of updating 
the Application Software please refer to Chapter 6 “Updating the Instrument’s 
Software”.

The 9101 Handheld Spectrum Analyzer is a measurement device. As with all such 
instruments, the 9101 should be calibrated on a regular basis to ensure the accu-
racy. Willtek recommends calibration of the 9101 at yearly intervals.

Please take also advantage of our Frequently Asked Questions and our electronic 
newsletter, both available on the Internet.

Further questions regarding the 9101 Handheld Spectrum Analyzer can be 
directed to support.9101@willtek.com.

M 860 261 Antenna, 900 MHz (TNC)

M 860 262 Antenna, 1800/1900 MHz (TNC)

M 860 146 Antenna, 2400 MHz (TNC)

M 867 037 Safety lock

M 897 137 91xx Data Exchange Software

Table 7 Accessories for the 9101 Handheld Spectrum Analyzer

Order number Description
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Chapter 2 General Operation

This chapter describes the instrument’s functions that are independent of the 
selected mode. Topics discussed in this chapter are as follows:

– “Connecting the 9101 Handheld Spectrum Analyzer” on page 8

– “Powering up the unit” on page 9

– “Starting measurements” on page 9

– “Using the front panel” on page 10

– “Selecting the measurement mode” on page 20

– “Working with the markers” on page 21

– “Using limit lines” on page 24

– “Controlling the 9101 from a PC” on page 27

– “Returning from remote control to local mode” on page 27

– “Checking general settings” on page 28

– “Working with stored settings” on page 35
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Connecting the 9101 Handheld Spectrum Analyzer

DC IN connector The 9101 can be operated either from the internal battery or from an external DC 
source such as the power supply which is delivered with the 9101. In addition, 
the battery is loaded when an external DC source is connected. See the specifi-
cations in your getting started manual for details of the required DC source. Here 
you will also find detailed information on charging the battery.

Apply the source to the DC IN connector at the top of the 9101.

RF IN connector RF in is a 50 Ω N-type connector (female).  

If you have a 50 Ω shielded RF cable with an N-type connector (male) to connect 
to the device under test, simply screw the connector tightly to the 9101. 

If you have a 50 Ω shielded RF cable with a BNC connector (male), use an N to 
BNC adapter to connect the cable to the 9101. Willtek offers an appropriate 
adapter; see section “Options” on page 4.

Figure 1 9101 connectors

DC in 

Ext. trigger 

RF in 

Serial

LAN 

CAUTION

The maximum allowable input level at the RF IN connector is 30 dBm (1 W). 
Higher levels at this port can damage the instrument!

CAUTION

Only use a 50 Ω N-type connector to connect to the RF IN port of the 9101. 
Use of any other connector may result in damage of the instrument.

Take care of proper termination

Use of cables and sources with an impedance other than 50 Ω results in inac-
curate measurements.
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If you want to test a device with an impedance of 75 Ω, refer to section 
“Changing the input impedance” on page 44 to adapt the 9101 settings.

The link between the device under test and the 9101 Handheld Spectrum 
Analyzer may be attenuated, for example because the link is an antenna or 
includes a power splitter, or a long cable. The effect of the attenuation on the 
measurement results can be compensated by entering the attenuation value in 
the 9101, see section “Compensating gains and losses” on page 43.

EXT. TRIG. connector This connector has no function in this software version.

SERIAL (RS-232)
connector

This 9-pin sub-D connector of the 9101 Handheld Spectrum Analyzer can be used 
to control the instrument remotely via serial interface (RS-232). The command 
set and responses are explained in section “SCPI Command Reference” on 
page 101.

Use a null modem (PC to PC) cable to connect the 9101 to a controlling PC.

LAN connector The 9101 can also be controlled via local area network (LAN) using a TCP/IP 
connection. The IP address can be set up in the system configuration menu or via 
RS-232. The 9101 can be operated in networks operating at 100 Mbps, but is 
capable of transmitting and receiving at 10 Mbps only.

The command set to control the 9101 and the responses from the 9101 are 
explained in section “SCPI Command Reference” on page 101.

Connect the 9101 to the LAN with a standard LAN cable with RJ-45 connectors.

Powering up the unit
The 9101 is switched on and off using the power switch located at the top of the 
instrument. It takes about 55 seconds for the 9101 to load and start its software.

Starting measurements
The 9101 starts measuring and displaying results automatically after powering 
the instrument. It starts in the measurement mode last active.

WARNING

The EXT. TRIG. input is designed for TTL input levels only. Higher levels at 
this port can damage the instrument!
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Using the front panel

Overview The front panel is divided into different sections as follows:

Battery status LED This LED has different states:

– The LED lights green when the 9101 is being operated from its battery and 
no external power is supplied.

– The LED lights yellow when the battery is connected to an external power 
supply. 

– The LED may initially go on and off intermittently (yellow, qualification 
charge, less than three minutes).

– When the LED is flashing yellow quickly for less than a minute, the battery is 
being checked.

– When the LED is flashing yellow quickly and permanently, there is a problem 
with the battery or the charger. Please report this problem to a Willtek 
service center.

– The LED is off in all other cases.

Figure 2 Front panel elements

display cursor keys function keys

horizontal (menu) softkeysvertical (function) softkeys numeric keys enter keys

NOTE

Signal level measurement results may be impaired when the battery is low, 
that means when the battery has less than 10% of its nominal capacity. See 
Table 8 on page 12 for an indication when the battery is low. For a detailed 
description on installing and charging the battery please refer to your Getting 
Started Manual.
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Display The 6.5 inch display is divided into the following sections (see Figure 3):

– Results area

– Marker field

– Input field

– Softkey descriptions

Results area Result area (graph)

The results area utilizes most of the screen and provides you with the measure-
ment results. A grid of ten vertical and eight horizontal lines eases readability of 
results from the axes. There may be one or two graphs, depending on the number 
of traces selected.

Horizontal axis

The horizontal axis is the frequency axis for the spectral components. The zero 
span mode is an exception, as the horizontal axis is the time axis in this case. The 
values of the frequencies at both ends of the scale are indicated (start and stop 
frequencies).

Vertical axis

The vertical axis reflects the RF power. Depending on your choice of the level 
unit, the RF power is indicated in dBm, dBV, dBmV, or dBµV. The top end of the 
power scale is called the reference level.

Figure 3 Display sections
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Symbols (icons)

Apart from the results graph itself, several icons are available to indicate the 
status of the 9101 as follows:

Other screen elements

The bar to the left of the vertical axis carries some or all of the elements shown 
below:

Table 8 Icons on the display

Symbol Meaning

The 9101 is taking its operating current from the battery. The 
colored area marks how much of the capacity is still available.
For 30% or more, the area is indicated in yellow; from 10% to 
30%, the area is shown in red, and in white for less than 10%. 
The 9101 sounds a double beep when the capacity goes below 
30% of its nominal value and two double beeps below 10%.

The 9101 is connected to an external DC supply.

The 9101 cannot determine the battery charge although the 
battery can still be used and recharged. 
Please contact Willtek service to have your battery checked.

The 9101 cannot determine the battery charge; typically 
appears during the last third of operating time of battery 
operation. Please contact Willtek service to have your battery 
checked.

The battery is not installed and the 9101 is operated from the 
external power supply.

The 9101 is connected to a local area network (LAN).

A video trigger has been set at the power level indicated. The 
icon also displays the slope of the trigger.

Demodulation is switched on so that the 9101 emits the 
demodulated signal at the loudspeaker.

Table 9 Texts on the left-hand side

Text Meaning

Ref. Level Indicates the top-most level on the vertical (power) axis. Can 
be modified with the REF hardkey.

dBm
dBµV
dBmV
dBV

Shows the unit in which power is displayed. Can be changed 
in the Level > Units menu.

HOLD Indicates when measurements have been halted with a press 
of the HOLD/RUN key. 
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Marker field

If any of the markers is active, the marker field is displayed, showing the 
measurement values at the marker positions. Up to four markers are displayed 
with their level and frequency values. A marker can be switched from absolute 
to relative values; the values are then shown relative to those of marker M1.

Input field

The input field allows you to enter a number or a text, depending on the selected 
function. The meaning of the input value is expressed by the header line. Some 
input fields have an additional explanation of the step size beneath; the step size 
applies when the value is changed using the up/down cursor keys instead of the 
numeric keys.

Cnt The number following shows the progress of the measure-
ments, that means it indicates how many measurements with 
the present configuration have already been taken. The 
counter continues while the trace hold mode is enabled. It is 
reset whenever a parameter affecting the measurements is 
changed, that means frequencies, filters or attenuation.

Ext. Dev. Indicates that the external device compensation is turned on, 
that means the attenuation of any coupling device is taken 
into account. The external device compensation can be set up 
as shown in section “Compensating gains and losses” on 
page 43.

UNCAL When displayed, the filter and sweep time setting do not per-
mit proper measurements.

Pos./Neg.
Pos. Peak
Neg. Peak
Sample

Shows the current detector setting. The detector can be 
changed as explained in section “Selecting the detection 
method” on page 51. 

A/B (ACT)
A/B (HLD)
A/B (MAX)
A/B (MIN)
A/B (AVG)

Shows the currently selected trace mode for the respective 
trace. The background color of the text coincides with the 
color of the graph. For more information on trace modes, see 
section “Selecting the trace mode” on page 48.

Table 9 Texts on the left-hand side

Text Meaning
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Softkey descriptions

The softkey descriptions indicate the assignment of a function to a softkey. They 
are aligned to the lower side with the horizontal softkeys and to the right-hand 
side with the vertical softkeys. See below for more information about the soft-
keys.

Keypad The front panel carries a large number of keys, giving you direct access to func-
tions and menus and allowing you to enter test parameters such as the center 
frequency. The keypad is divided into the following sections:

Function keys

The function keys have specific functions which do not change. The function keys 
are:

Table 10 Function keys

Key Function

Mode Measurement mode selection. This key allows you to 
select between different predefined types of measure-
ments for specific applications. It also provides access to 
system settings.

Preset Presets all the entry fields to the factory default set-
tings. 
To prevent accidental resets, the preset function does 
not execute after a short keypress. Press this button for 
at least half a second to return to the defaults.

Hold/Run Stops and starts sweeps.
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Cursor keys

In an input field, the up and down cursor keys are used to increase or decrease 
the current value. The left and right cursor keys move the cursor position by one 
digit.

If a marker field is active, the up and down cursors move the marker by half a 
division up or down, respectively. The left and right cursor keys move the marker 
pixelwise.

Param This key calls up the parameter pages summarizing the 
current settings. Use the Previous and Next softkeys to 
navigate between the pages, or press ESC or Exit to 
close the parameter pages and resume measurements.
Note that the parameter pages differ between the mea-
surement modes.
Parameters that lead to an UNCAL warning are marked 
with a diamond.

Rcl/Store Provides access to the memory menus.

Clr Trc This key resets previous results (including averages), the 
sweep counter and the failure counter, and starts a new 
sweep.

Cent Direct access to the center frequency input field within 
the frequency menu.

Span Direct access to the frequency span input field within 
the frequency menu.

Ref Direct access to the reference level input field.

Mkr Access to the marker menu. 

Table 10 Function keys

Key Function
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Numeric keys

The numeric keys allow you to enter a value similar to a pocket calculator. On 
some input fields, you can enter text instead, as on a mobile phone.

Enter keys Any input of numerical or alphanumerical entries must be closed or can be 
affected by one of the enter keys. The meaning of the keys is as follows:

Immediate reaction

Any change of an input parameter with the cursor keys has immediate effect. 
With the straight feedback on the screen, you can easily adjust parameters to 
the optimum values with a trial-and-error approach.

Invalid entries

If you enter an invalid number or string, the 9101 beeps and corrects the entry 
to the closest valid value.

Table 11 Enter keys

Key Function

GHz/dBm In frequency input fields, closes the entry by applying 
the unit GHz (gigahertz). In power input fields, assigns 
the unit dBm to the entered value.

MHz/dB/µs In frequency input fields, closes the entry by applying 
the unit MHz (megahertz). In power input fields, assigns 
the unit dB to the entered value. In time parameter 
input fields, assigns the unit µs to the value.

kHz/dBµV/ms In frequency input fields, closes the entry by applying 
the unit kHz (kilohertz). In power input fields, assigns 
the unit dBµV to the entered value. In time parameter 
input fields, assigns the unit ms to the value.

Enter Confirms an entry without a unit and with the units 
Hertz and seconds.
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Escape key If pressed while an input field is open, the ESCAPE key closes 
this input field without changing the previous value.

Backspace key Deletes the last entered alphanumerical (backspace).

When an input field is entered, all digits are marked. By pressing 
the backspace key, the entire entry is deleted.

Softkeys The functions of the softkeys change with the description on the screen given 
next to the respective key.

Horizontal (menu) softkeys

The horizontal softkeys provide access to the various menus. The name of the 
active menu is highlighted; the functions of a menu are offered on the vertical 
softkeys. Submenus are indicated with three dots (“...”); the menu softkey 
without the dots leads you one level up in the menu hierarchy.

Vertical (function) softkeys

The vertical softkeys allow you to change the settings of the 9101. 

The vertical softkeys in the 9101 carry out one of the following functions:

– Normal settings – by pushing the softkey, an entry field appears on the top 
of the display, allowing you to enter numerical or alphanumerical data. The 
data become valid after pushing one of the enter keys. Some of the softkeys 
for normal settings also describe the currently set value.
Example: The Channel softkey in channel power mode.
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– Combined entry and selection – this type of softkey allows you to change a 
value and also to change a related setting, for example changing between 
automatic and manual parameter setting. The first push on the softkey 
opens the entry field like the normal settings softkey. Pushing it several 
times results in the 9101 toggling between the available options. The option 
currently selected is indicated in blue while the inactive options are shown 
in white.
Example: The RBW softkey.

– Execution – by pushing the softkey, the function described is performed. The 
execution softkey is indicated by an exclamation mark.
Example: Max Peak softkey in the marker menu.

– Selection – several selection softkeys allow you to choose between different 
options. The selection softkeys for one function are indicated by a vertical 
bar connecting the softkeys, and a text describing the function. The option 
currently active is highlighted, i.e. indicated by inverted colors.
Example: The TrigMode softkeys in the sweep menu.

Entering numbers and text Whenever an input field is open, it expects you to enter either numbers or char-
acters (where characters may also include numerical digits). You will notice 
immediately what the 9101 expects as the numeric keys have the appropriate 
function.

Filling in a numerical input
field

When the 9101 software expects a numerical entry, pressing a numeric key 
results in the appropriate digit to appear in the input field. The 9101 may or may 
not allow you to enter a decimal number or a signed value, so the keys for the 
decimal point and for changing the sign of the number are either active or not. 
When all digits, the sign and the decimal point have been entered as required, 
one of the enter keys must be pressed. Numbers often carry a unit with them; 
the enter keys provide the appropriate units.

Acoustical reaction on inputs

After entering a new parameter value, one of two acoustical alarms may appear:
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– Short beep (hint): The parameter is out of limits, or the input affects an 
associated parameter; the respective parameter has been corrected by the 
9101 Handheld Spectrum Analyzer. 
Example 1: An invalid stop frequency of 5 GHz has been entered, resulting in 
a short beep and the maximum stop frequency of 4 GHz being set.
Example 2: The start frequency is set to 2 GHz, the stop frequency is set to 
4 GHz and the user enters a new span of 3 GHz. This results in the start 
frequency being changed to 1 GHz and a short beep to sound.

– Long beep (error): A parameter is set to an invalid value and the 9101 Hand-
held Spectrum Analyzer resumes the old value, sounding an error beep.
Example: After entering a new (invalid) attenuation value of 60 dB, the 9101 
Handheld Spectrum Analyzer sounds a long beep and sets the attenuation 
back to the previous value.

Filling in a text input field Some input fields can be filled with alphanumerical text instead. The numeric 
keys can then be used to enter characters. The keys may have several letters or 
numbers assigned. The assignment of the keys in this case is as follows:

To enter a character, push the key rapidly and repeatedly until the desired char-
acter appears in the input field.

Changing the input Once an input field is open, you can move the cursor with the LEFT/RIGHT 
cursor keys to place it within the number or text. Additional digits or characters 
can be entered, or you can delete the digit or character in front of the cursor 
using the BACKSPACE key.

Table 12 Keys for alphanumerical text entry

Key Assignment

0 0

1 1

2 A, B, C, 2

3 D, E, F, 3

4 G, H, I, 4

5 J, K, L, 5

6 M, N, O, 6

7 P, Q, R, S, 7

8 T, U, V, 8

9 W, X, Y, Z, 9

. not assigned

± not assigned
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Selecting the measurement mode
The 9101 provides different measurement modes:

– The spectrum analysis mode is most versatile; it provides most of the options 
included in all other modes. For more information on this mode, refer to 
page 37.

– The channel power mode allows you to measure the radiated power within a 
certain frequency band. Read more about channel power mode on page 59.

In addition, the Mode menu provides access to the system settings, e.g. the I/O 
configuration, and to version information. See section “Checking general 
settings” on page 28 for more details.

To select the measurement mode, proceed as follows:

1 Push the MODE button.
The mode menu appears (see Figure 4).

2 Select a new mode or return to the mode last active by pressing the respec-
tive softkey.
The main menu of the selected mode appears. If you select a new mode, all 
parameters are set to the values from when the mode was last active. If, 
however, you resume the last active mode, measurements are continued.

Figure 4 Selecting a measurement mode
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Working with the markers

The 9101 includes powerful and easy-to-use marker functions. Up to four 
markers can be used; up to three of them can be delta markers. Markers are easy 
to place and you can easily affect the center frequency and the reference level 
upon a keypress.

It is important to note that if you place the cursor on a signal peak and then 
reduce the span, the marker position may be offset a little from the peak. This is 
due to the limited resolution of the displayed frequencies when using a high 
span. After reducing the span, the marker should be readjusted to the new peak.

Enabling and moving a
marker

1 From the main menu, select Marker. Or push the MKR key in any menu.
If no marker is active, marker M1 will be enabled at the maximum peak. The 
input field for marker M1 appears.

2 If you want to enable another marker, push the appropriate softkey (M1 
through M4).
The marker is enabled and the input field opens; the selected marker appears 
in the marker field in the top bar of the display.

3 If required, move the marker to another position using the cursor keys, one 
of the softkeys Max Peak and Next Peak, or by entering the frequency with 
the numeric keys and the appropriate enter key.

Figure 5 Example of markers
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Disabling a marker 1 From the main menu, select Marker. Or push the MKR key in any menu.
The marker menu appears and the input field for marker M1 appears.

2 Push the softkey (one of M1 through M4) for the marker that you want to 
disable.
If previously enabled, the marker is disabled and the respective marker 
values disappear in the marker field at the top. A subsequent push would 
reenable the marker.

Enabling a delta marker For delta markers, the power level and frequency relative to marker M1 is 
displayed in the marker field. Marker M1 cannot be a delta marker.

1 From the main menu, select Marker, or push the MKR key in any menu.
The marker menu and the marker M1 input field appear.

2 Select Mkr Delta.
The delta marker menu appears.

3 Select the marker which you want to turn into a delta marker (M2 through 
M4).
If not already enabled, the marker is turned on.

4 Push the rel softkey to turn the selected marker into a delta marker.
The rel softkey is highlighted and the respective marker in the marker field is 
indicated as a delta marker, e.g. D2 instead of M2. 

Disabling a delta marker 1 From the main menu, select Marker, or push the MKR key in any menu.
The marker menu and the marker M1 input field appear.

2 Select Mkr Delta.
The delta marker menu appears.

3 Select the delta marker that you want to disable (e.g. D2).

4 To disable the marker completely, push the key until off is highlighted.
To turn the delta marker into a normal marker displaying absolute values 
again, push the abs softkey.

Setting a marker on a
frequency relative to

marker M1

1 Enable a delta marker as described in “Enabling a delta marker”.
For the selected delta marker, the input field shows the frequency relative to 
marker M1.

2 Enter a (signed) frequency relative to the frequency at marker M1, either 
using the numeric keys and the respective enter key, or moving the cursor to 
that frequency with the help of the cursor keys.
The marker field indicates the desired frequency offset for that marker, along 
with the power level relative to the power at marker M1.
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Changing the center
frequency with a marker

This function modifies the center frequency, adapting the frequency of a select-
able marker.

1 From the main menu, select Marker, or push the MKR key in any menu.
The marker menu and the input field for marker M1 appear.

2 If you want to use the frequency at a marker position other than M1, push 
the appropriate softkey (M2 through M4).

3 Push the Marker to Center softkey.
The center frequency changes to the frequency at which the selected marker 
is located. The frequency span only changes if the change in center 
frequency would lead to an invalid start or stop frequency.

Changing the reference
level with the marker

The reference level can be changed to the level at a marker position as follows:

1 From the main menu, select Marker, or push the MKR key in any menu.

2 Select the Mkr Transfer menu.

3 If you want to use the power level at a marker position other than M1, push 
the appropriate softkey (M2 through M4).

4 Push the Marker to Ref. Lvl softkey.
The reference level changes to the level of the selected marker.

Assigning the marker
frequency to FStep

For measurements of harmonics or intermodulation products, it can be useful to 
easily change between frequencies in user-defined steps. The “Marker to FStep” 
function assigns the active marker (or delta marker) frequency to FStep, the step 
width for the selection of center frequency and marker frequency.

Assumption: One of the markers M1 through M4 is active.

1 From the main menu, select Marker > Mkr Transfer to access the marker 
transfer menu.

2 Push Marker to FStep.
The FStep parameter assumes manual mode. If the currently active marker is 
an absolute marker, the frequency at the marker position becomes the new 
FStep value. Alternatively, if the currently active marker is a relative (delta) 
marker, the difference between the frequencies at the active marker and M1 
becomes the new FStep value.
If the new FStep value is higher than 1 GHz, the old FStep value is main-
tained and the 9101 sounds a hint beep.



Chapter 2 General Operation
Using limit lines

24 9101 Handheld Spectrum Analyzer Version 2.21

Using limit lines

Overview A very useful feature of the 9101 is the possibility to set limits for the trace A 
results. These are displayed on the screen and the 9101 can show if the results 
exceed the limits. 

Two different limit modes exist in the 9101. In the first case, the limits exist of 
horizontal lines for the upper and lower limit. This method is called “simple 
limits”; the limits can be entered directly in the limits menus of the 9101. 

In the second case, there are more complex limits as shown in the example in 
Figure 6. These limits can be entered with a comfortable tool on a PC and loaded 
to the 9101 via RS-232 or LAN interface. A set of limit lines can be used to define 
a measurement template. There are versatile tools around these limits available 
on the 9101, such as a fail counter, a beep when a failure occurs, or a measure-
ment hold function upon failure. The limits can be used both in the frequency 
and in the time domain.
Up to 99 sets of limits can be stored on the 9101.

The actual limit values must be defined on a PC and loaded to the 9101 using the 
91xx Data Exchange Software. Several limit files can be stored on the 9101. The 
name of the current limit file is indicated in the upper left-hand corner.

Note that the limits are defined within a grid, no matter what the units on the 
vertical and horizontal axes are. This way, you can apply the limits to different 
frequency ranges and power levels. It is your responsibility, however, to select a 
useful frequency range, reference level and level scale.

Note that a FAIL indication may occur if the start frequency is 0 Hz and an upper 
limit is set at this frequency.

Figure 6 Example of limit lines in spectrum analysis
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Using simple limits Simple limits consist of constant upper and lower limits. They must be activated 
to take effect. Once activated, each measurement is accompanied by a Pass/Fail 
verdict indicating whether or not the measurement result was within the limits.

Switching simple limits on and
off

By switching limit lines on, any previously active limit template is disabled.

1 Press Level > Limits Memory.

2 Press the Simple Limits softkey so that the new choice (on or off) is high-
lighted.
When switching limits on, red horizontal lines indicating the upper and 
lower limits appear. A Pass/Fail verdict is displayed with every new measure-
ment in the upper left corner of the screen. The text above the verdict 
(“Simple Limits”) indicates that the verdict applies to simple limits.
When switching limits off, the limit lines and the verdict disappear.

Defining upper and lower limits The limits can be changed only when simple limits are activated. The range of 
valid entries depends on the power scale displayed (vertical axis) as follows:

Follow the steps below to define simple upper and lower limits.

1 Press Level > Limits Memory.

2 Press the Upper softkey, enter a new value for the upper limit (in dB, rela-
tive to the reference level) (or move the upper limit with the UP/DOWN 
cursor keys) and confirm with MHZ/DB/µS or ENTER.
The upper limit line is moved to the new value.

3 Press the LOWER softkey, enter a new value for the lower limit (in dB) (or 
move the lower limit with the UP/DOWN cursor keys) and confirm with 
MHZ/DB/µS or ENTER.
The lower limit line is moved to the new value. 

Table 13 Valid entries for upper/lower simple limits (relative to 
reference level)

Scale Valid range

1 dB/division –8 … 0 dB

2 dB/division –16 … 0 dB

5 dB/division –40 … 0 dB

10 dB/division –80 … 0 dB

20 dB/division –160 … 0 dB
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Using limit templates Limits can be comfortably defined with a PC-based tool and loaded to the 9101. 
This is described in full detail in chapter “91xx Data Exchange Software” on 
page 83. The sections below describe how to recall, delete, activate and deacti-
vate limit templates.

Selecting limit lines within
the 9101

1 From the main menu, select Level > Limits Memory.
The limits memory menu appears.

2 Push the Recall Limit Template softkey.
An entry field appears, together with a file selection box.

3 Select a file either by moving the selection to its file name using the UP/
DOWN cursor keys, or by entering the file name in the entry field and 
closing the input field with the ENTER key.
The file with the limits is loaded and the upper/lower limits are activated 
immediately.

Activating and deactivating
limit templates

1 Select a limits file (see section “Selecting limit lines within the 9101”).

2 Select Level > Limits Evaluation
The limits evaluation menu appears.

3 Select the limits option you want by pushing the appropriate softkey from 
the following choice: Off, Upper/Lower, Upper Limit, Lower Limit.
If you selected Off, no limits are displayed. Otherwise, the selected limits 
curve (upper and/or lower limits) appears on the screen. A pass/fail indica-
tion is given for each measurement trace in the upper left-hand corner.

Deleting limit files in the 9101 1 From the main menu, select Level > Limits Memory. 

2 a. To delete an individual file, push Delete Limit Template, select a limits 
file with the UP/DOWN cursor keys and push ENTER to delete an individual 
file (pressing ESC aborts the process before the file is deleted).

b. To delete all the limit files stored in the 9101, push Delete All Templates. 
Confirm with ENTER if you really want to delete all the limit files.

Counting limit failures When limit checking is enabled, a failure counter can be activated. The number 
of failures appears below the pass/fail verdict. The counter makes particular 
sense for statistical evaluations. For this application, it is important to define the 
number of measurements. The following sequence can be useful to obtain a 
failure count in conjunction with a defined number of measurement traces.

1 Select a limited number of traces (Freq > Sweep, see “Performing a limited 
number of measurements” on page 46).

2 From the main menu, push Level > Limits Evaluation > Fail Count to turn 
the failure counter on; if it was on already it should be switched off and on 
again.
The failure counter is reset to 0.
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3 Push the HOLD/RUN key to start the measurement.
Both the measurement counter and the failure counter start from 0. When 
the selected number of traces has been reached, the measurements are 
stopped and you can read the failure count.

Resetting the counter The failure counter for the limits check can be reset by turning it off and then on 
again (in the Level > Limits Evaluation menu).

Enabling a beep upon
failures

1 From the main menu, push Level > Limits Evaluation.
The limits evaluation menu appears.

2 Push the Fail Beep softkey to activate or deactivate the beep counter:
If activated, a beep sounds each time the measured signal exceeds the 
limits.

Viewing a failed
measurement

This feature can be useful if you want to stop the measurement and view the 
measured signal when it fails the limits. Note that the 9101 should be set to 
continuous measurements.

1 From the main menu, select Level > Limits Evaluation.

2 Push the Fail Hold softkey once or twice to enable or disable the hold-on-
fail function.
The measurements are halted when a failure occurs. The trace of the failed 
signal remains on screen.

Measurements can also be stored and recalled in the 9101 for later analysis or 
comparison. This is shown in “Storing and loading traces” on page 53.

With the 91xx Data Exchange Software, traces can also be transferred to and 
viewed and stored on a PC. For more details, please refer to chapter “91xx Data 
Exchange Software” on page 83.

Controlling the 9101 from a PC
The 9101 can be used under remote control from a PC. The interfaces supported 
for this are the serial interface (RS-232) and the LAN (TCP/IP). Please refer to 
section “SCPI Command Reference” on page 101 for more information on remote 
control.

Returning from remote control to local mode
To gain manual control after using the 9101 under remote control, push the 
ESCAPE key.
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Checking general settings
This section covers information about the unit, setting display brightness, time 
and date, and configuring the remote control interfaces of the 9101.

Reading the serial number You can find the serial number of your 9101 as follows:

1 Push the MODE key.

2 Select System > System Information.
The system information display appears (see Figure 7), showing the serial 
number, the installed software version and the installed options.

Reading the software
version number

Before loading a new software version or reporting problems, you may want to 
check the currently installed version.

1 Press hardkey MODE, followed by softkey System.
The System Information menu appears.

2 Read and note the software version number in the field entitled Application. 

Reviewing the calibration As for all test instruments, the 9101 Handheld Spectrum Analyzer accuracy 
should be checked against its specifications; this process is called calibration. If 
the 9101 accuracy falls outside the specified tolerance it may be necessary to 
correct the instrument.

Figure 7 System information menu
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Willtek recommends a calibration interval of one year. The 9101 stores the date 
of the last calibration by a Willtek-certified lab and the date when the next cali-
bration is due. In addition, you can document when the calibration date has been 
reviewed last.

To check if the 9101 is due for calibration, proceed as follows:

1 Press hardkey MODE, followed by softkey System.
The System Information menu appears.

2 See the Calibration area:
The first line indicates the date of the last calibration and the organization 
calibrating the 9101.
The second line indicates when and by whom the calibration has been 
checked last.
The third line indicates when the next calibration is due. This date is typi-
cally one year after the last calibration.

3 Push softkey Date Last Changed to change the last check date. It will be 
set to the actual date as set by the built-in real-time clock.

4 Push softkey Name Last Changed to enter the name of the person that 
carried out the last calibration date review.

Checking installed options Willtek provides different application programs and options for the 9101 Hand-
held Spectrum Analyzer. These may or may not be active on your instrument. To 
check which options are actually installed on your 9101, take the following steps:

1 Press hardkey MODE, followed by softkey System.
The System Information menu appears.

2 Select Options.
The Options menu appears, indicating the installed options in bold print with 
a tick in front; the options not installed are shown in grey.

Installing a new option Software options can be installed by entering an activation key which you can 
purchase from Willtek Communications or one of its representatives. To install a 
new option:

1 Press hardkey MODE, followed by softkey System.
The System Information menu appears.

2 Select Options and press Activate Options.

3 Enter the activation key and press the ENTER key.
If the code is valid, the appropriate option is shown in bold print with a tick 
in front, indicating that the option is accessible now.
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Changing the display
brightness

1 Push the Mode key. 

2 Select System > General Settings.
The general settings display appears (see Figure 8), showing the current 
display backlight setting as a percentage.

3 Push the Display softkey.
The backlight input field is highlighted.

4 Enter a new value and confirm with ENTER, or change the current value 
with the UP/DOWN cursor keys.
The 9101 display uses the new brightness value.

Enabling and disabling
beeps

Warning and error beeps can be turned off and on in the General Settings menu: 

1 Push the Mode key. 

2 Select System > General Settings.
The general settings display appears, showing the current setting for beeps 
(on or off).

3 Push the Beep softkey several times until the desired setting is highlighted 
(on or off).
The beep input field shows the current setting.

Figure 8 General settings menu

NOTE

The display setting for adjusting the brightness is not affected by a press on 
the PRESET button, but by a push on the Back to Defaults softkey.

NOTE

This parameter is not affected by a press on the PRESET button, but by a 
push on the Back to Defaults softkey.
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Assigning a device name
to the instrument

A device name for the 9101 can be useful if you have several units of the 9101 
Handheld Spectrum Analyzer. They can be identified if you choose different 
names for them. The name also appears on traces transferred to the PC with the 
91xx Data Exchange Software. 

A new name can be entered as follows:

1 Push the Mode key. 

2 Select System > General Settings.
The general settings display appears, showing the current device name.

3 Push the Device name softkey.
The device name input field is active so you can overwrite the current name.

4 Enter a new name (max. 11 characters; see section “Filling in a text input 
field” on page 19 to learn how to do this) and close the entry field by 
pressing ENTER.
The new name is displayed in the device name field.

Adjusting date and time in
the instrument

The 9101 Handheld Spectrum Analyzer includes a real-time clock. It can be used 
to show the actual date or to compare it with the date when the next calibration 
is due.

The date can be changed as follows:

1 Push the Mode key. 

2 Select System > General Settings.
The general settings display appears, showing the current date and time.

3 Push the Date softkey.
The date input field is active so you can overwrite the old date with a new 
one or move the cursor with the LEFT/RIGHT cursor keys behind a digit 
that needs to be changed, push the BACKSPACE key to erase it and enter a 
new digit.

4 Press ENTER or another function key to confirm the entry.
The new date is shown in the General Settings menu.

The time can be modified as follows:

1 Push the Mode key. 

2 Select System > General Settings.
The general settings display appears, showing the current date and time.

3 Push the Time softkey.
The time input field is active so you can move the cursor with the LEFT/
RIGHT cursor keys behind a digit that needs to be changed, push the BACK-
SPACE key to erase it and enter a new digit.

NOTE

This parameter is not affected by a press on the PRESET button, but by a 
push on the Back to Defaults softkey.
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4 Press ENTER or another function key to confirm the entry.
The new time is shown in the General Settings menu.

Changing the bit rate on
the RS-232 port

1 Push the Mode key.

2 Select System > I/O Config.
The port configuration display appears (see Figure 9), showing the current 
RS-232 bit rate (or baud rate) and interface settings.

3 To change the data rate, push the Baudrate softkey and select a new rate 
with the UP/DOWN cursor keys.
The change takes effect immediately.

Changing the IP address of
the 9101

The IP address should be adapted to the address space in use in your environment 
and should be unique for each device on that network.

1 Push the Mode key.

2 Select System > I/O Config.
The port configuration display appears, showing the current TCP/IP settings.

NOTE

These parameters are affected neither by a press on the PRESET button nor 
by a push on the Back to Defaults softkey.

NOTE

This parameter is not affected by a press on the PRESET button, but by a 
push on the Back to Defaults softkey.

Figure 9 I/O configuration menu
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3 To change the IP address of the 9101, push the Host IP softkey.
The address field is highlighted.

4 Overwrite the entire IP address or select a field with the LEFT/RIGHT cursor 
keys, enter a new IP address and push ENTER.

5 For the change to take effect, switch off and on the 9101.

6 Ensure that your application on the PC addresses the 9101 using this IP 
address so that the two units can communicate with each other.

Changing the IP address of
the PC

For remote control of the 9101 Handheld Spectrum Analyzer from a PC, the IP 
address of that PC can be entered on the instrument.

1 Push the Mode key.

2 Select System > I/O Config.
The port configuration display appears, showing the current TCP/IP settings.

3 To change the IP address of the 9101, push the Target IP softkey.
The address field is highlighted.

4 Overwrite the entire IP address or select a field with the LEFT/RIGHT cursor 
keys, enter a new IP address and push ENTER.

5 Reboot the 9101 (that means, switch it off and on again) for the new 
settings to work.

Changing the IP port used
by the 9101

When the 9101 Handheld Spectrum Analyzer is to be controlled remotely from a 
PC, the PC must address the remote control application within the 9101 with an 
IP port number. The 9101 uses a default of 49200 which can be changed easily 
as follows:

1 Push the Mode key.

2 Select System > I/O Config.
The port configuration display appears, showing the current TCP/IP settings.

3 To change the IP port of the 9101, push the Port softkey.
The address field is highlighted.

4 Overwrite the entire IP address or select a field with the LEFT/RIGHT cursor 
keys, enter a new IP address and push ENTER.

5 Reboot the 9101 (that means, switch it off and on again) for the new 
settings to work.

The Back to Default button resets the parameter to its default value.
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Selecting user interface
colors

You can change the colors of some of the user interface elements in the color 
scheme menu. The available colors are shown in the color palette at the top of 
the display and in Table 14. Color 8 is not available for all user interface 
elements.

The colors of the traces, the grid and the limit lines can be modified as follows:

1 Push the Mode key.

2 Select System > Color Scheme.
The color scheme display appears (see Figure 10), showing the current color 
settings.

3 To change the color of a user interface element, push the appropriate 
softkey (Trace A, Trace B, Grid, or Limits Color).
The input field on the left is activated.

Table 14 Color palette in the 9101 user interface

Color number Color

1 black

2 grey

3 blue

4 green

5 violet

6 yellow

7 red

8 brown

Figure 10 Color scheme menu
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4 To select a new color, enter a number corresponding to the colors in the 
color palette and push the ENTER key, or use the UP/DOWN cursor keys to 
change the color.
The color field to the left of the input field changes according to the selec-
tion made.

5 Press softkey Last Mode to return to the measurement screen.
The new color scheme takes effect immediately.

Working with stored settings
The 9101 Handheld Spectrum Analyzer provides the capability of storing all the 
parameters for a particular measurement, allowing to recall these parameters 
whenever the measurement shall be repeated under the same conditions, and 
this includes the measurement mode. A large number of parameter sets can be 
stored under different names that allow fast and easy identification; each 
parameter set name may consist of up to 11 characters.

In addition to using these files of parameter sets on the same 9101, you can also 
transfer them to a PC for backup, easy modification and amendment using a 
standard text editor, or for use the same parameters on multiple 9101 instru-
ments. This is described in more detail in sections “Working with settings” on 
page 97 and “Managing files on the PC and on the 9101” on page 98.

Storing settings on the
9101

To store the current settings on the 9101, take the following steps:

1 Press hardkey RCL/STORE.
The trace memory menu appears.

2 Select the Settings menu softkey.
The settings memory menu is displayed.

3 Press Store Settings.
An input field appears (see Figure 11).
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4 Enter a new file name of up to 11 characters, and confirm with ENTER.
The current parameter settings are stored in this settings file and can be 
recalled at any time.

Using previously stored
settings

You can use settings previously stored in the memory of the 9101 by recalling the 
settings file.

1 Press hardkey RCL/STORE.
The trace memory menu appears.

2 Select the Settings menu softkey.
The settings memory menu is displayed.

3 Press Recall Settings.
An input field and a file selection box appear.

4 Select the desired settings file using the UP/DOWN cursor keys or enter an 
existing file name, and confirm with ENTER.
The current parameter settings are overwritten by those in the settings file 
and the measurement mode with the parameters stored in the file are 
assumed.

Figure 11 Recall settings menu
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Chapter 3 Spectrum Analysis Operation

This chapter describes the instrument’s functions that are specific to the spec-
trum analysis mode. Topics discussed in this chapter are as follows:

– “Selecting the measurement mode” on page 38

– “Changing the frequency settings” on page 38

– “Selecting RBW, VBW and SWT” on page 41

– “Setting up the level parameters” on page 41

– “Changing the input impedance” on page 44

– “Applying special functions on the signal” on page 44

– “Setting up the trace” on page 48

– “Storing and loading traces” on page 53

– “Special measurement functions” on page 55
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Selecting the measurement mode
The 9101 provides different measurement modes. To select the spectrum analysis 
mode, proceed as follows:

1 Push the MODE button.
The mode menu appears.

2 Select Spectrum Analysis.
The spectrum analysis main menu appears.

Changing the frequency settings

There are different methods to set the frequency range to be measured; the range 
can be expressed by either the start and stop frequencies (i.e. first and last 
frequencies on the display), or by center frequency and span (i.e. the center and 
the frequency range), or by other combinations of center frequency, span, start 
and stop frequencies. 

All four parameters are accessible in the Freq menu. On the main menu, 
however, only one of the above-mentioned combinations is shown, depending on 
the parameter last entered.

Figure 12 Frequency menu

NOTE

Changing a frequency parameter may affect an associated parameter.
Example: If you change the span to the maximum of 4 GHz, the start and stop 
frequencies are changed to 0 and 4 GHz, respectively.
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Setting start and stop
frequency

1 Push the CENT function key (or the Freq softkey in the main menu).
The vertical softkeys include Start and Stop softkeys.

2 Push the Start softkey.
An entry field appears, indicating the start frequency currently set and the 
step size for the UP/DOWN cursor keys.

3 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

4 Conclude the entry by pushing an enter key for the unit (GHZ or MHZ).
If the start frequency entered is lower than the stop frequency, the hori-
zontal axis will display the range from the new start to the stop frequency.
If the new start frequency is higher or equal to the stop frequency, the start 
frequency is used as the center frequency with zero span, i.e. the signal at 
the selected frequency will be shown in the time domain.

5 Push the Stop softkey and enter the frequency for the right end of the 
display.

You can also place softkeys for the start and stop frequencies available on the 
main menu by changing the frequency mode, see page 39.

Setting center frequency
and span

1 Push the CENT function key (or the Freq softkey in the main menu).
The vertical softkeys include Center and Span. An entry field appears, indi-
cating the center frequency currently set and the step size for the up/down 
cursor keys.

2 Enter a new frequency using the numeric keys, the cursor keys and the 
BACKSPACE key.

3 Conclude the entry by pushing an enter key for the unit (GHZ or MHZ).

4 Push the Span softkey and enter the frequency for the range from the left 
to the right end of the display.

You can also place softkeys for the center frequency and the span available on 
the main menu by changing the frequency mode, see section “Changing the main 
menu for different frequency parameters” below.

Changing the main menu
for different frequency

parameters

The main menu shows two softkeys for the definition of the frequency range on 
the display. Different methods exist to define the range as depicted above; you 
can configure these softkeys to one of the two allowable combinations as 
follows:

1 From the main menu, select Freq > Freq Mode.

2 Select the combination of softkeys that you want to see in the main menu 
(Start/Stop or Center/Span).

3 Return to the main menu by pushing the Main... softkey.
The main menu appears and displays the selected combination of keys.

Note that the description of the horizontal frequency axis changes with the 
selected parameter set.
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Viewing the complete
frequency band

To change the frequency range to the full bandwidth supported by the 9101, 
proceed as follows:

1 From the main menu, push the Freq softkey.
The frequency menu is displayed.

2 Push the Full Span softkey.
The leftmost frequency changes to 0 Hz and the rightmost frequency to 
4 GHz.

Performing measurements
in the time domain

Measurements on a selected center frequency can also be displayed in the time 
domain.

1 From the main menu, push the Freq softkey.
The frequency menu is displayed.

2 Push the Center softkey and enter the desired center frequency; close the 
input field by selecting the appropriate unit with one of the enter keys.

3 Push the Zero Span softkey.
The horizontal axis becomes the time axis. The scale width is identical to the 
sweep time. See Figure 13 on page 46 for an example.

Selecting the step size for
the frequency input

The center, start and stop frequencies can be set by either entering a new value 
with the numeric keys, or by using the arrow keys (UP, DOWN) to increase or 
decrease the current setting. The step size for an arrow keypress can be either 
automatically selected by the 9101, or manually adjusted.

Manually setting the frequency step size

1 From the main menu, select Freq. 

2 Push the FStep key.
The Freq Step entry field opens.

3 Enter a new frequency step value and close the entry field by pressing the 
appropriate enter determining the unit (GHZ/DBM for gigahertz, MHZ/DB/
µS for megahertz, KHZ/DBµV/MS for kilohertz, or ENTER for hertz).
The auto/manual selection switches to manual and the selected frequency 
step size is displayed on the softkey.

Setting the frequency step size selection to automatic

1 From the main menu, select Freq.

2 Push the FStep softkey several times until the “auto” selection is high-
lighted.
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Selecting RBW, VBW and SWT
The resolution bandwidth (RBW) is the 3 dB bandwidth of the IF filter for 
selecting the signal to be measured. The resolution bandwidth describes the 
ability of the spectrum analyzer to discriminate between adjacent signals of 
similar amplitude. Only signals spaced at a frequency of more than the RBW can 
be discriminated from one another.
The 9101 can be set to automatically select the resolution bandwidth, depending 
on the frequency span.

The video bandwidth (VBW) is the lowpass bandwidth over which several results 
for one frequency point are smoothened. The lower the video bandwidth, the 
smoother the signal curve and the less variations there are.
The 9101 can be set to select the video bandwidth automatically as a function of 
the resolution bandwidth.

The sweep time (SWT) determines how long it takes for a complete sweep over 
the measured frequency range (span).
The 9101 can be set to automatically select the sweep time, depending on RBW 
and VBW. If manually set, the sweep time should be selected long enough for the 
filtered signal to reach steady state. The 9101 will output an “UNCALibrated” 
warning if the sweep time is too low.

To set the resolution bandwidth, the video bandwidth or the sweep time, proceed 
as follows:

1 In the main menu, select the appropriate function softkey (RBW, VBW, or 
SWT).

2 Enter the value and complete the entry with the appropriate enter key for 
the unit, select a new value with the help of the UP/DOWN cursor keys, or 
switch to auto to leave the setting to the 9101.

Changing between automatic and manual mode

Push the appropriate function softkey (RBW, VBW, or SWT) several times until 
the desired selection (auto or manual) is highlighted.

Setting up the level parameters
The accuracy and the dynamic range between the measured signal and the noise 
floor depend on the proper setting of the level settings. These consist of the 
reference level and the attenuation.

The reference level basically determines the level at the top of the display. The 
vertical axis is divided into eight horizontal lines; you can adjust the scale (which 
defaults to 10 dB per line) to your preferences.

The attenuation setting can be coupled to automatically follow the reference 
level setting. For reference levels of –20 dBm and lower, the attenuation is set to 
10 dB; the maximum attenuation is 50 dB.
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Attenuation or gain due to external coupling can be compensated by frequency-
dependent coupling factors, so that the displayed measurement values reflect 
the power at the device under test.

Setting the reference level 1 In the main menu, push the Ref. Level softkey. Alternatively, push the REF 
function key.
The reference level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. If the attenu-
ation option is set to automatic, the new attenuation level will be shown 
with the Attenuation softkey.

Setting the hardware
attenuation

1 In the main menu, push the Attenuation softkey.
The Attenuation input field opens.

2 Enter a new attenuation value in the range 0 to 50 dB (in 10 dB steps) and 
close the input field with one of the enter keys, or use the UP/DOWN arrow 
keys to select the attenuation value in the range 10 to 50 dB.
If the attenuation value is changed, the attenuation option will change to 
“manual”.

Changing the vertical
scale

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-2-5 steps as follows:

1 From the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

NOTE

The attenuation value of 0 dB can be set only with the numeric keys to avoid 
accidental deactivation. The 0 dB setting should be selected carefully because 
too high input levels at the input may damage the instrument.

NOTE

For precision measurements, the input level subtracted by the attenuation 
should not exceed –23 dBm.
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Selecting the level unit for
input and output

1 From the main menu, select Level > Units.

2 Push the required unit softkey; available choices are dBm, dBµV, dBmV and 
dBV.

Compensating gains and
losses

If the device under test is connected to the 9101 Handheld Spectrum Analyzer 
via an amplifier or a device attenuating the signal, such as an antenna or a long 
cable, the measurement results are wrong by the gain or loss factor. This factor 
may be a constant or even frequency dependent.

To view the correct measurement results, the gain or loss can be compensated. 
The 9101 can even compensate a frequency-dependent factor; a correction curve 
or table can be entered on an external PC using the 91xx Data Exchange Soft-
ware and loaded to the 9101. The section “Defining and loading external coupling 
parameters” on page 95 explains this part in more detail.

Enabling external device
compensation

Once correction values are stored in the 9101, these can be selected and acti-
vated as follows:

1 From the main menu, select Level > Ext. Dev. Memory.

2 Push Recall Ext. Dev. Comp.
A pull-down menu appears with a list of names for the compensation tables 
available in the 9101.

3 Select a compensation table using the UP/DOWN cursor keys and confirm 
your choice with the ENTER key.
Compensation is still off, but the 9101 changes automatically to the Level 
menu.

4 Push the Ext. Dev. Comp. softkey until “On” is highlighted.
The text “Ext. Dev.”, together with the name of the file loaded, appears on 
the upper left-hand corner of the results display.

Turning external device
compensation off

1 From the main menu, select the Level menu.

2 Push Ext. Dev. Comp. until “Off” is highlighted.
The text “Ext. Dev.” to the left of the results display disappears.

NOTE

Steps 1 thru 3 may be omitted if a file had been previously selected. In this 
case, select the Level menu and continue with step 4.
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Deleting files for external
device compensation

You can delete files containing compensation parameters as follows:

1 From the main menu, select Level > Ext. Dev. Memory.

2 a. To delete an individual compensation file from the 9101 memory, push 
Delete Ext. Dev. Comp. Select a file name and push the ENTER key.
The compensation file is deleted from the list. Note that there will be no 
warning; once you have selected and requested a file to be deleted, this will 
occur immediately.

b. To delete all the compensation files from the 9101, push Delete All and 
confirm with the ENTER key.
All compensation files are deleted.

Changing the input impedance
Most RF applications are using an impedance of 50 Ω; other applications such 
as cable TV apply 75 Ω. The 9101 is designed with an input impedance of 50 Ω; 
it can, however, be used for testing a device with an impedance of 75 Ω by using 
the software impedance switch. The measurement results from the 50 Ω input 
are recalculated to fit the different impedance.

On the 9101, simply select the correct impedance value so that the 9101 can 
translate the internal measurement values to the power before the coupler.

1 Connect the device under test to the 9101 Handheld Spectrum Analyzer. 

2 From the main menu, select the Level menu.

3 In the vertical menu, select the impedance of the device, that means select 
Impedance: 50 Ω or Impedance: 75 Ω, respectively.
New measurement results are presented with the new impedance value 
taken into account. In addition, if the impedance is changed to 75 Ω and the 
power had been displayed in dBm, the new measurements are shown in 
dBµV. If the impedance is changed to 50 Ω and the power had been 
displayed in dBµV, the new measurements are shown in dBm.

Applying special functions on the signal
This section shows how the measurement can be triggered, how the number of 
measurements can be limited and how you can listen to the sound of the demod-
ulated signal.

NOTE

Signal reflections on the cable between the 50 Ω and the 75 Ω device affect 
the measurement accuracy of the 9101 Handheld Analyzer. For more accurate 
results, Willtek recommends using an impedance converter; such a converter 
will cause attenuation affecting the results. This attenuation can be compen-
sated as explained in section “Compensating gains and losses” on page 43.
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Using a signal trigger The 9101 can either start signal analysis at a random point in time, or start the 
measurement when a given signal threshold is passed. Starting measurements 
depending on the actual signal level is only supported in zero span mode.

Selecting untriggered signal analysis

1 From the main menu, enter the sweep menu by pushing Freq > Trigger.
The Trigger menu appears.

2 Push the Free Run softkey.
The softkey is highlighted and the 9101 is ready for measurements at 
random times.

Selecting a trigger threshold in the RF signal

1 From the main menu, enter the sweep menu by pushing Freq > Trigger.
The Trigger menu appears.

2 Push the Video softkey.
The Video softkey is highlighted and an input field for the trigger level 
appears.

3 Enter the trigger level (in dBm) and complete the entry by pushing either the 
GHZ/DBM or the ENTER key.
The trigger threshold is displayed at the power axis; the symbol also indi-
cates the slope (direction in which the signal passes the threshold to start 
the measurement).

4 If necessary, change the slope between positive and negative direction by 
pushing the Slope softkey.
The active slope is indicated at the power axis, see Figure 13.

NOTE

The Video trigger is available in zero span mode only, otherwise the softkey 
description is grayed out.
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Performing a limited
number of measurements

The 9101 can run measurements continuously or a defined number of times. 
Limiting the number of measurements can be useful for statistical analyses.

1 From the main menu, select Freq > Sweep.
The sweep menu appears.

2 Select the trigger mode: Push Cont. for continuous measurements or Single 
for a limited number of measurements.
The selected trigger mode is highlighted.

3 To enter the number of measurements, push the Single Count softkey, 
enter a number in the range from 1 to 1000 and press the ENTER key.
If Trigger Mode is set to Single, the 9101 performs the defined number of 
measurements and enters Hold mode.

– To restart single-mode measurements, push the HOLD/RUN hardkey or the 
Single softkey.

– To stop a continuous measurement, push the HOLD/RUN key. Push it again 
to resume measurements.

Figure 13 Triggered measurement (in the time domain)
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Demodulating an AM or
FM signal

The 9101 has the ability to demodulate an AM (amplitude modulation) or FM 
(frequency modulation) signal and to output the signal at the built-in loud-
speaker. The signal should have a signal strength of at least –50 dBm; the 
demodulation bandwidth is about 10 kHz.

The 9101 can be set to either demodulate one signal permanently, or to toggle 
between the different frequencies. When set to permanently demodulate one 
signal, the 9101 demodulates the signal at the center position. 

When the 9101 is set to toggle between frequencies, it uses the marker frequen-
cies (marker M1 is enabled if not already active). After performing and displaying 
a new measurement, the 9101 demodulates and outputs the received signal for 
a short duration. This duration is selectable in the range from 100 milliseconds 
to 10 seconds. The 9101 demodulates the carrier at the marker position; the 
demodulated signal is output for the selected duration. If more than one marker 
is active, demodulation is resumed at the next marker frequency and so on until 
a piece of the signal at all active markers has been demodulated. The process 
starts anew with a new measurement.

The speaker volume can be selected as a percentage of the speaker’s maximum 
capacity.

1 Set a marker to the center frequency of the signal to be demodulated (see 
section “Setting up the trace” on page 48).

2 From the main menu, select Freq > Demod.
The demodulation menu appears.

3 Select the demodulation method (AM, FM, or Off).
The selected method is highlighted.

4 Choose between permanent demodulation and intermittent demodulation at 
multiple markers by pressing the respective Demod softkey.

5 If demodulation at marker is selected, you can change the duration of the 
output of the demodulated signal: 

– Push the Duration softkey. 
The Demod Duration input field opens.

– Enter the new duration using the numeric keys. Conclude the entry with 
a push on one of the enter keys with the appropriate unit: push KHZ/
DBµV/MS for milliseconds or ENTER for seconds.

6 To adjust the speaker volume, push the Volume softkey, enter a new volume 
level from 0 to 100% and press ENTER.
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Setting up the trace

The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9101 and loaded to one of the trace views (see section “Storing 
and loading traces” on page 53).

The 9101 samples many measurements for each frequency point. With the 
detector functions, you can define the method to select which of the samples is 
displayed.

Selecting the trace mode The 9101 has five different modes to display a trace:

– In Actual mode, the 9101 shows a complete new measurement in each trace. 
Subsequent traces are independent of each other.

– In Hold mode, the last measurement is kept on the display; measurements 
continue but are not displayed.

– In Max hold mode, the 9101 takes new measurements and, for each 
frequency point, compares the new measurement with the previous result. If 
the new measurement value is higher than the previous result, the new 
measurement value becomes the new result value; otherwise the old result 
value is kept. This way, the highest result since the start of the Max hold 
measurement (or a parameter change) is kept and displayed.

– Similarly, in Min hold mode, the 9101 takes new measurements and 
compares the new measurement with the previous result. If the new 
measurement value is lower than the previous result, the new measurement 

Figure 14 Example of two traces
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value becomes the new result value; otherwise the old result value is kept. 
This way, the lowest result since the start of the Min hold measurement (or a 
parameter change) is kept and displayed.

– In Average mode, the new measurement and previous ones are averaged for 
each frequency point displayed. The 9101 uses a recursive algorithm for 
averaging.

To select whether you want to view an actual measurement, stop and hold the 
last measurement, see the lowest or highest data for each frequency or an 
average value, proceed as follows:

1 In the main menu, select Trace.

2 Select the trace you want to modify (Trace A or Trace B) using the hori-
zontal softkeys.

3 Select the trade mode with the vertical softkeys (Actual, Hold, Max hold, 
Min hold, Average).
The trace mode is shown at the left-hand side of the vertical axis, e.g. 
A (ACT).

NOTE

For fastest valid results it is advisable to briefly activate the Actual mode 
before selecting any other mode.

NOTE

When the trace is on hold, the measurement and failure counters continue 
counting. A second trace, if active, continues updating.
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Turning the second trace
on and off

You can define two different trace views, e.g. one with the actual values and one 
with the maximum values. While the first view (Trace A) is always active, the 
second can be switched off. The functions of turning Trace B on or off and 
selecting the trace mode are combined as follows:

1 From the main menu, select Trace > Trace B.

2 To turn trace B on, select the trace mode (Actual, Hold, Max hold, Min 
hold, or Average). To turn trace B off, select Off.
If activated, the trace mode is displayed left to the vertical axis, e.g. 
B (MAX).

Defining the number of
measurements for

averaging

When the trace mode is set to averaging, it may be useful to adjust the number 
of measurements over which the 9101 averages the results. The average count 
value that can be defined in the trace menus applies to both traces alike.

The 9101 uses a recursive algorithm in which a new result is added to the older 
averages with a weighting factor; the description below indicates how to change 
this weighting factor.

1 Select the trace menu (select Trace > Trace A or Trace B from the main 
menu).

2 Push the Average Count softkey.
The Average input field opens.

3 Enter the number of measurements over which to average the results, in the 
range from 2 to 128.

4 Push the ENTER key.
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Selecting the detection
method

For each new measurement, the 9101 selects one or two values from a number 
of measurements for each frequency value. The method is user-definable; the 
following methods are available (see also Figure 15): 

– Positive/negative peak: Both the largest and smallest values are taken and 
displayed as a vertical bar.

– Positive peak: Only the largest value is displayed. 

– Negative peak: The smallest value is shown.

– Sample: A measurement value is randomly picked.

The detection method applies to both traces. – Select the detection method as 
follows:

1 From the main menu, select Trace > Detect.

2 Select the trace method from the Detector section of the vertical softkeys.
The selected detection method is indicated at left-hand side of the display.

Copying traces inside the
9101

You can copy an actual measurement from trace A to trace B or vice versa; this 
way you can keep the last measurement results on the screen and at the same 
time continue measuring or change the settings of the 9101 Handheld Spectrum 
Analyzer. The previous results in the target trace will be erased; the target trace 
will assume hold mode. 

To copy the measurement data from one trace to another, proceed as follows:

1 From the main menu, select Trace > Trace Function.

2 To copy the measurement results in trace A to trace B, press Copy A – > B.
To copy results from trace B to trace A, press Copy B – > A.

Figure 15 Trace detectors
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Figure 16 Trace function menu

NOTE

If you first press Copy A – > B, then Copy B – > A (or vice versa), both 
traces will display the same results and will be in hold mode.
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Storing and loading traces

The 9101 provides the capability to store up to 99 traces in the 9101 and load 
them again at random. The stored trace can then be examined or compared to a 
recent measurement. In addition, stored traces can also be transferred to a PC 
using the 91xx Data Exchange Software which is being delivered with the 9101.

Storing a trace You can store either trace A or B. Any trace can be stored under a name with up 
to 11 characters. The procedure to enter text in alphanumerical input fields is 
explained in section “Entering numbers and text” on page 18. Note that along 
with the trace, the instrument settings such as frequency range, level range and 
markers are stored.

1 From the main menu, select Trace > Trace Memory.

2 Push either Store A or Store B, depending on which trace you want to save 
to the internal memory.
An input field opens, allowing you to enter a name for the trace. Below the 
input field, a list of existing traces is indicated.

3 Enter a name for the trace. To use a modified trace name, you can move the 
cursor to a suitable trace name with the UP/DOWN cursor keys. The 
selected trace name also appears in the input field; use the LEFT/RIGHT 
cursor keys to move the cursor to the appropriate position within the trace 
name to enter additional characters or delete existing ones.

4 Confirm your choice by pushing the ENTER key.
The input field closes and the trace is stored under the selected name.

Figure 17 Trace A menu
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Reusing a trace name An existing trace stored under a name cannot be overwritten by another trace 
using the same name, so the old trace will first have to be deleted.

Reloading a trace 1 From the main menu, select Trace > Trace Memory.

2 Push either Recall A or Recall B, depending on which trace you want to 
load from the internal memory.
An input field opens, allowing you to enter the trace name. Below the input 
field, a list of existing traces is indicated.

3 Enter the name of the trace to load, or choose one with the UP/DOWN 
cursor keys.

4 Confirm your choice with the Enter key.
The input field closes and the trace is displayed.

Deleting a trace Stored traces can be deleted. Note that there will be no warning; once you have 
selected and requested a file to be deleted, this will occur immediately.

1 From the main menu, select Trace > Trace Memory.

2 Push Delete Trace.
An input field for the name of the trace to be deleted appears, together with 
a trace selection box.

3 Select the trace to be deleted using the UP/DOWN cursor keys. Alterna-
tively, enter the trace name with the numeric keys.

4 Confirm your choice by pushing the ENTER key.
The trace is deleted from the trace list.

5 Select another trace for deletion, or push ESCAPE to leave the entry field 
and the trace selection box.

Deleting all traces Instead of deleting traces individually, all traces can be deleted in one step. You 
will be asked to confirm this step.

1 From the main menu, select Trace > Trace Memory.

2 Push Delete All.
A query appears, asking you to confirm your selection.

3 Push the ENTER key to have all traces deleted.
The query disappears. All traces are deleted.

NOTE

Along with the trace, the 9101 also loads the settings that were used when 
the trace was saved. These will overwrite the current settings such as fre-
quency range, reference level and markers.
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Storing and loading
instrument settings

To store or load the instrument settings including frequency range, level setting 
and markers, proceed as described in sections “Storing a trace” and “Reloading a 
trace”.

Special measurement functions
Within spectrum analysis mode, three different frequency-selective types of 
power measurements are supported: 

– Channel power

– Adjacent channel power ratio (ACPR)

– Occupied bandwidth (OBW)

These are similar to the measurement types in channel power mode (see chapter 
“Channel Power Operation” on page 59), without the restrictions that the 
channel power mode poses with predefined parameters such as span and reso-
lution bandwidth.

Channel power This measurement includes the power of the selected channel. A channel is 
defined by center frequency and channel width (not the span in this case); see 
“Changing the channel width” on page 57. 

The 9101 displays the numerical result of the channel power measurement on the 
top-left. The measured bandwidth is indicated graphically with bandwidth 
boundaries shown in red.
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Adjacent channel power
ratio (ACPR)

ACPR is the relation between the power transmitted in a neighboring (upper or 
lower) channel and that in the communication channel used. The measurement 
can be used to assess the quality of the modulator and the transmitter; the 
higher the result, the worse the transmitter because transmission in other chan-
nels may interfere with another ongoing communication. 

The 9101 determines the adjacent channels by the channel width and channel 
spacing input parameters (see sections “Changing the channel spacing” and 
“Changing the channel width” on page 57). It displays the numerical results of 
the adjacent channel power ratio measurements for the left (lower) and right 
(upper) channels on the top-left. The measured bands are indicated graphically 
with bandwidth boundaries shown in red.

Occupied bandwidth
(OBW)

The occupied bandwidth identifies the frequency range into which a given 
percentage of the signal power falls. The frequency range is not necessarily 
symmetric around the center frequency but is selected so that the bandwidth to 
hold a certain user-defined OBW percentage is minimized. See section 
“Changing the occupied bandwidth percentage” on page 58.

OBW is indicated as an absolute value in the upper left-hand corner of the 
display, together with the OBW percentage; marker M1 and delta marker D2 are 
assigned the lower and upper frequencies characterizing the frequency range. 
The power is measured over three times the normal channel bandwidth. The red 
boundary indicators mark the normal channel bandwidth as selected in the 
channel system menu.
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Selecting the
measurement type

To select the type of measurement within spectrum analyzer mode, proceed as 
follows:

1 From the spectrum analysis main menu, select Marker > Measure.

2 Select a measurement type using the vertically aligned function softkeys in 
the Measure section.
The numerical result for the selected measurement appears in the upper 
left-hand corner of the display.

Switching special
measurement functions

off

To return to normal spectrum analyzer measurements without the special 
measurement functions, simply press the button of the selected measurement 
type again. This will deactivate the special measurements.

Changing the channel
width

The channel width is the bandwidth which the transmission is expected to 
occupy. It can be set for the channel power and ACPR measurements as follows:

1 From the spectrum analysis main menu, select Marker > Measure.

NOTE

If the resolution bandwidth selected is high and the occupied bandwidth very 
low, there may be rare cases in which all the power for the occupied band-
width is mapped to one point in the spectrum display. In such a case, the 9101 
displays “N/A” (not available) instead of the bandwidth, and the markers usu-
ally indicating the bandwidth boundaries are invisible.
Increase the occupied bandwidth or decrease the resolution bandwidth to 
receive results.
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2 Press Channel Width, enter a new value and press the respective entry key 
for the unit.
The new measurement bandwidth for channel power and ACPR is displayed 
with the softkey.

Changing the channel
spacing

The channel spacing is distance in frequency between two adjacent channels. It 
can be set for the ACPR measurements as follows:

1 From the main menu, select Marker > Measure.

2 Press Channel Spacing, enter a new value and press the respective entry 
key for the unit.
The new channel spacing for ACPR is displayed with the softkey.

Reading the channel
power

In addition to the display elements explained on page 10, the channel power 
mode also includes a large display of the channel power, along with the channel, 
resolution bandwidth and sweep time. Please see the graphs on page 55 and the 
following for typical measurements. 

Changing the occupied
bandwidth percentage

OBW measurements identify the frequency range in which a certain percentage 
of the transmit power falls. The percentage value can be changed as follows:

1 From the spectrum analyzer main menu, select Marker > Measure. 

2 Press % OBW and enter a new percentage value in the range from 5 to 99.

3 Push ENTER to close the input field.
If the OBW measurement type is selected, the new OBW percentage value is 
indicated in the upper left-hand corner of the display.
The 9101 recalculates the frequency range based on the new percentage 
value.

Changing general analyzer
parameters

For the channel power, ACPR and OBW measurements within the spectrum 
analyzer mode, the general settings such as center frequency, span, resolution 
bandwidth, can be changed as usual. A one-button approach to adjusting span, 
resolution bandwidth, video bandwidth, detector and trace mode is described 
below.

1 From the spectrum analyzer main menu, select Marker > Measure. 

2 Press Adjust Settings.
Resolution bandwidth and video bandwidth are automatically set to 
optimum values (auto mode). The trace detector is set to sample and the 
trace mode is set to actual.
If channel power measurements are selected, the span is set to 120% of the 
selected channel width. For ACPR measurements, the span is adjusted to 
1.2 × channel width + 2 × channel spacing. The OBW span is three times the 
channel width.
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Chapter 4 Channel Power Operation

This chapter describes the instrument’s functions in channel power measurement 
mode. Topics discussed in this chapter are as follows:

– “About measurement modes and types” on page 60

– “Selecting the measurement mode” on page 62

– “Operating in channel power mode” on page 63

– “Reading the channel power” on page 64

– “Changing the occupied bandwidth percentage” on page 64

– “Working with communication systems and frequency settings” on page 64

– “Setting up the level parameters” on page 67

– “Changing the input impedance” on page 70

– “Setting up the trace” on page 71

– “Storing and loading traces” on page 74
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About measurement modes and types
The 9101 provides different measurement modes, e.g. spectrum analysis and 
channel power measurements. The channel power mode allows you to measure 
the radiated power within a certain frequency band with a single button press. 
This mode reduces the complexity of all the setup possibilities for defined 
communication systems. Several communication systems are predefined in the 
9101 or can be downloaded from a PC using the 91xx Data Exchange Software; 
see section “Managing communication systems for channel power measure-
ments” on page 96 for more details.

Within channel power mode, three different frequency-selective types of power 
measurements are supported: 

– Channel power

– Adjacent channel power ratio (ACPR)

– Occupied bandwidth (OBW)

These modes are available both in channel power and in spectrum analysis mode; 
in channel power mode, however, measurements on communication systems 
using different frequency channels are easier to perform with the predefined 
channel spacing and bandwidth.

Channel power This measurement includes the power of the selected channel. The channel can 
be selected in the main menu whereas parameters like channel width (the 
measurement bandwidth) and channel spacing can be viewed and changed in 
the channel system menu.

The 9101 displays the numerical result of the channel power measurement on the 
top-left. The measured bandwidth is indicated graphically with bandwidth 
boundaries shown in red.
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Adjacent channel power
ratio (ACPR)

ACPR is the relation between the power transmitted in a neighboring (upper or 
lower) channel and that in the channel used for communication. The measure-
ment can be used to assess the quality of the modulator and the transmitter; the 
higher the result, the worse the transmitter because transmission in other chan-
nels may interfere with another ongoing communication. 

The 9101 displays the numerical results of the adjacent channel power ratio 
measurements for the left (lower) and right (upper) channels on the top-left. The 
measured bands are indicated graphically with bandwidth boundaries shown in 
red.

Occupied bandwidth
(OBW)

The occupied bandwidth identifies the frequency range into which a given 
percentage of the signal power falls. The frequency range is not necessarily 
symmetric around the center frequency but is selected so that the bandwidth to 
hold a certain user-defined OBW percentage is minimized. See section 
“Changing the occupied bandwidth percentage” on page 64.

OBW is indicated as an absolute value in the upper left corner of the display, 
together with the OBW percentage; marker M1 and delta marker D2 are assigned 
the lower and upper frequencies characterizing the frequency range. The power 
is measured over three times the normal channel bandwidth. The red boundary 
indicators mark the normal channel bandwidth as selected in the channel system 
menu.
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Selecting the measurement mode
To select the channel power measurement mode, proceed as follows:

1 Push the MODE button.

2 Select the channel power mode.
The main menu of the channel power mode appears. If you select a new 
mode, all parameters are set to the values from when the mode was last 
active. If, however, you resume the last active mode, the measurements 
continue without any changes to the parameters.

To select the type of measurement within the channel power mode, proceed as 
follows:

1 Push the Measure softkey.

2 Select a measurement type using the vertically aligned function softkeys 
(channel power, ACPR, or OBW).

NOTE

If the resolution bandwidth selected is high and the occupied bandwidth very 
low, there may be rare cases in which all the power for the occupied band-
width is mapped to one point in the spectrum display. In such a case, the 9101 
displays “N/A” (not available) instead of the bandwidth, and the markers usu-
ally indicating the bandwidth boundaries are invisible.
Increase the occupied bandwidth to receive results.
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Operating in channel power mode

This mode provides a measurement of the integral power within a given band-
width. The measurement mode can be selected as desribed on page 62.

In channel power mode, the frequency parameters, filters and sweep time cannot 
be selected individually. Instead, a communication system can be selected or 
defined in which the 9101 shall measure the channel power; the frequency 
parameters are stored with the communication system settings.

A few communication systems such as GSM are predefined in the 9101. More 
predefined system settings are available in the 91xx Data Exchange Software and 
can be downloaded to the 9101. In addition, the settings for an alternative 
communication system can be defined by the user, stored in the 9101 and 
recalled for channel power measurements.

NOTE

Adjacent Channel Power Ratio (ACPR) measurements are available only in 
those communication systems where the channel bandwidth does not exceed 
the channel spacing; otherwise, the measurement range of the adjacent 
channel would overlap with that in the selected channel.
As an alternative, use the ACPR measurements within the spectrum analysis 
mode (page 56).

Figure 18 Example of a channel power measurement
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Reading the channel power
In addition to the display elements explained on page 11, the channel power 
mode also includes a large display of the channel power, along with the channel, 
resolution bandwidth and sweep time. In the example in Figure 18 on page 63, 
the 9101 indicates the frequency range over which the channel power is 
measured between red vertical bars.

Changing the occupied bandwidth percentage
OBW measurements identify the frequency range in which a certain percentage 
of the transmit power falls. The percentage value can be changed as follows:

1 From the channel power main menu, select Channel System. 

2 Press % OBW and enter a new percentage value in the range from 5 to 99.

3 Push ENTER to close the input field.
If the OBW measurement type is selected, the new OBW percentage value is 
indicated in the upper left-hand corner of the display.
The 9101 recalculates the frequency range based on the new percentage 
value.

Working with communication systems and frequency settings

Selecting a
communication system on

the 9101

You can activate communication system settings that are stored in the 9101 as 
follows:

1 In the main menu of the channel power mode, select Ch. System > System 
Memory.
The system memory menu appears.

2 Push Recall System. 
A scroll box appears, showing the available communication systems. Enter 
the system name as stored in the 9101, or move the UP/DOWN cursor keys 
to move the cursor to the system to be measured.

3 Push ENTER to confirm.
The input field and the scroll box disappear and the spectrum of the selected 
band is measured. The channel power of the first channel is displayed in the 
upper left-hand corner.

NOTE

The occupied bandwidth can also be changed from within the Measure menu.
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The 9101 comes installed with the following preinstalled communication 
systems:

Setting up a new
communication system

A new communication system can be defined in terms of frequency range, 
channel bandwidth and spacing, and channel numbering; channels can then be 
addressed easily by their channel number rather than the carrier or center 
frequency. Setting up a new communication system can be done as follows:

1 In the main menu, select Ch. System.
The channel system menu appears.

2 Push First Channel and enter the first channel number in use by the 
system, then close the input field using the ENTER key.

3 Push Last Channel to enter the number of the last channel in use by the 
system; close the input field with the ENTER key.

4 Push Channel Width to change the measurement bandwidth; ensure to 
select the right unit (e.g. kHz).

5 Select the Channel Spacing softkey, enter the spacing between channel 
numbers and close the input field with the ENTER key for the appropriate 
frequency unit.

6 Push the 1st Ch. Center softkey and enter the carrier frequency for the first 
channel in use (channel number defined with the first softkey). Close the 
input field using the enter key for the appropriate unit (e.g. MHZ).

7 For occupied bandwidth (OBW) measurements, select % OBW and enter the 
percentage value. Confirm the value with the ENTER key.

8 Push System Memory > Store System, enter a new name for the system 
and press the ENTER key.

Table 15 Preinstalled communication systems

System name System 
meaning

Channel 
numbers

Frequency 
range

DCS1800-DL GSM 1800, 
downlink

512 thru 885 1805.2 thru 
1879.8 MHz

PGSM900-DL P-GSM 900, 
downlink

0 thru 124 935.0 thru 
959.8 MHz

PCS1900-DL GSM 1900, 
downlink

512 thru 810 1930.2 thru 
1989.8 MHz

WCDMA-DL UMTS,
downlink

10562 thru 
10838

2112.4 thru 
2167.6 MHz

WCDMA-UL UMTS, uplink 9612 thru 9888 1922.4 thru 
1977.6 MHz

WLAN Wireless LAN to 
the IEEE 802.11 
standard

1 thru 13 2412 thru 
2472 MHz
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Deleting a communication
system

To delete a the communication system settings stored on the 9101, take the 
following steps.

1 From the main menu, select Ch. System > System Memory.
The system memory menu appears.

2 Push the Delete System softkey.
A scroll box with the list of available communication systems appears.

3 Select the system settings to be deleted by moving the UP/DOWN cursor 
keys to the respective system settings name, and confirm with Enter.
The system settings are deleted from the list.

4 Push ESCAPE to return to close the input field and the scroll box.

Deleting all
communication systems

You can clean up previously stored communication systems and easily delete all 
of them, including those that were originally delivered with the 9101.

1 From the main menu, select Ch. System > System Memory.
The system memory menu appears.

2 Push the Delete All softkey.
A box appears, asking to confirm that you want to delete all the communi-
cation system settings.

3 Push ENTER to confirm deletion or ESC to prevent the 9101 from deleting 
all the communication systems.
If confirmed, all the communication systems are deleted, that means the list 
of communication systems will be empty.

Undeleting default
communication systems

If you have deleted communication systems that were delivered with the 9101, 
you can restore these system settings. 

1 From the main menu, select Ch. System > System Memory.
The system memory menu appears.

2 Push the Restore Default Systems softkey.
The 9101 creates all the communication systems that were originally deliv-
ered with the 9101.

NOTE

Existing systems cannot be overwritten; you must delete a system first.

If you delete a predefined system that is delivered with the 9101, it can be 
restored as depicted in section “Undeleting default communication systems” 
on page 66.
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Using the 91xx Data
Exchange Software with
communication systems

With the 91xx Data Exchange Software, more communication systems can be 
defined, loaded to the 9101 and selected for use. See section “Managing commu-
nication systems for channel power measurements” on page 96 for more infor-
mation.

Defining the frequency
span

The 9101 can display either the full spectrum used by the system, or the channel 
to be measured. Select the frequency span as desired:

In the main menu, select either Full System or Single Channel.
If Full System is selected, the full frequency band as defined for the commu-
nication system is displayed. If the Single Channel softkey has been pushed, 
only the frequency range of the currently selected channel is shown.

Changing the channel 1 On the main menu, push the Channel softkey.
The Channel input field opens.

2 Enter the desired channel number within the communication system at 
hand, or select the channel number with the UP/DOWN cursor keys.

3 Push ENTER to confirm.
The channel power for the selected channel is indicated in the upper left-
hand corner.

Changing the sweep time
The sweep time (SWT) determines how long it takes for a complete sweep over 
the measured frequency range (span).
By default, the 9101 automatically selects the sweep time depending on other 
measurement parameters such as the span. In some cases it may be an advantage 
to manually select a different sweep time. This is the case with pulsed signals 
where a longer sweep time may increase the measurement accuracy. If manually 
set, the sweep time should be selected long enough for the filtered signal to 
reach steady state. The 9101 will output an “UNCALibrated” warning if the sweep 
time is too low.

To change the sweep time in channel power mode, proceed as follows:

1 From the main menu, select Measure.

2 Push the SWT softkey.

3 Enter the new sweep time and confirm with the appropriate enter key for 
the unit.

Setting up the level parameters
The accuracy and the dynamic range between the measured signal and the noise 
floor depend on the proper setting of the level settings. These consist of the 
reference level and the attenuation.
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The reference level basically determines the level at the top of the display. The 
vertical axis is divided into eight horizontal lines; you can adjust the scale (which 
defaults to 10 dB per line) to your preferences.

The attenuation setting can be coupled to automatically follow the reference 
level setting. For reference levels of –20 dBm and lower, the attenuation is set to 
10 dB; the maximum attenuation is 50 dB.

Attenuation or gain due to external coupling can be compensated by frequency-
dependent coupling factors, so that the displayed measurement values reflect 
the power at the device under test.

Setting the reference level 1 In the main menu, push the Ref. Level softkey. Alternatively, push the REF 
function key.
The reference level input field opens.

2 Enter the new reference level either using the numeric keys, closing the 
input field with the appropriate enter key, or with the UP/DOWN arrow 
keys.
The new reference level appears at the top of the vertical axis. If the attenu-
ation option is set to automatic, the new attenuation level will be shown 
with the Attenuation softkey.

Setting the hardware
attenuation

1 In the main menu, push the Attenuation softkey.
The Attenuation input field opens.

2 Enter a new attenuation value in the range 0 to 50 dB (in 10 dB steps) and 
close the input field with one of the enter keys, or use the UP/DOWN arrow 
keys to select the attenuation value in the range 10 to 50 dB.
If the attenuation value is changed, the attenuation option will change to 
“auto”.

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

NOTE

The attenuation value of 0 dB can be set only with the numeric keys to avoid 
accidental deactivation. The 0 dB setting should be selected carefully because 
too high input levels at the input may damage the instrument.

NOTE

For precision measurements, the input level subtracted by the attenuation 
should not exceed –23 dBm.
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Changing the vertical
scale

The scale for the vertical axis (power) can be changed in the range from 1 to 
20 dB per division (vertical line in the displayed grid) in 1-2-5 steps as follows:

1 From the main menu, select Level.

2 Push the Scale softkey.
The Scale input field opens.

3 Select a new scale by entering a new number of dB per division numerically 
and pressing the ENTER or MHZ/DB/µS key, or by pushing the UP/DOWN 
cursor keys.

Selecting the level unit for
input and output

1 From the main menu, select Level > Units.

2 Push the required unit softkey; available choices are dBm, dBµV, dBmV and 
dBV.

Compensating gains and
losses

If the device under test is connected to the 9101 Handheld Spectrum Analyzer 
via an amplifier or a device atttenuating the signal, such as an antenna or a long 
cable, the measurement results are wrong by the gain or loss factor. This factor 
may be a constant or even frequency-dependent.

To view the correct measurement results, the gain or loss can be compensated. 
The 9101 can even compensate a frequency-dependent factor; a correction curve 
or table can be entered on an external PC using the 91xx Data Exchange Soft-
ware and loaded to the 9101. Section “Defining and loading external coupling 
parameters” on page 95 explains this part in more detail.

Enabling external device
compensation

Once correction values are stored in the 9101, these can be selected and acti-
vated as follows:

1 From the main menu, select Level > Ext. Dev. Memory.

2 Push Recall Ext. Dev. Comp.
A pull-down menu appears with a list of names for the compensation tables 
available in the 9101.

3 Select a compensation table using the UP/DOWN cursor keys and confirm 
your choice with the ENTER key.

4 Select the Level menu and push the Ext. Dev. Comp. softkey until “On” is 
highlighted.
The text “Ext. Dev.” appears to the left of the results display.

Turning external device
compensation off

1 From the main menu, select the Level menu.

2 Push Ext. Dev. Comp. until “Off” is highlighted.
The text “Ext. Dev.” to the left of the results display disappears.
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Deleting files for external
device compensation

You can delete files containing compensation parameters as follows:

1 From the main menu, select Level > Ext. Dev. Memory.

2 a. To delete an individual compensation file from the 9101 memory, push 
Delete Ext. Dev. Comp. Select a file name and push the ENTER key.
The compensation file is deleted from the list. Note that there will be no 
warning; once you have selected and requested a file to be deleted, this will 
occur immediately.
b. To delete all the compensation files from the 9101, push Delete All and 
confirm with the ENTER key.
All compensation files are deleted.

Changing the input impedance
Most RF applications are using an impedance of 50 Ω; other applications such 
as cable TV apply 75 Ω. The 9101 is designed with an input impedance of 50 Ω; 
it can, however, be used for testing a device with an impedance of 75 Ω by using 
the software impedance switch. The measurement results from the 50 Ω input 
are recalculated to fit the different impedance.

On the 9101, simply select the correct impedance value so that the 9101 can 
translate the internal measurement values to the power before the coupler.

1 To connect a 75 Ω device, connect the device under test to the 9101 Hand-
held Spectrum Analyzer. 

2 From the main menu, select the Level menu.

3 In the vertical menu, select the impedance of the device, that means select 
Impedance: 50 Ω or Impedance: 75 Ω, respectively.
New measurement results are presented with the new impedance value 
taken into account. In addition, if the impedance is changed to 75 Ω and the 
power had been displayed in dBm, the new measurements are shown in 
dBµV. If the impedance is changed to 50 Ω and the power had been 
displayed in dBµV, the new measurements are shown in dBm.

NOTE

Signal reflections on the cable between the 50 Ω and the 75 Ω device affect 
the measurement accuracy of the 9101 Handheld Analyzer. For more accurate 
results, Willtek recommends using an impedance converter; such a converter 
will cause attenuation affecting the results. This attenuation can be compen-
sated as explained in section “Compensating gains and losses” on page 69.
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Setting up the trace

The trace functions provide different views of the measurements, for example 
the actual measurement or an average over the last couple of measurements. 
You can even select two different views of the measurement. Another possibility 
is to compare the actual measurement with an older measurement which has 
been stored in the 9101 and loaded to one of the trace views (see section “Storing 
and loading traces” on page 74).

The 9101 samples many measurements for each frequency point. With the 
detector functions, you can define the method to select which of the samples is 
displayed.

Selecting the trace mode The 9101 has five different modes to display a trace:

– In ’actual’ mode, the 9101 shows a complete new measurement in each 
trace. Subsequent traces are independent of each other.

– In ’hold’ mode, the last measurement is kept on the display; measurements 
continue but are not displayed.

– In ’max hold’ mode, the 9101 takes new measurements and, for each 
frequency point, compares the new measurement with the previous result. If 
the new measurement value is higher than the previous result, the new 
measurement value becomes the new result value; otherwise the old result 
value is kept. This way, the highest result since the start of the Max hold 
measurement (or a parameter change) is kept and displayed.

– Similarly, in ’min hold’ mode, the 9101 takes new measurements and 
compares the new measurement with the previous result. If the new 
measurement value is lower than the previous result, the new measurement 

Figure 19 Example of two traces in channel power mode
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value becomes the new result value; otherwise the old result value is kept. 
This way, the lowest result since the start of the Min hold measurement (or a 
parameter change) is kept and displayed.

– In ’average’ mode, the new measurement and previous ones are averaged for 
each frequency point displayed. The 9101 uses a recursive algorithm for 
averaging.

To select whether you want to view an actual measurement, stop and hold the 
last measurement, see the lowest or highest data for each frequency or an 
average value, proceed as follows:

1 In the main menu, select Trace.

2 Select the trace you want to modify (Trace A or Trace B) using the hori-
zontal softkeys.

3 Select the trade mode with the vertical softkeys (Actual, Hold, Max hold, 
Min hold, Average).
The trace mode is shown at the left-hand side of the vertical axis, e.g. 
A (ACT).

NOTE

For fastest valid results it is advisable to briefly activate the ’actual’ mode 
before selecting any other mode.

NOTE

When the trace is on hold, the measurement and failure counters continue 
counting. A second trace, if active, continues updating.
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Turning the second trace
on and off

You can define two different trace views, e.g. one with the actual values and one 
with the maximum values. While the first view (Trace A) is always active, the 
second can be switched off. The functions of turning Trace B on or off and 
selecting the trace mode are combined as follows:

1 From the main menu, select Trace > Trace B.

2 To turn trace B on, select the trace mode (Actual, Hold, Max hold, Min 
hold, or Average). To turn trace B off, select Off.
If activated, the trace mode is displayed left to the vertical axis, e.g. 
B (MAX).

Defining the number of
measurements for

averaging

When the trace mode is set to averaging, it may be useful to adjust the number 
of measurements over which the 9101 averages the results. The average count 
value that can be defined in the trace menus applies to both traces alike.

The 9101 uses a recursive algorithm in which a new result is added to the older 
averages with a weighting factor; the description below indicates how to change 
this weighting factor.

1 Select the trace menu (select Trace > Trace A or Trace B from the main 
menu).

2 Push the Average Count softkey.
The Average input field opens.

3 Enter the number of measurements over which to average the results, in the 
range from 2 to 128.

4 Push the ENTER key.

Selecting the detection
method

In channel power mode, the detection method is set to Sample (compare with 
spectrum analysis mode on page 51). 
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Copying traces inside the
9101

You can copy an actual measurement from trace A to trace B or vice versa; this 
way you can keep the last measurement results on the screen and at the same 
time continue measuring or change the settings of the 9101 Handheld Spectrum 
Analyzer. The previous results in the target trace will be erased; the target trace 
will assume hold mode. 

To copy the measurement data from one trace to another, proceed as follows:

1 From the main menu, select Trace > Trace Function.

2 To copy the measurement results in trace A to trace B, press Copy A – > B.
To copy results from trace B to trace A, press Copy B – > A.

Storing and loading traces

The 9101 provides the capability to store up to 99 traces in the 9101 and load 
them again at random. The stored trace can then be examined or compared to a 
recent measurement. In addition, stored traces can also be transferred to a PC 
using the 91xx Data Exchange Software which is being delivered with the 9101.

NOTE

If you first press Copy A – > B, then Copy B – > A (or vice versa), both 
traces will display the same results and will be in hold mode.

Figure 20 Trace A menu in channel power mode
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Storing a trace You can store either trace A or B. Any trace can be stored under a name with up 
to 11 characters. The procedure to enter text in alphanumerical input fields is 
explained in section “Entering numbers and text” on page 18. Note that along 
with the trace, the instrument settings such as frequency range, level range and 
markers are stored.

1 From the main menu, select Trace > Trace Memory.

2 Push either Store A or Store B, depending on which trace you want to save 
to the internal memory.
An input field opens, allowing you to enter a name for the trace. Below the 
input field, a list of existing traces is indicated.

3 Enter a name for the trace. To use a modified trace name, you can move the 
cursor to a suitable trace name with the UP/DOWN cursor keys. The 
selected trace name also appears in the input field; use the LEFT/RIGHT 
cursor keys to move the cursor to the appropriate position within the trace 
name to enter additional characters or delete existing ones.

4 Confirm your choice by pushing the ENTER key.
The input field closes and the trace is stored under the selected name.

Reusing a trace name An existing trace stored under a name cannot be overwritten by another trace 
using the same name, so the old trace will first have to be deleted.

Reloading a trace 1 From the main menu, select Trace > Trace Memory.

2 Push either Recall A or Recall B, depending on which trace you want to 
load from the internal memory.
An input field opens, allowing you to enter the trace name. Below the input 
field, a list of existing traces is indicated.

3 Enter the name of the trace to load, or choose one with the UP/DOWN 
cursor keys.

4 Confirm your choice with the Enter key.
The input field closes and the trace is displayed.

Deleting a trace Stored traces can be deleted. Note that there will be no warning; once you have 
selected and requested a file to be deleted, this will occur immediately.

1 From the main menu, select Trace > Trace Memory.

2 Push Delete Trace.
An input field for the name of the trace to be deleted appears, together with 
a trace selection box.

NOTE

Along with the trace, the 9101 also loads the settings that were used when 
the trace was saved. These will overwrite the current settings such as fre-
quency range, reference level and markers.
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3 Select the trace to be deleted using the UP/DOWN cursor keys. Alterna-
tively, enter the trace name with the numeric keys.

4 Confirm your choice by pushing the ENTER key.
The trace is deleted from the trace list.

5 Select another trace for deletion, or push ESCAPE to leave the entry field 
and the trace selection box.

Deleting all traces Instead of deleting traces individually, all traces can be deleted in one step. You 
will be asked to confirm this step.

1 From the main menu, select Trace > Trace Memory.

2 Push Delete All.
A query appears, asking you to confirm your selection.

3 Push the ENTER key to have all traces deleted.
The query disappears. All traces are deleted.

Storing and loading
instrument settings

To store or load the instrument settings including frequency range, level setting 
and markers, proceed as described in sections “Storing a trace” and “Reloading a 
trace” on page 75.
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Chapter 5 Troubleshooting

This chapter provides information on handling errors and problems related to the 
9101 Handheld Spectrum Analyzer. 
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Handling system errors
Should an error or problem occur that prevents you from controlling the instru-
ment and thus requires the instrument’s software to be set up again, the 9101 
offers the Setup Application Software menu. This menu provides you with access 
to the instrument without starting the software and enables you to perform a 
software update.

Chapter 6 “Updating the Instrument’s Software” contains a detailed description 
of the processes involved in updating the instrument’s software via the Setup 
Application Software menu.
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Chapter 6 Updating the Instrument’s Software

This chapter describes how to perform an update of the instrument’s software 
via the 9101 Handheld Spectrum Analyzer’s Setup Application Software menu. 
Topics discussed in this chapter include the following:

– “The Setup Application Software menu” on page 80

– “Performing a serial update” on page 80

– “Performing a LAN update” on page 81

– “Determining the Host IP address” on page 81
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The Setup Application Software menu
The 9101 Handheld Spectrum Analyzer’s Setup Application Software menu 
provides you with access to the instrument without starting the software. Via 
this menu you can perform a software update. The menu offers two options for 
this process: Serial update and LAN update.

Performing a serial update
Take the following steps to perform a serial update of the instrument’s software 
via the Setup Application Software menu:

1 Connect the 9101 to an external power supply.

2 Connect the 9101 to the PC. See section“Connecting the 9101 Handheld 
Spectrum Analyzer” on page 8 for further details. 

3 Switch on the 9101. In order to enter the Setup Application Software menu 
press the numeric key 0 when the input request message is displayed on the 
boot-up screen. Now the Setup Application Software menu is displayed.

4 Press the numeric key 1 to open the Serial Update menu.

5 In order to upload the application files from the PC to the instrument start 
the installation program on your PC. This will open the Update window as 
shown below.

6 In the Connection frame, select Serial.

7 To start the serial update press the numeric key 1 on the instrument.
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Performing a LAN update
Take the following steps to perform a LAN update of the instrument’s software 
via the Setup Application Software menu:

1 Connect the 9101 to an external power supply.

2 Connect the 9101 to the PC. See section“Connecting the 9101 Handheld 
Spectrum Analyzer” on page 8 for further details. 

3 Switch on the 9101. In order to enter the Setup Application Software menu 
press the numeric key 0 when the input request message is displayed on the 
boot up screen. Now the Setup Application Software menu is displayed.

4 Press the numeric key 2 to open the LAN Update menu.

5 Here the IP adresses of the instrument (Target IP) and the PC (Host IP) are 
displayed. Press the numeric key 1 to change or enter the Host IP and 2 to 
change the Target IP. See section “Determining the Host IP address” on 
page 81 for information on determining the Host PC’s IP address.

6 In order to upload the application files from the PC to the instrument start 
the installation program on your PC. This will open the Update window (see 
“Performing a serial update” on page 80).

7 In the Connection frame, select LAN.

8 In order to start the update press the numeric key 3 on the instrument.

Determining the Host IP address
In order to determine your host PC’s IP address proceed as follows:

1 On the status bar, click Start and select Run to open an input window.

2 On the input line, type cmd to open a command prompt.

3 Type IPconfig -all to display the network settings for the PC. In this 
list you will find its IP address. 

4 To close the command prompt type exit.

NOTE

You do not have to click Start in the Update window on your PC. The update 
process will be started without any further input on the PC.



Chapter 6 Updating the Instrument’s Software
Determining the Host IP address

82 9101 Handheld Spectrum Analyzer Version 2.21



7

9101 Handheld Spectrum Analyzer Version 2.21 83

Chapter 7 91xx Data Exchange Software

This help file describes how to install and use the 91xx Data Exchange Software. 
The topics discussed in this chapter are as follows:

– “About the 91xx Data Exchange Software” on page 84

– “Installation requirements” on page 84

– “Understanding the license conditions” on page 84

– “Installing the software” on page 84

– “Starting the software” on page 84

– “Connecting the PC to the 9101” on page 85

– “Loading measurement results from the 9101” on page 87

– “Saving, loading and printing results on the PC” on page 89

– “Working with measurement results” on page 90

– “Defining and loading limit templates” on page 91

– “Defining and loading external coupling parameters” on page 95

– “Managing communication systems for channel power measurements” on 
page 96

– “Working with settings” on page 97

– “Managing files on the PC and on the 9101” on page 98
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About the 91xx Data Exchange Software
The 9101 is delivered with a software product, the 91xx Data Exchange Software. 
This is a tool to load and display measurements from the 9101 to the PC and to 
install software updates on the 9101.

Installation requirements
To install the 91xx Data Exchange Software, you need

– a PC with Pentium II processor or equivalent

– Windows 98SE, Windows NT or later versions

– a minimum of 32 megabytes of RAM

– 50 megabytes of free space on the hard disk

– a free serial interface or a LAN connection

Understanding the license conditions
Before installing the 91xx Data Exchange Software, ensure that you understand 
the license terms which can be found in the appendix “Software License” on 
page 183. The software may only be installed on one computer at any one time!

Installing the software
If you received the software on a CD, just insert the CD in the CD drive of your PC.

Run 91xxDataExchange.exe.
This will start the install wizard which will copy the required files onto your PC.

Follow the instructions given by the install wizard.
By default, the install wizard will store the program files in the following direc-
tory (assuming an English Windows installation): 
C:\Program files\Willtek\91xx Data Exchange.

Starting the software
Click Start > Programs > Willtek > 91xx Data Exchange to run the 91xx Data 
Exchange Software. 
The following box appears:
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To connect to the 9101 via serial connection (RS-232 interface on a COM port of 
the PC), select Serial Connection.

To connect to the 9101 via a local area network (LAN) over TCP/IP, select LAN 
Connection.

If you do not want to connect to the 9101 but rather open a measurement trace 
file that has been previously stored on the PC, select Open existing Trace.

Connecting the PC to the 9101
In order to connect the PC to the 9101, you need to configure the 91xx Data 
Exchange Software first. 

From the menu bar, select Settings > Serial / LAN.
This will open the Connect menu as shown below:
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Using a predefined
configuration for the

connection

If you have previously stored configuration data for a successful connection with 
the 9101, you can proceed as follows:

1 Connect the 9101 with the PC using a serial interface cable or the LAN, 
depending on the configuration you want to use.

2 In the Connect menu of the 91xx Data Exchange Software (see above), load 
the configuration by selecting a name from the file selector in the upper 
left-hand corner of the Connect menu. Click OK to load this configuration.
The PC will now attempt to exchange messages with the 9101 over the 
interface defined in the configuration file. The Connect menu will disappear 
and if a connection has been set up successfully, the status bar of the PC 
software will indicate CONNECTED.

Serial interface
connection

1 Select the Serial radio button.

2 Select the baudrate (bit rate) that is set up in the 9101 as well.

3 Select a serial port (COM1 through COM4).

4 Switch on the 9101 and connect it to the PC using a null modem cable as 
specified in the user’s guide. 

5 Click Check Connection to verify that the connection is working over the 
selected COM port. 
The PC will now attempt to exchange messages with the 9101 over the cable 
attached to the selected serial port. The Connect menu will disappear and if 
a connection has been set up successfully, the status bar of the PC software 
will indicate CONNECTED.

LAN (TCP/IP) connection 1 Select the LAN radio button.

2 Enter the IP address of the 9101. The IP address of the 9101 can be read and 
modified over an RS-232 link using the SCPI command; see “Changing the IP 
address of the 9101” on page 32 for changing the IP address of the 9101.

3 Enter the IP port number in the Socket input field. Valid entries are in the 
range from 1024 to 65535; the default is 49200.

4 Switch on the 9101 and connect both 9101 and PC to the computer network 
with a normal patch cable, or connect them directly with each other using a 
cross patch cable.

5 Click Check Connection to verify that the connection is working over the 
selected LAN connection. 
The PC will now attempt to exchange messages with the 9101 over the 
network. The Connect menu will disappear and if a connection has been set 
up successfully, the status bar of the PC software will indicate CONNECTED.
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Saving the configuration You can save the configuration in a file for later use so that you do not have to 
reenter the configuration each time you are using 91xx Data Exchange Software.

1 In the entry field at the upper left-hand corner, enter a configuration name 
that allows you to identify the configuration that you have made. Several 
configurations can be stored under individual names.

2 Push the Store button to save the current configuration. 

Loading measurement results from the 9101
The 91xx Data Exchange Software can load and display a measurement (trace) 
from the 9101 in two different ways. The software can load either the trace 
currently displayed or a trace that is saved in the 9101 memory. Note that the 
91xx Data Exchange Software can hold multiple windows, each with a trace.

Viewing the actual trace
on the PC

1 Connect the PC to the 9101 as described on page 85.

2 In the 91xx Data Exchange Software, select Instrument > Display Trace, or 
enter Ctrl+T, or click on the icon: 

The trace is displayed in the program window (see example below). You can 
resize or maximize the trace within the program window.

3 To store the results on a local PC drive, select File > Save or File > Save as 
and choose a directory and file name. 
The trace file is stored on your PC.
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Transferring a saved trace
to the PC

To load the data saved in the 9101 proceed as follows:

1 On the 9101, save the desired measurements in trace files.

2 Connect the PC to the 9101 as described on page 85.

3 In the 91xx Data Exchange Software, select Instrument > Get Trace, or 
press Ctrl+G, or click the icon: 

This will load and display a list of trace files that reside on the 9101 (see 
example below).

4 Select the desired trace file(s) and click VIEW.
The trace is displayed in the program window. You can resize or maximize 
the trace within the program window.

5 To store the results on a local PC drive, select the window with the trace to 
be stored, push File > Save or File > Save as and choose a directory and 
file name. The default directory is Traces inside your 91xx Data Exchange 
installation directory.
The trace file is stored on your PC.

NOTE

The trace will also display any active limits. When working in channel power 
mode, the trace will include the communication system name.

NOTE

Trace data can also be transferred in both directions using the Traces tab in 
the Instrument > Data Transfer menu.
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Saving, loading and printing results on the PC
Once a measurement trace has been transferred to the PC, it can be stored on 
the hard disk, printed or exported to a graphics or text file.

Storing results on the PC The trace, along with the 9101 settings and markers, can be saved in a file and 
loaded again in a trace file. This way, information about settings and individual 
result values will not be lost.

1 Select File > Save or File > Save As... .
A window with a file selection box appears.

2 Select a directory and a file name to save the trace data, and confirm with 
ENTER.
The trace data are saved in a file.

Loading a trace file on the
PC

Results previously stored on the PC can be retrieved and displayed in the 
91xx Data Exchange Software.

1 Select File > Open. 
A window with a file selection box appears.

2 Select the directory and the file name containing the trace data, and 
confirm with ENTER.
The trace data are loaded to the 91xx Data Exchange Software.

Printing measurement
results

1 Select File > Print Setup and set up the correct printer, the paper orienta-
tion and printer-dependent settings. Confirm the changes made by pushing 
the ENTER key.

2 You can check the layout before printing by selecting File > Print Preview.

3 Go to the File > Print menu to select the pages to print and start printing by 
pushing the ENTER key.

Saving results to a
graphics file

If you save the results in a graphics file, you can load them in other applications 
such as a word processor and include them in your documentation in graphical 
format. File formats supported are: 

– Windows Bitmap (BMP)

– JPEG (JPG/JPEG)

– JPEG2000 (J2K/JP2)

– Tagged Image File Format (TIF/TIFF)

– Zsoft Paintbrush (PCX)

– Portable Network Graphics (PNG)

– Sun Raster (RAS)
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– Truevision Targa (TGA)

– Portable Bitmaps (PPM/PGM)

1 Select File > Export > Image.
A file selection box appears (“Save image file”).

2 Select a directory, a file name to save the measurement trace and a file 
format, and confirm with ENTER.
The trace data are stored as a graphics file in the selected location.

Saving results to a text
file

You can use the numerical results and include them in other applications for 
postprocessing, e.g. in Microsoft Excel.

1 Select File > Export > ASCII file. 
A file selection box appears (“Save Trace as ASCII File...”).

2 Select a directory and a file name to save the measurement data, and 
confirm with ENTER.
The data are stored in a text file (*.TXT) in the selected location.

Each line in the resulting text file contains a parameter from the settings; the 
parameter name is separated from its value by a semicolon.

Working with measurement results
To open a measurement trace that has been previously loaded from the PC, select 
File > Open.
This will open a file selector box from which you can select a directory and a 
trace file. 

Adding a marker The 9101 already provides up to four markers; the marker positions are stored 
and transferred together with the trace.

In addition to these static markers, you can use an additional dynamic marker on 
the PC to read out the level values at any displayed frequency.

– To enable or disable the marker on the PC, select View > PC Marker.
The PC marker will be enabled at the center frequency, or will be disabled 
depending on the previous setting. The coordinates of the marker position 
will be displayed in the top-right corner of the graph.

– To move the PC marker to another frequency, drag it with the mouse. Alter-
natively, use the LEFT/RIGHT (slow movement) or UP/DOWN (larger steps) 
cursor keys on the keyboard.
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Using a grid The grid of vertical and horizontal lines can be switched on and off with 
View > Grid. The grid is the same as on the 9101, i.e. it consists of eight hori-
zontal and ten vertical lines.

Entering text You can add text to the trace and store it with the measurement. This way, you 
can add valuable information about the conditions of the measurement. The 
comment text will be printed and saved with the graph but not exported to a 
graphics or text file.

1 Select View > Comment.
A “Comment” window opens, allowing you to enter text.

2 Enter your text (three lines maximum), then click on Save to have the 
91xx Data Exchange Software store the text along with the measurements.

Defining and loading limit templates
One of the powerful features of the 9101 is its capability to compare the 
measurements with predefined limits. The limits are set in the form of a template 
that the actual measurement passes or fails. The template can be defined on the 
PC using the 91xx Data Exchange Software and then loaded to the 9101; the 
9101 can hold up to 99 templates.

Editing a template may be easier when an example of a typical result trace is 
available. The limits editing menu of the 91xx Data Exchange Software cannot 
only show the actual limit curve (template) but also an example trace that is 
stored on the PC.



Chapter 7 91xx Data Exchange Software
Defining and loading limit templates

92 9101 Handheld Spectrum Analyzer Version 2.21

Templates can be applied to measurements in both the spectrum and the time 
domain. An example of a limit template in the time domain is the power/time 
template for GSM phones.

The limits are expressed relative to the grid on the 9101 display, not as absolute 
values in terms of frequency (or time) and power. This way, you can apply the 
same template to different power levels and frequencies provided that the scales 
are as intended.

Defining limits Limits can be defined as a template with an upper and and a lower limit curve. 
Each curve consists of a number of straight lines between points. The limits menu 
of the 91xx Data Exchange Software allows you to enter and display such lines.

The limits are expressed relative to the grid on the screen, with eight horizontal 
and ten vertical lines. The coordinates of each point (in x/y coordinates) corre-
spond to these lines.

To define a new template, proceed as follows:

1 In the 91xx Data Exchange Software, select Tools > Limits.
The limits menu appears, with a limits coordinates table on the left and the 
limit lines on the right-hand side.

2 To enter a new limit line, push Insert.
A window appears, allowing you to enter the x/y coordinates for two points.

3 Select whether you wish to define an upper or lower limit by selecting one 
of the Upper Level and Lower Level buttons.
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4 Enter the coordinates for the first point of the limit line (x1, y1).

5 Enter the coordinates for the second point determining the limit line (x2, 
y2).

6 Confirm your choice and close the window by selecting OK.
The window disappears. The values are entered in the limits table on the left 
and the limit line is shown in the limit lines graph on the right. 

7 Enter more limit lines as described above to complete the template 
according to your requirements.

Changing limit lines You can change the template by modifying or deleting individual limit lines:

1 In the table within the Limits menu, click on the line that you want to 
modify or delete.
The line within the table is highlighted and the corresponding limit line in 
the graph is shown in red.

2 To modify the limits, click on Edit or double-click on the row. A dialog box 
appears, allowing you to change the limits.
To delete a limit line, click on Delete. 

Alternatively, to change the starting or ending point for an existing limit line, 
proceed as follows:

1 In the graph within the Limits menu, click on the starting point of a limit 
line that you want to modify.

2 Point the mouse to the starting or ending point of the limit line, keep the 
left mouse button pressed and drag the point to its new position and release 
it there.

Displaying an example
trace in the limits editing

menu

1 In the Limits menu, click on the Overlay Trace button. 
A file selection box appears.

2 Select a trace file from the default or any other directory, and click Open.
The file selection box disappears and the trace data is displayed in the limit 
lines box on the right-hand side of the Limits menu.

Storing a template on the
PC

A template can be stored on the PC, e.g. to allow modifications later or to down-
load it to different 9101 analyzers at any time.

1 In the Limits menu, click on the Save button.
A window opens (“Save Limits as Text File...”).

NOTE

Only one trace can be displayed in this menu at a time. Once a trace is being 
displayed, the Overlay Trace button is replaced by a Clear Trace button. 
After clicking the latter, the displayed trace disappears and the Overlay 
Trace is shown again.
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2 Choose a directory and enter a file name to save your limits template.

3 Confirm your choice with the ENTER key.
The limits are saved in a file.

Loading a template from
the PC

To modify or to load a template to a 9101 that has previously been stored on the 
PC, proceed as follows:

1 In the Limits menu, click on the Open button.
A file selection window appears (“Open Limits File...”).

2 Select the directory and the file containing a template file previously stored 
with the 91xx Data Exchange Software.

3 Confirm your choice by pushing the ENTER key.
The limits are loaded to the limits table and the graph. You can now modify 
the limits (see section “Changing limit lines” above), or download the limits 
to the 9101.

Transferring a template to
the 9101

1 Define a template or load it from the PC’s hard disk as described above.

2 Ensure that the PC is connected to the 9101 either via RS-232 or LAN.

3 Push the Data Transfer button.
If the template (characterized by its limit lines) is not yet stored you will be 
asked if you want to save it on the PC harddisk. If you choose not to store 
the template, your changes will be lost.
The data transfer menu pops up with the Limits tab active.

4 Choose a limits file (or multiple files) on the PC side (right-hand side) of the 
data transfer menu, and click < copy. 
The 9101 will, if not done so previously, ask whether to connect to the 9101. 
In that case, follow the instructions in section “Connecting the PC to the 
9101” on page 85.

The file name on the 9101 will only carry the first 11 characters of the file 
name that was used on the PC.
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If a limits file on the PC has been selected for transfer and a limits file with 
the same name already exists on the 9101, the 91xx Data Exchange 
Software will display a pop-up box with the file name in question in the 
header bar, and offer several possibilities:

– Click Yes if you want to overwrite the file in question.

– Click No to cancel transmission of the file in question.

– Click Yes to All to copy all files to the 9101, irrespective of duplicate file 
names.

– Click No to All to prevent overwriting of all files with duplicate file 
names.

– Click Rename to enter a new file name applying to that file when down-
loaded to the 9101. 

– Click Cancel to cancel transmission of all files, no matter whether file 
names already exist on the 9101 or not.

The 91xx Data Exchange Software will indicate when the download has 
been completed successfully. 

5 On the 9101, push the ESCAPE key to return to local mode. You can then 
start using the limits template.

Defining and loading external coupling parameters
The 9101 Handheld Spectrum Analyzer can compensate a defined gain or atten-
uation introduced by external equipment between the device under test and the 
9101. The coupling can be specified in the 91xx Data Exchange Software; several 
files for different devices can be defined, stored and downloaded to the 9101. 
Once downloaded, the compensation of effects from external devices can be 
switched on and off at any time. The 9101 takes the coupling factor into account 
before presenting the measurement result.

Gain and attenuation are frequency dependent in most cases; therefore the 91xx 
Data Exchange Software allows you to enter interpolation points to cover the 
frequency-dependent coupling factor over the whole frequency range of interest.
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Defining the external
coupling factor

1 Open the External Device Compensation menu by selecting Tools > Ext. 
Dev. Compensation or by pressing Alt-E.

2 To enter an interpolation point, select Insert. 
A box appears, allowing you to enter frequency and level.

3 Enter the frequency, select a unit (from hertz to gigahertz) and enter the 
coupling factor (in dB). Positive factors indicate signal attenuation, nega-
tive factors indicate gain in the signal line.

4 Close the box by pushing the OK button and repeat the last two steps with 
as many interpolation points as available.
The frequency-dependent compensation curve appears on the right-hand 
side as values are entered.

5 If you want to change a factor, either select a line from the table on the left-
hand side and click Edit to change the values numerically, or point with the 
mouse to an interpolation point in the graph on the right and drag it to a 
new position.

6 To move the whole interpolation curve up or down in steps of 1 dB, click on 
the Level Offset arrow buttons.

7 When completed, save the device compensation values in a file on the PC: 
Click Save, enter a file name and confirm with the Save button. 

8 Push Cancel to leave the menu.

Loading an external
coupling loss file to the

9101

One or more files with external coupling loss data can be transferred to the 9101 
and reside in the internal memory of the 9101. They will not be taken into 
account until they are activated (see “Compensating gains and losses”).

1 Select Instrument > Data Transfer (Ctrl-D), or in the External Device 
Compensation menu, push the Data Transfer button.
The Data Transfer menu opens.

2 In the Ext. Device tab, select a directory and file(s) on the right-hand side 
and push the < copy button.
The selected files are transferred to the 9101. 

Managing communication systems for channel power measurements
Measurements in channel mode imply that a communication system with 
predefined channel numbers and associated frequencies has been defined. The 
9101 comes with a few systems preinstalled; more systems are available for 
download to the 9101 in the 91xx Data Exchange Software, for example Wireless 
LAN, Bluetooth, TETRA and DECT. Other systems’ data can be easily entered on 
the PC using the 91xx Data Exchange Software. Each set of system data can be 
stored in a separate file; one or multiple files can be downloaded to the 9101. For 
downloading and copying system files between the PC and the 9101, see section 
“Managing files on the PC and on the 9101” below. Once data are stored in the 
9101, they can be used as described in section “Operating in channel power 
mode” on page 63.
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Editing communication
system parameters on the

PC

1 Select Tools > Channel System (or Alt-C).
The Channel System menu appears.

2 If you want to edit a communication system that is already stored on the PC, 
press Open, select the appropriate directory and file, and press the Open 
button.

3 Enter the first and the last valid channel number of the system.

4 In the Channel Width line, enter the measurement bandwidth (separate 
input fields for value and unit).

5 In the Channel Spacing line, enter the frequency spacing (including the unit) 
between consecutive channel numbers.

6 Enter the carrier frequency (including the unit) corresponding to the first 
channel number in the 1st Ch. Center line.

7 Press the Save button.
A dialog box appears, allowing you to enter a name for the file in which the 
channel system parameters of the communication system shall be stored.

8 Enter a file name and press Save.
The data are stored and the menu disappears.

9 To transfer the data to the 9101, press Data Transfer. To leave the Channel 
System menu, press Cancel.

Working with settings
The 9101 allows to store and recall settings (see section “Working with stored 
settings” on page 35). This can be useful when you want to perform measure-
ments under exactly the same conditions as at an earlier time. With the 91xx 
Data Exchange Software, you can transfer the settings from a 9101 to the PC for 
backup purposes or to replicate the settings to another 9101. Another useful 
application is to manipulate settings on the PC; this is easily done because the 
settings file is editable and the format consists of SCPI commands. Changing or 
adding a setting is equivalent to changing or adding a line in the settings file.

Exchanging a settings file
between 9101 and PC

The settings stored on the 9101 can be copied to the PC with the 91xx Data 
Exchange Software. Use the Settings tab within the Data Transfer utility to copy 
files between the PC and the 9101. See section “Managing files on the PC and on 
the 9101” on page 98 for more details.
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Changing 9101 settings on
the PC

Take the following steps to change and amend a settings file for later transfer 
and usage on the 9101.

1 In the 91xx Data Exchange Software, select Tools > Settings.
The 91xx Settings box appears.

2 Push the Open button to open an existing settings file on the PC.
A file selection dialog box appears.

3 Select the directory and settings file that you want to modify, and press the 
Open button.
An additional program window with the Microsoft Windows text editor 
Notepad opens, and the selected file is displayed.

4 Modify or add lines with SCPI commands for the desired settings. Refer to 
chapter “SCPI Command Reference” on page 101 for correct syntax and 
value range of the parameters.

5 Save and close the file within Notepad, and return to 91xx Data Exchange 
Software to transfer the file to the 9101.

Managing files on the PC and on the 9101
There are various types of settings which can be maintained from the PC using 
the 91xx Data Exchange Software. This section explains how data can be trans-
ferred between the 9101 and the PC, maintained and deleted.

File types and directory
structure

Each type of setting stored on the PC has a preferred file name extension and 
directory for different sets of parameters. The table below summarizes this file 
structure.
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Starting the file manager
menu

The files on the PC and on the 9101 can easily be selected, copied and deleted 
from the Data Transfer menu.

1 In the 91xx Data Exchange Software, select Instrument > Data Transfer (or 
Ctrl-D).
The Data Transfer menu appears.

2 Select the appropriate tab (Traces, Settings, Limits, Systems, Ext. Device) 
either by clicking on it with the mouse, or by moving the tab selection with 
the << and >> buttons.
The menu displays the appropriate files available on the 9101 on the left-
hand side, and the appropriate files available on the PC on the right-hand 
side. Files on the PC have a file extension and can be stored on any drive and 
in any directory; there are no directories available on the 9101.

Table 16 Configuration file types

Type File names Directory

Traces *.9tr 91xx Data Exchange\Traces

Settings *.9st 91xx Data Exchange\Settings

Limits *.9lm 91xx Data Exchange\Extdev

Systems *.9sy 91xx Data Exchange\Systems

Ext. Device *.9ed 91xx Data Exchange\Extdev

NOTE

File names on the 9101 only carry 11 characters. When copying a file from the 
PC to the 9101 that has more than 11 characters, the file name will be trun-
cated.
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Copying configuration
files from the 9101 to the

PC

Files can be copied in both directions. 

1 Select a PC directory where the file shall be stored or from which it shall be 
copied.

2 Select one or several files for copying, either on the PC or on the 9101. 

3 Press < copy to transfer the files from the PC to the 9101.
or
Press copy > to transfer files to the PC.
If a file on one side has been selected for transfer and a file with the same 
name already exists on the other, the 91xx Data Exchange Software will 
display a pop-up box with the file name in question in the header bar, and 
offer several possibilities:

– Click Yes if you want to overwrite the file in question.

– Click No to cancel transmission of the file in question.

– Click Yes to All to copy all files, irrespective of duplicate file names.

– Click No to All to prevent overwriting of all files with duplicate file 
names.

– Click Rename to enter a new file name applying to that file when trans-
ferred. 

4 Click Cancel to cancel transmission of all files, no matter whether file names 
already exist on the receiving side or not.

Deleting files 1 To delete a file either on the 9101 or on the PC, select (highlight) the file 
name first. Several files may be selected concurrently by holding the Shift or 
Ctrl key pressed while selecting individual files.

2 Press the Delete button  above the files marked for deletion.
A box appears asking, “Are you sure to delete the selected items?”

3 Push Yes to confirm deletion.
The selected files are removed.
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Chapter 8 SCPI Command Reference

This chapter provides a reference list of commands for remote control of the  
9101 Handheld Spectrum Analyzer. Topics discussed in this chapter are as 
follows:

– “Overview” on page 102

– “General commands” on page 102

– “System commands” on page 106

– “Sense commands” on page 111

– “Input commands” on page 125

– “MMemory commands” on page 126

– “Instrument commands” on page 134

– “Display commands” on page 134

– “Calculate commands” on page 136

– “Format commands” on page 142

– “Service commands” on page 143

– “SCPI errors” on page 145
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Overview
The command set of the 9101 Handheld Spectrum Analyzer follows the SCPI 
standard and is broken down into the following subsystems:

– General commands

– System commands

– Sense commands

– Input commands

– Memory commands

– Display commands

– Calculate commands

– Format commands

Each keyword in the command can be used either in its long or its short form. 
Uppercase letters are used to indicate the short-form command syntax. Within 
one keyword, either the short form or the full version can be used, but not a mix.

The syntax can be used to form either a command or a query (with a question 
mark behind the command form). Many SCPI commands have either a command 
form or a query form, but not both.

Please refer to the “Index of SCPI Commands” on page 163 for an alphabetical 
list of commands.

General commands

:REBoot

*CAL

Syntax :REBoot

Parameters There are no parameters.

Command Reboots the Willtek 9101. The current settings are not affected of this command.

Query There is no query form of this command available.

Example :REB

Syntax *CAL?

Parameters There are no parameters.

Command The command form is not available.

Query Returns the date of the last calibration by Willtek in the format yyyy, mm,dd.

Example *CAL?
Returns 2004,04,01.
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*CLS

*IDN

*RST

*OPC

Syntax *CLS 

Parameters There are no parameters.

Command Resets the entire status reporting system:
– The service register will be cleared (all bits will be set to 0).
– The event status register will be cleared (all bits will be set to 0).
– The error message queue will be emptied.
– All event-type registers will be cleared.

Query There is no query form of this command available.

Syntax *IDN? 

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns a string, containing the following information:
– manufacturer's name
– name of the device
– serial number
– software revision number
All parameters are separated by commas.
Note: In times of company mergers and acquisitions, it is a good idea to check the 
name of the device, not the manufacturer's name which may change between soft-
ware updates. This does not preclude any name changes at Willtek but rather applies 
to instrumentation in general.

Example *IDN?
returns: "WILLTEK, 9101, 0104012, 1.00"

Syntax *RST

Parameters There are no parameters.

Command Resets the entire test set. All parameters, limits etc. will be set to the internally pre-
defined default values.

Query There is no query form available.

Syntax *OPC?

Parameters There are no parameters.

Command Only the query form is available.

Query Waits until the previous command is completed. In addition, the query returns the 
Operation Complete flag which is 1 in the successful case.
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Commands affecting the
event status register

The event status register contains eight bits. The meaning of these bits is 
outlined in the table below.
The commands working on the event status register are described below the 
table.

*ESE

Bit Decimal Meaning

7 128 Power on – this bit is always set.

6 64 User Request – a 1 on this position indicates that the 
9101 is no longer controlled by remote commands 
but by user interaction.

5 32 Command error – this bit indicates that a SCPI com-
mand error occurred (SCPI error codes 100 to 199).

4 16 Execution error – is set after a SCPI execution error 
did occur (SCPI error codes 200 to 299).

3 8 Device dependent error – this bit indicates that a 
device-specific SCPI error did occur (SCPI error codes 
300 to 399).

2 4 Query error – is set after a SCPI query error occurred 
(SCPI error codes 400 to 499).

1 2 Request control – this bit is reserved for future use.

0 1 Operation complete flag – is set as soon as the exe-
cution of a command has been completed.

Syntax *ESE <int1>

Parameters int1 is an integer.
The valid range is from 0 to 255 (8 bits).

Command Sets the enable filter (mask) of the event status register.
int1 is the decimal representation of the binary mask.
The mask and the current contents of the event status register will be ANDed. If the 
result is not zero, then bit 5 of the Service register will be set.

Query The query form reads out the enable filter (mask) currently set and returns its binary 
representation in a string.

Example *ESE 128
As soon as power has been switched on, bit 7 (Power on) will be set. ANDed with the 
mask 128, a binary 1 will occur and thus bit 5 of the service register will be set.
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*ESR

Commands affecting the
service register

The service register represents the highest level within the report structure of the 
9101.
The service register contains eight bits.
If any of the bits 0 to 5 or 7 is set, the summary status bit (bit 6) of the service 
register will be set as well.

Syntax *ESR? 

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns the decimal representation of the current contents of the event status regis-
ter in a string.
Note: This register is self-destructive, i.e. its contents will be cleared after reading.

Example After power-on, the *ESR? query will return "128". This means that bit 7 is set 
and all the other bits of the event status register are 0.
The command will clear the event status register and a subsequent *ESR? query will 
return "0".

NOTE

The service register is self-destructive. This means that its contents will be 
cleared after reading.

Bit Decimal Meaning

7 128 OPERational status summary. When this bit is set, an 
event within the general operation register group 
(e.g. the 9101 is waiting for a trigger) passed all fil-
ters.

6 64 Summary status bit. This bit will always be set as 
soon as any other bit of the service register has been 
set.

5 32 Event status summary. When this bit is set, an event 
within the event status register group (e.g. an error 
occurred) passed all filters.

4 16 Message available. This bit will be set to 1 as soon as 
a query has been completed and measurement 
results are available.

3 8 QUESTionable status summary. If this bit is set, an 
event within the general questionable status register 
group (e.g. 'value out of range') passed all filters.

2 4 Error queue status. When this bit is set, the error 
queue contains error messages. Up to 10 error mes-
sages can be logged in the error queue. The error 
queue can be read out, using the :SYSTem:ERRor? 
query.
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*SRE

*STB

System commands
With the system commands, the internal settings of the 9101 Handheld Spec-
trum Analyzer can be changed.

1 2 Remote command completed. This bit will be set to 
1 after a remote (SCPI) command has been com-
pleted.
Note: When the 9101 receives a SCPI command, it 
will block any further input readings until the com-
mand has been completed.

Syntax *SRE <int1>

Parameters int1 is an integer.
The valid range is from 0 to 255 (8 bits).

Command Sets the enable filter (mask) for the service register.
int1 is the decimal representation of this binary mask.
The mask and the current contents of the service register will be ANDed. 

Query The query form reads out the mask currently set and returns its binary representation 
in a string.

Example *SRE 68
As soon as an error occurs, bits 2 and 6 of the service register will be set. ANDed with 
the mask (68), a binary 1 will be the result.

Syntax *STB?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns the decimal representation of the current contents of the service register in a 
string.
Note: This register is self-destructive, i.e. its contents will be cleared after reading.

Example A *STB? command returns "68".
The return value of 68 (= 64 + 4) means that an error occurred (4).
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:SYSTem:DATE

:SYSTem:TIME

:SYSTem:COMMunicate:LOCal

Syntax :SYSTem:DATE <int1>,<int2>,<int3>

Parameters intx are three integers.
The minimum value for int1 is 1998, the maximum is 2100. The default value is 
1998.
The minimum value for int2 is 1, the maximum is 12. The default value is 1.
The minimum value for int3 is 1, the maximum is 31. The default value is 1.

Command Sets the system date. This command uses the following format: yyyy,mm,dd 
where
yyyy stands for the four digits of the year (int1),
mm gives the current month (int2),
dd represents the day of the current month (int3).

Query Returns the current system date in a string, using the format explained above.

Example :SYST:DATE 2001,7,6
Sets the system date to the July 6, 2001.

Syntax :SYSTem:TIME <int1>,<int2>,<int3>

Parameters intx are three integers.
The minimum value for int1 is 0, the maximum is 23. The default value is 0.
The minimum value for int2 is 0, the maximum is 59. The default value is 0.
The minimum value for int3 is 0, the maximum is 59. The default value is 0.

Command Sets the system time. This command uses the following format: hh,mm,ss where
hh stands for the two digits of the current hour, using a 24 hour time format (int1),
mm gives the current minute (int2) and,
ss represents the seconds of the system time (int3).

Query Returns the current system time in a string, using the format explained above.

Example :SYST:TIME?
String returned: "14,56,05" meaning roughly four minutes to 3 pm.

Syntax :SYSTem:COMMunicate:LOCal 

Parameters There are no parameters.

Command Sets up the Willtek 9101 to allow manual operation on the front panel during SCPI 
operation.
Notes: 
– This command may be used e.g. to allow interactive alignment procedures in a 

production flow.
– The instrument can also be set to local mode by pressing the Escape button on the 

front panel.

Query There is no query form of this command available.

Example :SYSTem:COMM:LOC
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:SYSTem:COMMunicate:ECHo

:SYSTem:COMMunicate:ETHernet:IPADdress

:SYSTem:COMMunicate:ETHernet:TNAMe

Syntax :SYSTem:COMMunicate:ECHo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command This command determines how the Willtek 9101 acts after executing a SCPI com-
mand.
If echo is set to ON, there will be a response. Either "ok", if the execution was suc-
cessful or "ERR" if an error occured. The echo-on mode is preferred for entering 
interactive commands.
If echo is set to OFF, there will be no response to a SCPI command. In this case it is 
possible to check with the *OPC? query, when the SCPI command is finished and the 
Willtek 9101 is ready to receive the next command.

Query Returns the current echo setting.

Example :SYST:COMM:ECH ON
Returns the following string: "ok"
All subsequent commands returns "ok" or "ERR".
:SYST:COMM:ECH?
Returns the following string: "ON"
:SYST:COMM:ECH OFF
Returns nothing, all subsequent commands return nothing.

Syntax :SYSTem:COMMunicate:ETHernet:IPADdress 
<int1>,<int2>,<int3>,<int4> 

Parameters intx are four integers.
The minimum value for all integers is 0, the maximum is 255. The default value is 0.

Command This command sets the IP address of the Willtek 9101 to the parameter values. The 
change takes effect after reboot (e.g. after executing the REBoot command).

Query Returns the current setting of the IP address as explained above.

Example SYST:COMM:ETH:IPAD 192,16,16,114 sets the IP address to a defined 
value.

Syntax :SYSTem:COMMunicate:ETHernet:TNAMe <string> 

Parameters string is a string only containing the device name of the Willtek 9101.

Command This command sets the device name of the Willtek 9101. It can be used to announce a 
symbolic device name for the 9101 if the network supports DHCP (Dynamic Host Con-
figuration Protocol).

Query Returns the current setting of the device name as explained above.

Example SYST:COMM:ETHernet:TNAMe "TARGET9104" sets the device name to a 
defined value.
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:SYSTem:COMMunicate:ETHernet:PORT

:SYSTem:COMMunicate:ETHernet:TERMinator

:SYSTem:COMMunicate:SER:BAUDrate

Syntax :SYSTem:COMMunicate:ETHernet:PORT <int> 

Parameters int defines the TCP/IP port address of the Willtek 9101. The address must be in the 
range from 1024 to 65535. Default value is 49200.

Command This command sets the port address on which the Willtek 9101 can be controlled via 
LAN.

Query Returns the current setting of the port used by TCPIP as explained above.

Example SYST:COMM:ETHernet:PORT 49200 sets the TCP/IP port address to its 
default.

Syntax :SYSTem:COMMunicate:ETHernet:TERMinator <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: CRLF|LF|CR.
Default is CRLF.

Command Sets the terminator characters, which are appended to every SCPI respond from the 
Willtek 9101 LAN interface.

Query Returns the current terminator setting for the LAN interface.

Example :SYST:COMM:ETH:TERM CR
:SYST:COMM:ETH:TERM?
Returns the following string: "CR"

Syntax :SYSTem:COMMunicate:SER:BAUDrate <int1>

Parameters int1 is an integer.
The minimum value for int1 is 300, the maximum value is 57600. The default 
value for int1 is 57600. Valid values are 
300,1200,2400,4800,9600,19200,38400 and 57600.

Command Sets the data rate for the serial port. Only the data rate can be changed; all other 
parameters are fixed. The number of bits per character is set to 8, the number of stop 
bits is set to 1 and parity is set to NO. The change takes effect immediately.

Query Returns the serial interface data rate currently set.

Example :SYST:COMM:SER:BAUD 9600
:SYST:COMM:SER:BAUD?
String returned: "9600".
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:SYSTem:COMMunicate:SER:TERMinator

:SYSTem:ERRor[:NEXT]

:SYSTem:ERRor:COUNt

Syntax :SYSTem:COMMunicate:SER:TERMinator <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: CRLF|LF|CR.
Default is CRLF.

Command Sets the terminator characters, which are appended to every SCPI response from the 
Willtek 9101 serial interface.

Query Returns the current terminator setting for the serial interface.

Example :SYST:COMM:SER:TERM LF
:SYST:COMM:SER:TERM?
Returns the following string: "LF"

Syntax :SYSTem:ERRor[:NEXT]? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the oldest unread error message from the internal error queue of the Willtek 
9101. The queue entry returned will be a string (text). The maximum length of the 
text is 255 characters.
Note: A list of error messages can be found in section “SCPI errors” on page 145.

Example *RESET
:SYSTem:ERRor:NEXT?
String returned: -113,"Undefined header"

Syntax :SYSTem:ERRor:COUNt? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the number of unread error messages in the internal error queue of the 
Willtek 9101. The string returned will contain one integer. The maximum number of 
errors stored internally is 10.

Example :SYSTem:ERRor:COUNt?
String returned: "0"
This means that there are no unread error messages in the error queue.



Chapter 8 SCPI Command Reference
Sense commands

9101 Handheld Spectrum Analyzer Version 2.21 111

:SYSTem:ERRor:CODE[:NEXT]

:SYSTem:ERRor:CODE:ALL

:SYSTem:DNAMe

Sense commands
These commands affect the spectrum analyzer settings, start measurements and 
return results.

Syntax :SYSTem:ERRor:CODE[:NEXT]? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the code of the oldest unread error message in the internal error queue of the 
Willtek 9101. The string returned will contain one integer (and no text).
Note: A list of error messages can be found in section “SCPI errors” on page 145.

Example *RESET
:SYSTem:ERRor:CODE?
String returned: "-113"
This means that an undefined header (*RESET) was received.

Syntax :SYSTem:ERRor:CODE:ALL? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the error codes of all unread error messages in the internal error queue of the 
Willtek 9101. The string returned will contain a maximum of 100 integers, separated 
by commas.
Note: A list of error messages can be found in section “SCPI errors” on page 145.

Example :SYSTem:ERRor:CODE:ALL?
String returned: "-113,-112,0,0,0,0,0,0,0,0"
This means that there were two unread error messages in the error queue.

Syntax :SYSTem:DNAMe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Sets a user-definable device name for the 9101 to use this unique name on protocols.

Query Returns the device name set on this 9101.

Example :SYSTem:DNAMe "Develop5"
:SYST:DNAM?
String returned in this example: "Develop5"
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:SENSe:BANDwidth:RESolution

:SENSe:BANDwidth:RESolution:AUTo

:SENSe:BANDwidth:VIDeo

Syntax :SENSe:BANDwidth:RESolution <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 10000, the maximum value 1000000. real1 
can be set as 1∗10n or 3∗10n. The default value for real1 is 106 (1E6).

Command This command sets the resolution bandwidth of the 9101, in Hertz.

Query Returns the current setting.

Example :SENSe:BANDwidth:RESolution 300000
:SENSe:BANDwidth:RESolution?
The value returned is: "300000".

Syntax :SENSe:BANDwidth:RESolution:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Switches the automatic selection of the bandwidth resolution on or off. If switched 
on, the 9101 selects the resolution bandwidth depending on the current span, video 
bandwidth, and sweep time.

Query Returns the current setting.

Example :SENSe:BANDwidth:RESolution:AUTo ON
:SENSe:BANDwidth:RESolution:AUTo?
Returns the following string: "ON"

Syntax :SENSe:BANDwidth:VIDeo <real1>

Parameters real1 is a floating point real number.
Valid entries are 10, 100, 300, 1000, 3000, 10000, 30000, 100000, 300000, 
1000000. The default value for real1 is 1000000.

Command Sets the video bandwidth of the 9101. The unit of real1 is Hertz.

Query Returns the current setting.

Example :SENSe:BANDwidth:VIDeo 300000
:SENSe:BANDwidth:VIDeo?
The value returned is: "300000".
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:SENSe:BANDwidth:VIDeo:AUTo

:SENSe:FREQuency:CENTer

:SENSe:FREQuency:SPAN

Syntax :SENSe:BANDwidth:VIDeo:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF|.
Default is ON.

Command Switches the automatic selection of the video bandwidth on or off. If switched on, 
the 9101 selects the video bandwidth depending on the current span, resolution 
bandwidth, and sweep time.

Query Returns the current setting.

Example :SENSe:BANDwidth:VIDeo:AUTo OFF
:SENSe:BANDwidth:VIDeo:AUTo?
Returns the following string: "OFF"

Syntax :SENSe:FREQuency:CENTer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 5E4, the maximum value 4E9. real1 can be set 
in multiples of 1000. The default value for real1 is 1.8E6.
Instead of 150000000 for 150 MHz, you can also use 150E6 for easier reading.

Command Sets the center frequency of the 9101, in Hertz. When a new center frequency is 
selected, this affects the start and stop frequencies, leaving the span unchanged so 
long as the new start and stop frequencies do not exceed the limits of the 9101.

Query Returns the current setting.

Example :SENSe:FREQuency:CENTer 1500000000
:SENSe:FREQuency:CENTer?
The value returned is: "1500000000".

Syntax :SENSe:FREQuency:SPAN <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 4000000000. The mini-
mum resolution possible for real1 is 1000. The default value for real1 is 
3600000000.

Command Sets the frequency span, i.e. the measured bandwidth, in Hertz. A new frequency span 
setting will leave the center frequency unchanged but affect start and stop frequen-
cies; only if the new start or stop frequency exceeds a limit of the 9101, the center 
frequency will be changed accordingly.

Query Returns the current setting.

Example :SENSe:FREQuency:SPAN 1500000000
:SENSe:FREQuency:SPAN?
The value returned is: "1500000000".
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:SENSe:FREQuency:SPAN:FULL

:SENSe:FREQuency:STARt

:SENSe:FREQuency:STOP

Syntax :SENSe:FREQuency:SPAN:FULL

Parameters There are no parameters.

Command Sets the 9101 to the maximum supported frequency span. This command affects 
start, stop and corresponding center frequency.
Note: If you set the span to 0, the 9101 will perform measurements in the time rather 
than the frequency domain.

Query There is no query form of this command available.

Example :SENS:FREQ:SPAN:FULL
Sets the start frequency of the 9101 to 0 and the stop frequency to 4 GHz.

Syntax :SENSe:FREQuency:STARt <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 4000000000. The mini-
mum resolution possible for real1 is 1000. The default value for real1 is 0.

Command Sets the start frequency of the 9101, in Hertz. This command leaves the span as is but 
affects the center frequency and the stop frequency.

Query Returns the current setting.

Example :SENSe:FREQuency:STARt 1500000000
:SENSe:FREQuency:STARt?
The value returned is: "1500000000".

Syntax :SENSe:FREQuency:STOP <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 100000, the maximum value 4000000000. The 
minimum resolution possible for real1 is 1000. The default value for real1 is 
3600000000.

Command Sets the stop frequency of the measured bandwidth, in Hertz. This command leaves 
the span unchanged but affects the center frequency and the start frequency.

Query Returns the current setting.

Example :SENSe:FREQuency:STOP 2500000000
:SENSe:FREQuency:STOP?
The value returned is: "2500000000".
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:SENSe:FREQuency:MODE

:SENSe:FREQuency:FSTep

:SENSe:FREQuency:FSTep:AUTo

Syntax :SENSe:FREQuency:MODE <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: CSPan|SSTop. 
Default is CSPan.

Command Defines which frequency mode is active.
The following modes are available: Center-Span, Start-Stop.

Query Returns the current setting.

Example :SENSe:FREQuency:MODe CSPan
:SENSe:FREQuency:MODe?
Returns the following string: "CSPan"

Syntax :SENSe:FREQuency:FSTep <real1>

Parameters real1 is a floating point real number. The minimum value for real1 is 0, the max-
imum value 1000000000. The minimum resolution is 1000. The default value for 
real1 is 360000000.

Command Sets the step size for the center frequency setting using the cursor keys in manual 
mode.

Query Returns the current setting.

Example :SENSe:FREQuency:FSTep 2.5E6
:SENSe:FREQuency:FST?
Value returned in this example: 2500000

Syntax :SENSe:FREQuency:FSTep:AUTo <PredefExp>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF. Default is 
ON.

Command Enables or disables the automatic selection of the step size for the center frequency 
setting using the cursor keys in manual mode.

Query Returns the current setting.

Example :SENSe:FREQuency:FSTep:AUTo ON
:SENSe:FREQuency:FSTep:AUTo?
Returns the following string: "ON"
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:SENSe:CPOWer:SPAN

:SENSe:CPOWer:CHANnel

:SENSe:CPOWer:OBW

:SENSe:CPOWer:MEASure

Syntax :SENSe:CPOWer:SPAN <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: FULL|SINGle.
Default is FULL.

Command Sets the channel power display mode of the 9101.
FULL selects the whole system spectrum. SINGle displays the spectrum of the 
selected channel.

Query Returns the current setting.

Example :CPOWer:SPAN SINGle
:SENSe:CPOWer:SPAN?
Returns the following string: "SINGle"

Syntax :SENSe:CPOWer:CHANnel <int1>

Parameters int1 is an integer. The minimum value for int1 is 0, the maximum is 1000000. 
The default value is 0.

Command Sets the actual channel number which is displayed.

Query Returns the current setting.

Example :SENSe:CPOWer:CHANnel 50
:SENSe:CPOWer:CHANnel?
The value returned in this example is: "50".

Syntax :SENSe:CPOWer:OBW <int1>

Parameters int1 is a integer. The minimum value for int1 is 5, the maximum is 99. The 
default value for int1 is 90.

Command Sets percentage value for which the 9101 shall determine the occupied bandwidth 
(channnel power mode).

Query Returns the current setting.

Example :SENSe:CPOWer:OBW 20
:SENSe:CPOWer:OBW?
The value returned in this example is: "20"

Syntax :SENSe:CPOWer:MEASure <PredefExp>

Parameters PredefExpr is one of the following predefined expressions: 
CPOWer|ACPR|OBW. Default is CPOWer.

Command Sets the type of measurement in channel power mode.

Query Returns the current setting.

Example :SENSe:CPOWer:MEASure ACPR
:SENSe:CPOWer:MEASure?
Returns the following string: "ACPR".



Chapter 8 SCPI Command Reference
Sense commands

9101 Handheld Spectrum Analyzer Version 2.21 117

:SENSe:SWEep:TIME

:SENSe:SWEep:TIME:AUTO

:SENSe:SWEep:STATe

Syntax :SENSe:SWEep:TIME <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 20.0. The minimum resolu-
tion possible for real1 is 0.0001. The default value for real1 is 0.0432.

Command Sets the sweep time, i.e. the measurement time to cover the full frequency span. 
real1 is the time in seconds.

Query Returns the current setting.

Example :SENSe:SWEep:TIME 0.3
:SENSe:SWEep:TIME?
The value returned is: "0.3".

Syntax :SENSe:SWEep:TIME:AUTO <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Switches the automatic selection of the sweep time on or off. If turned on, the 9101 
will decide on the best sweep time depending on the current settings of span, resolu-
tion bandwidth and video bandwidth.

Query Returns the current setting.

Example :SENSe:SWEep:TIME:AUTO ON
:SENSe:SWEep:TIME:AUTO?
Returns the following string: "ON".

Syntax :SENSe:SWEep:STATe <PredefExpr>[,<int1>]

Parameters PredefExpr is one of the following predefined expressions: CONTinu-
ous|SINGle|HOLD. Default is CONTinuous.
int1 is an optional integer. It is only valid for SINGLe sweeps. The minimum value 
for int1 is 1, the maximum is 999. The default value is 1.

Command Sets the measurement display mode of the 9101.
CONTinuous selects repetitive measurements.
SINGle lets the 9101 perform and display one (or a limited number of) measure-
ment(s). The optional second parameter indicates how often a sweep will be per-
formed.
HOLD immediately stops any ongoing measurement.

Query Returns the current setting.

Example :SENSe:SWEep:STATe SINGle
:SENSe:SWEep:STATe?
Returns the following string: "SINGle".
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:SENSe:TRIGger

:SENSe:TRIGger:LEVel

:SENSe:TRIGger:EDGE

:SENSe:DEMod:VOLume

Syntax :SENSe:TRIGger <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|VIDeo. Default 
is FULL.

Command Sets the trigger mode of the 9100.
OFF means no trigger is active. VIDeo activates the trigger at choosen level.

Query Returns the current setting.

Example SENSe:TRIGger VIDeo
:SENSe:TRIGger?
Returns the following string: "VIDeo".

Syntax :SENSe:TRIGger:LEVel <real1>

Parameters real1 is a floating point real number. 
The minimum value for real1 is -100, the maximum value 30.0. The minimum 
resolution is 0.1. The default value is -40.

Command Sets trigger level which is active if SENSe:TRIGger is set to VIDeo. 
real1 is the level in dBm.

Query Returns the current setting.

Example :SENSe:TRIGger:LEVel -10
:SENSe:TRIGger:LEVel?
The value returned in this example is: "-10".

Syntax :SENSe:TRIGger:EDGE <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
POSitive|NEGative. Default is POSitive.

Command Sets either the positive or the negative slope for the trigger.

Query Returns the current setting.

Example SENSe:TRIGger:EDGe NEGative
:SENSe:TRIGger?
Returns the following string: "NEGative".

Syntax :SENSe:DEMod:VOLume <int1>

Parameters int1 is an integer. The minimum value for int1 is 0, the maximum is 100. The 
default value is 50.

Command Sets the speaker volume of the demodulated signal in percent.

Query Returns the current setting.

Example :SENSe:DEMod:VOLume 20
:SENSe:DEMod:VOLume?
The value returned is:  "20".
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:SENSe:DEMod:DURation

:SENSe:DEMod[:MODulation]

:SENSe:DEMod:DEMod

Syntax :SENSe:DEMod:DURation <real1>

Parameters real1 is a floating point real number. The minimum value for real1 is 0, the max-
imum value 100. The minimum resolution is 0.001. The default value is 2.

Command Sets the duration of the demodulated signal in seconds.

Query Returns the current setting.

Example :SENSe:DEMod:DURation 10
:SENSe:DEMod:DURation?
The value returned is: "10".

Syntax :SENSe:DEMod[:MODulation] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|AM|FM.
Default is OFF.

Command Sets the demodulation mode, which can be off, AM (amplitude modulation) or FM 
(frequency modulation). FM demodulation is performed in a 30 kHz bandwidth.

Query Returns the current setting.

Example :SENSe:DEMod FM
:SENSe:DEMod:MODulation?
Returns the following string: "FM"

Syntax :SENSe:DEMod:DEMod <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions:  
PERManent|ATMarker. Default is PERManent.

Command Switches between permanent demodulation at the center frequency and demodula-
tion at the marker frequencies.

Query Returns the current setting.

Example :SENSe:DEMod:DEMod PERManent
:SENSe:DEMod:DEMod?
Returns the following string: "PERManent"
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:SENSe:DETector:FUNCtion

:SENSe:TRACe:A[:STATe]

Syntax :SENSe:DETector:FUNCtion <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: POSNeg|SAM-
Ple|POSitive|NEGative|.
Default is POSNeg.

Command Defines which of the measurement values shall be displayed.
The 9101 takes far more measurements than can be displayed on the screen, so sev-
eral results are summarized into one.
POSNeg indicates both the maximum and minimum values for each frequency point 
in the form of a straight vertical line between these values.
SAMPle lets the 9101 randomly select one of the measurement values for each fre-
quency point.
POSitive lets the 9101 pick the highest value.
NEGative lets the 9101 select the lowest value.

Query Returns the current setting.

Example :SENSe:DETector:FUNCtion SAMPle
:SENSe:DETector:FUNCtion?
Returns the following string: "SAMPle".

Syntax :SENSe:TRACe:A[:STATe] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ACTual|MAX-
Hold|MINHold|HOLD|AVG|OFF. Default is ACTual.

Command Sets the display mode for Trace A.
ACTual shows measurement by measurement.
MAXHold displays the maximum value for each frequency point over all the mea-
surements.
MINHold shows the minimum value for each frequency point over all the measure-
ments.
HOLD stops the measurement immediately.
AVG displays, for each frequency point, an average value over all the measurements.
OFF switches the trace off.

Query Returns the current settings.

Example :SENSe:TRACe:A MAXHold
:SENSe:TRACe:A:STATe?
Returns the following string: "MAXHold".
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:SENSe:TRACe:A:FETCh

:SENSe:TRACe:B[:STATe]

Syntax :SENSe:TRACe:A:FETCh <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
ALL|MINimum|MAXimum|FREQuency|FMINimum|FMAXimum.

Command There is solely a query form of this command available.

Query Returns the data of trace A depending on the parameter:
Param ALL returns: <min>,<max>,<freq>,<min>,<max>,<freq>, ... . 
Param MIN returns: <min>,<min>, ... . 
Param MAX returns: <max>,<max>, ... .
Param FREQ returns: <freq>,<freq>, ... . 
Param FMIN returns: <min>,<freq>,<min>,<freq>, ... . 
Param FMAX returns: <max>,<freq>,<max>,<freq>, ... .

Example :SENSe:TRACe:A:FETCh? ALL
Returns the following string:
"1000000.0,-50.3,-45.5,1001000.0,-53.4,-48.2,...".

Syntax :SENSe:TRACe:B[:STATe] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ACTual|MAX-
Hold|MINHold|HOLD|AVG|OFF.
Default is OFF.

Command Sets the display mode for Trace B.
ACTual shows measurement by measurement.
MAXHold displays the maximum value for each frequency point over all the mea-
surements.
MINHold shows the minimum value for each frequency point over all the measure-
ments.
HOLD stops the measurement immediately.
AVG displays, for each frequency point, an average value over all the measurements.
OFF switches Trace B off.

Query Returns the current settings.

Example :SENSe:TRACe:B MAXHold
:SENSe:TRACe:B?
Returns the following string: "MAXHold".
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:SENSe:TRACe:B:FETCh

:SENSe:TRACe:AVGFactor

:SENSe:TRACe:CLEar

:SENSe:TRACe:COPY

Syntax :SENSe:TRACe:B:FETCh <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
ALL|MINimum|MAXimum|FREQuency|FMINimum|FMAXimum.

Command There is solely a query form of this command available.

Query Returns the data of trace B depending on the parameter:
Param ALL returns: <min>,<max>,<freq>,<min>,<max>,<freq>, ... . 
Param MIN returns: <min>,<min>, ... . 
Param MAX returns: <max>,<max>, ... .
Param FREQ returns: <freq>,<freq>, ... . 
Param FMIN returns: <min>,<freq>,<min>,<freq>, ... . 
Param FMAX returns: <max>,<freq>,<max>,<freq>, ... .

Example :SENSe:TRACe:B:FETCh? ALL
Returns the following string:
"1000000.0,-50.3,-45.5,1001000.0,-53.4,-48.2,..."

Syntax :SENSe:TRACe:AVGFactor <int1>

Parameters int1 is an integer. The minimum value for int1 is 2, the maximum is 128. The 
default value for int1 is 5.

Command Sets the trace averaging factor.

Query Returns the current setting.

Example :SENSe:TRACe:AVGFactor 10
:SENSe:TRACe:AVGFactor?
Value returned in this example: "10".

Syntax :SENSe:TRACe:CLEar

Parameters There are no parameters.

Command Clears the current trace.

Query There is no query form of this command available.

Example :SENSe:TRACe:CLEar

Syntax :SENSe:TRACe:COPY <PredefExpr>[,<int>]

Parameters PredefExpr is one of the following predefined expressions: ATOB|BTOA.

Command Copies trace A to B or vice versa.

Query There is no query form of this command available.

Example :SENSe:TRACe:COPY ATOB
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:SENSe:REFLevel

:SENSe:REFLevel:UNIT

:SENSe:STATe

Syntax :SENSe:REFLevel <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is -113, the maximum value 137. The minimum res-
olution possible for real1 is 1. The default value for real1 is 0.
The minimum and maximum value for real1 depends on the unit set by 
SENS:REFL:UNIT. When unit is set to dBm, the minimum value is -100 and the 
maximum value is 30. When unit is set to dBuV, the minimum value is 7 and the 
maximum value is 137. When unit is set to dBmV, the minimum value is -53 and 
the maximum value is 77. When unit is set to dBV, the minimum value is -113 and 
the maximum value is 17. The default value for real1 is 0 dBm.

Command This command sets the reference level of the 9101 (0 dB line), in the unit selected 
with the :SENS:REFL:UNIT command.

Query Returns the current setting.

Example :SENSe:REFLevel -50
:SENSe:REFLevel?
The value returned is: "-50".

Syntax :SENSe:REFLevel:UNIT <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
DBM|DBUV|DBMV|DBV|.
Default is DBM.

Command Defines the unit for the reference level (dBm, dBµV, dBmV or dBV). It also affects the 
unit in which results (on the vertical axis) are displayed.

Query Returns the current setting.

Example :SENSe:REFLevel:UNIT DBMV
:SENSe:REFLevel:UNIT?
Returns the following string: "DBMV".

Syntax :SENSe:STATe?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the Uncal state. If the current settings lead to an invalid measurement (e.g. 
because the filters are not in steady state), the reply is “ON”, otherwise the reply is 
“OFF”.

Example :SENSe:STATe?
Returns the following string: "ON", meaning the 9101 filter and sweep settings 
should be adjusted. 
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:SENSe:MEASure

:SENSe:MEASure:OBW

:SENSe:MEASure:CHANnel:WIDTh

:SENSe:MEASure:CHANnel:SPACing

Syntax :SENSe:MEASure <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
NONE|CPOWer|ACPR|OBW. Default is NONE.

Command Starts measurements of the type described by PredefExp.

Query Returns the current setting.

Example :SENSe:MEASure ACPR
:SENSe:MEASure?
Returns the following string: "ACPR"

Syntax :SENSe:MEASure:OBW <int1>

Parameters int1 is an integer. The minimum value for int1 is 5, the maximum is 99. The 
default value is 90.

Command Sets percentage value for which the 9101 shall determine the occupied bandwidth 
(spectrum analyzer mode).

Query Returns the current setting.

Example :SENSe:MEASure:OBW 20
:SENSe:MEASure:OBW?
The value returned in this example is: "20".

Syntax :SENSe:MEASure:CHANnel:WIDTh <real1>

Parameters real1 is a floating point real number. The minimum value for real1 is 100000, 
the maximum value 2E9. real1 can be set in multiples of 1000. The default value 
for real1 is 5E6.

Command Sets actual channel width in spectrum analyzer mode.

Query Returns the current setting.

Example :SENSe:MEASure:CHANnel:WIDTh 150000000
:SENSe:MEASure:CHANnel:WIDTh?
The value returned in this example is: "150000000".

Syntax :SENSe:MEASure:CHANnel:SPACing <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 100000, the maximum value 2000000000. 
real1 can be set in multiples of 1000. The default value is 10000000.

Command Sets actual channel spacing in spectrum analyzer mode.

Query Returns the current setting.

Example :SENSe:MEASure:CHANnel:SPACing 1500000000
:SENSe:MEASure:CHANnel:SPACing?
The value returned in this example is: "1500000000".
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:SENSe:MEASure:ADJSettings

Input commands
With these commands, the input stage of the 9101 Handheld Spectrum Analyzer 
is affected.

:INPut:ATTenuation

:INPut:ATTenuation:AUTo

Syntax :SENSe:MEASure:ADJSettings

Parameters There are no parameters.

Command Adjusts settings in display made with ...CHAN:WIDTh and ...SPACing in the corre-
sponding measure mode CPOWer, ACPR or OBW.

Query There is no query form of this command available.

Example :SENSe:MEASure:ADJSettings

WARNING

The maximum input power level at the RF IN connector is 30 dBm (1 W). 
Higher input levels may result in serious damage of the instrument.

Syntax :INPut:ATTenuation <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 50. real1 can be set in 
steps of 10. The default value for real1 is 30.

Command This command sets the RF preattenuation of the Willtek 9101. The physical dimension 
of real1 is dB.

Query Returns the current setting.

Example :INP:ATT 20
:INPut:ATTenuation?
The value returned is: "20".

Syntax :INPut:ATTenuation:AUTo <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command Lets the 9101 select the preattenuation depending on the reference level.

Query Returns the current setting.

Example :INP:ATT:AUTO ON
:INPut:ATTenuation:AUTO?
Returns the following string: "ON"
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:INPut:IMPedance

:INPut:EDEVice

MMemory commands
With the MMemory commands, you can fully exploit the capabilities of the 
instrument to store and reload measurement results in its nonvolatile memory.

:MMEMory:STORe:STATe

Syntax :INPut:IMPedance <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: IMP50|IMP75.
Default is IMP50.

Command Lets the 9100 select between 50 Ω and 75 Ω impedance.
Changing the impedance automatically adjusts the display unit (as with the 
:SENSe:REFLevel:UNIT command): When switching to 75 Ω, the new unit 
will be dBµV. When switching to 50 Ω, the new unit will be dBm.

Query Returns the current setting.

Example :INP:IMP IMP75
:INPut:IMPedance?
Returns the following string: "IMP75"

Syntax :INPut:EDEVice <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Switch the external device compensation on or off. A corresponding file has to be 
loaded first with command MMEMory:LOAD:EDEVice.

Query Returns the current setting.

Example :INP:EDEVice ON
:INPut:EDEVice?
Returns the following string: "ON"

Syntax :MMEMory:STORe:STATe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Stores the actual parameter settings of the 9101 in the SETTINGS directory on the 
flash disk in a file named <string1>.

Query Returns the file name last stored with this command.

Example :MMEMory:STORe:STATe "sett3"
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:MMEMory:STORe:TRACe

:MMEMory:STORe:LIMit

Syntax :MMEMory:STORe:TRACe <string1>[,<PredefExp>]

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
PredefExpr is an optional parameter and one of the following predefined expres-
sions: A|B. Default is A.

Command Stores the current trace A or B and the parameter settings on the flash disk in the 
TRACE directory in a file named <string1>.

Query Returns the file name last stored with this command.

Example :MMEMory:STORe:TRACe "GSM900",A

Syntax :MMEMory:STORe:LIMit 
<string1>{,<PredefExpr>,<x1>,<y1>,<x2>,<y2>...}
:MMEMory:STORe:LIMit? <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters. 
PredefExpr is one of the following predefined expressions: LOWer|UPPer.
x1 y1 x2 y2 are floating point real numbers.
The minimum value for all these reals is 0, the maximum value for the x values is 10, 
the maximum value for the y values is 8, the resolution for all real values is 0.1 and 
the default is 0.

Command Stores the limits defined as lines in the LIMIT directory on the flash disk in a file 
named <string1>. A line is defined by a parameter set 
PredefExpr,x1,y1,x2,y2. Up to 30 parameter sets can follow the string 
parameter.

Query Returns the parameter sets of the limit file which is given as parameter.

Example :MMEMory:STORe:LIMit 
"lim2",UPP,2.3,4.5,6.9,7,2,LOW,2.3,1.5,6.9,3,2
:MMEMory:STORe:LIMit? "lim2"
String returned: UPP,2.3,4.5,6.9,7,2,LOW,2.3,1.5,6.9,3,2
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:MMEMory:STORe:CHANnel

:MMEMory:STORe:EDEVice

Syntax :MMEMory:STORe:CHANnel <string1>, <int1>, <int2>, 
<real1>, <real2>, <real3>, <real4>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
int1 is an integer. The minimum value for int1 is 1, the maximum is 1000000. 
The default value for int1 is 100.
int2 is an integer. The minimum value for int2 is 0, the maximum is 1000000. 
The default value for int2 is 0.
real1 is a floating point real number. The minimum value for real1 is 0, the max-
imum value 4000000000. The minimum resolution possible for real1 is 1000. 
The default value for real1 is 1000000.
real2 is a floating point real number. The minimum value for real2 is 0, the max-
imum value 4000000000. The minimum resolution is 1000. The default value is 
1000000.
real3 is a floating point real number. The minimum value for real3 is 0, the max-
imum value 4000000000. The minimum resolution is 1000. The default value is 
1000000000.
real4 is a floating point real number. The minimum value for real4 is -100, the 
maximum value 30. The minimum resolution is 1. The default value is 0.

Command This command stores the present communication system settings within the 9101 
(e.g. for the channel power mode).
string1 is the name of system settings file in which the parameters are stored. 
int1 sets the number of channels. int2 sets the start channel number. real1 
sets the channel bandwidth over which to measure, in Hertz. real2 sets the fre-
quency spacing of the channels, in Hertz. real3 sets the frequency of the first 
channel, in Hertz. real4 sets the system reference level (0 dB line).

Query Reads and returns the parameter set from the limit file given as a parameter.

Example :MMEMory:STORe:CHANnel "P-GSM9DO", 125, 0, 400000, 
200000, 935000000, 0.0
:MMEM:STOR:CHAN? 
String returned: "P-GSM9DO".

Syntax :MMEMory:STORe:EDEVice <string1>, <real1freq>, 
<real1lev>, <real2freq>, <real2lev>, ... <real100freq>, 
<real100lev>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
real1freq to real100freq are floating point real numbers. The minimum 
value is 0, the maximum value 4e9. The minimum resolution is 1. 
real1lev to real100lev are floating point real numbers. The minimum value is 
-100, the maximum value 30. The minimum resolution is 0.01.

Command This command stores settings for external device compensation. string1 is the 
name of the external device compensation file in which the parameters are stored. 
realxfreq and realxlev are pairs of frequency and level values to set the 
attenuation on the respective frequency. The instrument applies linear interpolation 
for the level between frequency points. 

Query Returns the parameter sets of the external device compensation file which is given as 
a parameter.
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:MMEMory:LOAD:FILelist[:TRACe]

:MMEMory:LOAD:FILelist:STATe

:MMEMory:LOAD:FILelist:LIMit?

Example :MMEMory:STORe:EDEVice "EXT_DEV2",1000000, -5.1, 
2000000,-3.2,5000000,-4.1,10000000,-3.8,20000000,-2.6
:MMEM:STOR:EDEV? "EXT_DEV2"
String returned: 1000000, -5.1,2000000,-3.2,5000000,-4.1, 
10000000,-3.8,20000000,-2.6

Syntax :MMEMory:LOAD:FILelist[:TRACe]? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Returns the list of files stored in the TRACE directory. The file names are separated by 
commas.

Example :MMEMory:LOAD:FILelist:TRACe?
String returned: "trace1","trace2","trace3"

Syntax :MMEMory:LOAD:FILelist:STATe? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Returns the list of files stored in the SETTINGS directory. The file names are separated 
by commas.

Example :MMEMory:LOAD:FILelist:STATe?
String returned in this example:
"sett1","sett2","sett3"

Syntax :MMEMory:LOAD:FILelist:LIMit? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Returns a comma-separated list of file names. Each file contains spectrum limit val-
ues stored on the 9101.

Example :MMEMory:LOAD:FILelist:LIMit?
String returned: "lim1","lim2"
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:MMEMory:LOAD:FILelist:CHANnel

:MMEMory:LOAD:FILelist:EDEVice

:MMEMory:LOAD:STATe

:MMEMory:LOAD:TRACe

Syntax :MMEMory:LOAD:FILelist:CHANnel? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Returns a comma-separated list of file names. Each file contains channel values 
stored on the 9101.

Example :MMEMory:LOAD:FILelist:CHANnel?
String returned: "GSM900","GSM1800"

Syntax :MMEMory:LOAD:FILelist:EDEVice? <PredefExpr>

Parameters PredefExpr is an optional parameter and one of the following predefined expres-
sions: SHORt|EXTent. Default is SHORt.

Command There is only a query form of this command available.

Query Returns a comma-separated list of file names. Each file contains external device 
compensation values stored on the 9101.

Example :MMEMory:LOAD:FILelist:EDEVice?
String returned in this example: "EXT_DEV2","EXT_DEV5"

Syntax :MMEMory:LOAD:STATe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Loads 9101 parameter settings from file string1 located in the SETTINGS directory 
on the flash disk.

Query Returns the file name last loaded with this command.

Example :MMEMory:LOAD:STATe "sett3"

Syntax :MMEMory:LOAD:TRACe? <string1>[,<PredefExpr>]

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.
PredefExpr is an optional parameter and one of the following predefined expres-
sions: A|B. Default is A.

Command Loads 9101 traces from file <string1> located in the TRACE directory on the flash disk 
to trace A or B.

Query Returns the file name last loaded with this command.

Example :MMEMory:LOAD:TRACe "TESTTRACE2"
:MMEM:LOAD:TRAC "TTR3",B
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:MMEMory:LOAD:LIMit

:MMEMory:LOAD:CHANnel

:MMEMory:LOAD:EDEVice

:MMEMory:DELete:STATe

Syntax :MMEMory:LOAD:LIMit <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Loads 9101 limit settings from file <string1> located in the LIMIT directory on the 
flash disk.

Query Returns the file name last loaded with this command.

Example :MMEMory:LOAD:LIMit "sett3"

Syntax :MMEMory:LOAD:CHANnel <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Load saved channel data from file <string1> in the CHANNEL directory on the flash 
disk.

Query Returns the file name last loaded with this command.

Example <TT>:MMEMory:LOAD:CHANnel "GSM900"

Syntax :MMEMory:LOAD:EDEVice <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Load saved channel data from file <string1> in the external device directory on the 
flash disk.

Query Returns the file name last loaded with this command.

Example :MMEMory:LOAD:EDEVice "EXT_DEV2"

Syntax :MMEMory:DELete:STATe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1 in the SETTINGS directory on the flash disk. Files in this direc-
tory usually contain parameter settings of the device.

Query Returns the name of the file last deleted with this command.

Example :MMEMory:DELete:STATe "sett3"
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:MMEMory:DELete:STATe:ALL

:MMEMory:DELete:TRACe

:MMEMory:DELete:TRACe:ALL

:MMEMory:DELete:LIMit

Syntax :MMEMory:DELete:STATe:ALL

Parameters There are no parameters.

Command Deletes all the files in the SETTINGS directory on the flash disk. These files usually 
contain parameter settings of the 9101.

Query There is no query form of this command available.

Example :MMEMory:DELete:STATe:ALL 

Syntax :MMEMory:DELete:TRACe <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file <string1> (saved trace data and parameter settings) from the TRACE 
directory on the flash disk.

Query Returns the name of the file last deleted with this command.

Example :MMEMory:DELete:TRACe "GSM900"

Syntax :MMEMory:DELete:TRACe:ALL

Parameters There are no parameters.

Command Deletes all the TRACE files in the 9101 memory.

Query There is no query form of this command available.

Example :MMEMory:DELete:TRACe:ALL

Syntax :MMEMory:DELete:LIMit <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file <string1> in the LIMIT directory. Files in this directory contain limit set-
tings of the device.

Query Returns the name of the file last deleted with this command.

Example :MMEMory:DELete:LIMit "lim3"
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:MMEMory:DELete:LIMit:ALL

:MMEMory:DELete:CHANnel

:MMEMory:DELete:CHANnel:ALL

:MMEMory:DELete:EDEVice

Syntax :MMEMory:DELete:LIMit:ALL

Parameters There are no parameters.

Command Deletes all the files in the LIMIT directory on the flash disk. These files contain spec-
trum limit settings of the 9101.

Query There is no query form of this command available.

Example :MMEMory:DELete:LIMit:ALL

Syntax :MMEMory:DELete:CHANnel <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file <string1>  from the CHANNEL directory. Files in this directory contain 
channel settings of the device.

Query Returns the name of the file last deleted with this command.

Example :MMEMory:DELete:CHAN "P-GSM"

Syntax :MMEMory:DELete:CHANnel:ALL

Parameters There are no parameters.

Command Deletes all the files in the CHANNEL directory on the flash disk.

Query There is no query form of this command available.

Example :MMEMory:DELete:CHANnel:ALL

Syntax :MMEMory:DELete:EDEVice <string1>

Parameters string1 is a string (text) parameter. The maximum length of string1 is 11 char-
acters.

Command Deletes file string1 in the external device directory on the flash disk. Files in this 
directory contain external device compensation settings on the 9101.

Query Returns the name of the file last deleted with this command.

Example :MMEMory:DELete:EDEVice "lim3"
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:MMEMory:DELete:EDEVice:ALL

Instrument commands

:INSTrument:SELect

Display commands
The display command subsystem affects the screen of the instrument.

:DISPlay:TRACe:Y[:SCALe]

Syntax :MMEMory:DELete:EDEVice:ALL

Parameters There are no parameters.

Command Deletes all the files in the external device directory on the flash disk.

Query There is no query form of this command available.

Example :MMEMory:DELete:EDEVice:ALL

Syntax :INSTrument:SELect <PredefExpr>

Parameters PredefExpr is one of the following expressions: SANalyzer|CPOWer. Default 
is SANalyzer.

Command Selects the measurement mode. Available modes are spectrum analyzer and channel 
power.

Query Returns the current setting.

Example :INSTrument:SELect CPOWer
:INSTrument:SELect?
String returned: "CPOWer"

Syntax :DISPlay:TRACe:Y[:SCALe] <int1>

Parameters int1 is an integer. Valid entries are 1, 2, 5, 10, 20. The default value is 10.

Command Holds the upper limit of the power scale but changes the resolution (and the lower 
limit) of the scale. real1 defines how many dB per scale unit are shown on the dis-
play.

Query Returns the current setting.

Example :DISPlay:TRACe:Y:[SCALe] 20
:DISPlay:TRACe:Y:[SCALe]?
The value returned is: "20".
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:DISPlay:BACKlight

:DISPlay:BEEP

:DISPlay:COLor:TRACe:[A|B]

:DISPlay:COLor:GRATicule

Syntax :DISPlay:BACKlight <int1>

Parameters int1 is an integer. The minimum value for <int1> is 0, the maximum is 100. The 
default value is 100.

Command Sets the brightness of the screen. A setting of 100 leads to the maximum brightness.

Query Returns the current setting.

Example :DISPlay:BACKlight 50
:DISPlay:BACKlight?
The value returned is: "50".

Syntax :DISPlay:BEEP <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is ON.

Command When on, the 9101 sounds a beep in case of an error or warning. When turned off, the 
sound is omitted.

Query Returns the current setting.

Example :DISPlay:BEEP ON
:DISPlay:BEEP?
Returns the following string: "ON"

Syntax :DISPlay:COLor:TRACe:[A|B] <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 8. The 
default value is 1 for trace A and 3 for trace B.

Command Sets the color from the color palette for trace A or B.

Query Returns the current setting.

Example :DISPlay:COLor:TRACe:A 5
:DISPlay:COLor:TRACe:A?
The value returned in this example is: "5".

Syntax :DISPlay:COLor:GRATicule <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 8. The 
default value is 2.

Command Sets the color from the color palette for the grid.

Query Returns the current setting.

Example :DISPlay:COLor:GRATicule 5
:DISPlay:COLor:GRAT?
The value returned in this example is: "5".
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:DISPlay:COLor:LIMits

Calculate commands
The markers of the 9101 can be set using the calculate commands.

:CALCulate:MARKer:AOFF

:CALCulate:MARKer:{A|B|C|D}[:STATe]

Syntax :DISPlay:COLor:LIMits <int1>

Parameters int1 is an integer. The minimum value for <int1> is 1, the maximum is 8. The 
default value is 7.

Command Sets the color from the color palette for the limit lines.

Query Returns the current setting.

Example :DISPlay:COLor:LIM 5
:DISP:COL:LIMits?
The value returned in this example is: "5".

Syntax :CALCulate:MARKer:AOFF

Parameters There are no parameters.

Command All marker are switched off.

Query There is no query form of this command available.

Example :CALC:MARK:A:STAT NORM
:CALC:MARK:B:STAT DELT
:CALC:MARK:C:STAT DELT
:CALC:MARK:AOFF

Syntax :CALCulate:MARKer:{A|B|C|D}[:STATe] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: OFF|NOR-
Mal|DELTa.
Default is OFF.

Command Selects an active marker and sets it to one of the modes: OFF|NORMal|DELTa. 
OFF is used to switch off the selected marker. 
NORMal switches the selected marker on. 
DELTa changes the marker to a delta marker; the REF marker is always A (marker 1).

Query The query form of this command will return the current setting. The string delivered 
back will contain the short-form version of one of the predefined expressions 
explained above.

Example :CALC:MARK:A:STAT NORM
:CALC:MARK:A:STAT?
Value returned: "NORM".
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:CALCulate:MARKer:{A|B|C|D}:Y

:CALCulate:MARKer:{A|B|C|D}:X[:FREQuency]

:CALCulate:MARKer:{A|B|C|D}:X:TIMe

Syntax :CALCulate:MARKer:{A|B|C|D}:Y? 

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query The query form of this command returns the level value at the current marker posi-
tion set by CALCulate:MARKer:{A|B|C|D}:X. The string delivered back will contain 
one floating point real number with the physical dimension that has been selected for 
the reference level (:SENSe:REFLevel:UNIT).

Example :CALCulate:MARKer:B:X 2200000000
:CALCulate:MARKer:B:Y?
The value returned is: "-22.4".

Syntax :CALCulate:MARKer:{A|B|C|D}:X[:FREQuency] <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0, the maximum value 4000000000. The mini-
mum resolution possible for real1 is 1. The default value for real1 is 1.8E9.

Command This command sets the marker frequency for one of the four markers of the Willtek 
9101 when in spectrum mode. The physical dimension of real1 is Hertz.

Query The query form of this command will return the current marker frequency setting of 
the respective marker of the Willtek 9101 (A, B, C or D). The string delivered back will 
contain one real number.

Example :CALCulate:MARKer:C:X 1500000000
:CALCulate:MARKer:C:X?
The value returned is: "1500000000".

Syntax :CALCulate:MARKer:{A|B|C|D}:X:TIMe <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is 0.001, the maximum value 100.0. The mini-
mum resolution possible for real1 is 1. The default value for real1 is 0.0432.

Command This command sets the marker time for zero-span measurements for one of the four 
markers of the Willtek 9101. The physical dimension of real1 is seconds.

Query The query form of this command will return the current marker time setting of the 
respective marker of the Willtek 9101 (A, B, C or D). The string delivered back will 
contain one real number.

Example :CALCulate:MARKer:C:X:TIME 0.5
:CALCulate:MARKer:C:X:TIME?
The value returned in this example is: "0.5".



Chapter 8 SCPI Command Reference
Calculate commands

138 9101 Handheld Spectrum Analyzer Version 2.21

:CALCulate:{A|B|C|D}:MARKer:FSTep

:CALCulate:MARKer:MAXPeak

:CALCulate:MARKer:NPEak

:CALCulate:MARKer:MCENter

Syntax :CALCulate:MARKer:{A|B|C|D}:FSTep

Parameters There are no parameters.

Command This command sets the step frequency (fstep) to be the frequency at the respective 
marker position.

Query There is no query form of this command available.

Example :CALCulate:MARKer:A:FSTep

Syntax :CALCulate:MARKer:MAXPeak

Parameters There are no parameters.

Command Sets the currently selected marker to the maximum measured level. A marker is 
"selected" by way of the :CALCulate:MARKer:{A|B|C|D}[:STATe] com-
mand.

Query There is no query form of this command available.

Example :CALCulate:MARKer:MAXPeak.

Syntax :CALCulate:MARKer:NPEak

Parameters There are no parameters.

Command Sets the currently selected marker to the next highest level value.

Query There is no query form of this command available.

Example :CALCulate:MARKer:NPEak.

Syntax :CALCulate:MARKer:MCENter

Parameters There are no parameters.

Command The center frequency is changed to the current marker frequency.

Query There is no query form of this command available.

Example :CALCulate:MARKer:MCENter.
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:CALCulate:MARKer:MREFlevel

:CALCulate:LIMit[:STATe]

:CALCulate:LIMit:FCOunt

Syntax :CALCulate:MARKer:MREFlevel

Parameters There are no parameters.

Command The REFerence level is changed to the level at the marker position.

Query There is no query form of this command available.

Example :CALCulate:MARKer:MREFlevel.

Syntax :CALCulate::LIMit[:STATe] <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: 
OFF|UPPer|LOWer|UPPLow.
Default is OFF.

Command Selects the limit lines to one of four different modes: 
OFF|UPPer|LOWer|UPPLow.
OFF is used to switch off the limit lines.
UPPer switches only the upper limit line on.
LOWer switches only the lower limit line on.
UPPLow switches both upper and lower limit lines on.

Query The query form of this command will return the current setting. The string delivered 
back will contain the short-form version of one of the predefined expressions 
explained above.

Example CALC:LIM:STAT UPPLOW
:CALC:LIM?
Value returned: "UPPL".

Syntax :CALCulate:LIMit:FCOunt <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Enables (and resets) or disables the failure counter. When enabled, requires that limit 
checking is also  active (see CALC:LIM:STAT).

Query Returns the current setting.

Example :CALCulate:LIMit:FCOunt ON
:CALCulate:LIMit:FCOunt?
Returns the following string: "ON"
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:CALCulate:LIMit:FCOunt:COUNt

:CALCulate:LIMit:FBEep

:CALCulate:LIMit:FHOLd

:CALCulate:LIMit:SIMPle

Syntax :CALCulate:LIMit:FCOunt:COUNt?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Gets the current count of fails in the limit check.

Example :CALCulate:LIMit:FCOunt:COUNt?
The value returned in this example is: "5".

Syntax :CALCulate:LIMit:FBEep <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Enables or disables a sound that can be output each time a measurement fails the 
limits.

Query Returns the current setting.

Example :CALC:LIMit:FBEep ON
:CALCulate:LIMit:FBEep?
Returns the following string: "ON".

Syntax :CALCulate:LIMit:FHOLd <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command If on, stops measurement updates and holds the last measurement result when it had 
a limit failure.

Query Returns the current setting.

Example :CALCulate:LIMit:FHOLd ON
:CALCulate:LIMit:FHOLd?
Returns the following string: "ON".

Syntax :CALCulate:LIMit:SIMPle <PredefExpr>

Parameters PredefExpr is one of the following predefined expressions: ON|OFF.
Default is OFF.

Command Enables or disables the simple limit lines.

Query Returns the current setting.

Example :CALCulate:LIMit:SIMPle ON
:CALCulate:LIMit:SIMPle?
Returns the following string: "ON". 
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:CALCulate:LIMit:SIMPle:UPPer

:CALCulate:LIMit:SIMPle:LOWer

:CALCulate:MEASure:ACPR

:CALCulate:MEASure:OBW

Syntax :CALCulate:LIMit:SIMPle:UPPer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is -160, the maximum value 0.0. The minimum res-
olution possible for real1 is 0.1. The default value for real1 is -10.0.

Command Sets the upper limit line for simple limits.

Query Returns the current setting.

Example :SENSe:LIMit:SIMPle:UPPer -10
:SENSe:LIMit:SIMPle:UPPer?
The value returned is: "-10".

Syntax :CALCulate:LIMit:SIMPle:LOWer <real1>

Parameters real1 is a floating point real number.
The minimum value for real1 is -160, the maximum value 0.0. The minimum res-
olution possible for real1 is 0.1. The default value for real1 is -70.0.

Command Sets the lower limit line for simple limits.

Query Returns the current setting.

Example :SENSe:LIMit:SIMPle:LOWer -70
:SENSe:LIMit:SIMPle:LOWer?
The value returned is: "-70".

Syntax :CALCulate:MEASure:ACPR?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string containing three floating point values; these represent the relative 
power in the lower adjacent channel (in dB), the in-channel power (in dBm) and the 
relative power in the upper adjacent channel (in dB).

Example :CALCulate:MEASure:ACPR?
Returns the following string: "-14.9,-31.5,-14.1". 

Syntax :CALCulate:MEASure:OBW?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns a string with the floating point value for the occupied bandwidth, in Hz.

Example :CALCulate:MEASure:OBW?
Returns the following string: "2694000.0". 
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:CALCulate:MEASure:CPOWer

Format commands
These commands are used for formatting the SCPI output of the 9101 Handheld 
Spectrum Analyzer.

:FORMat:ADELimiter

:FORMat:RESolution

Syntax :CALCulate:MEASure:CPOWer?

Parameters There are no parameters.

Command There is solely a query form of this command available.

Query Returns the measured in-channel power, in dBm.

Example :CALCulate:MEASure:CPOW?
Returns the following string: "-32.2". 

Syntax :FORMat:ADELimiter <PredefExp>

Parameters PredefExp is one of the following predefined expressions: 
COMMa|COLOn|SEMIcolon.
Default is COMMa.

Command Selects the delimiter to be used to separate parameters in SCPI commands, and also 
to separate the individual measurement result values in a result return string.
COMMa stands for commas (default),
COLOn sets the delimiter to be a colon (:), while
SEMIcolon will use and expect a semicolon (;) to be used.

Query Returns the current setting.

Example :FORM:ADEL
Defines the comma to be used as delimiter for both commands and measurement 
results.

Syntax :FORMat:RESolution <int1>

Parameters int1 is an integer. The minimum value for <int1> is 0, the maximum is 20. The 
default value is 6.

Command Defines the number of digits after the decimal point to be used for floating point real 
figures.

Query Returns the current setting.

Example :FORM:RES 0
Defines that there will be no digits after the decimal point.
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Service commands
These commands are used for information regarding the status of the 9101.

:SERVice:BOOTversion

:SERVice:BATTery

:SERVice:CHECk:LAST

Syntax :SERVice:BOOTversion?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns the version of the boot software of your Willtek 9101. The command will 
return a string.

Example :SERVice:BOOTversion?
String returned in this example: "1.80".

Syntax :SERVice:BATTery?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns the the current loading state of the battery in %. The command will return an 
integer.

Example :SERVice:BATTery?
String returned in this example: "40".

Syntax :SERVice:CHECk:LAST <int1>,<int2>,<int3>,<string>

Parameters intx are three integers. 
The minimum value for int1 is 1998, the maximum is 2100. The default value is 
1998.
The minimum value for int2 is 1, the maximum is 12. The default value is 1.
The minimum value for int3 is 1, the maximum is 31. The default value is 1.
string is a string (text) parameter. The maximum length of string1 is 16 char-
acters.

Command Sets date and operator’s name of the last check when calibration is due.

Query Returns the current settings of the last calibration check and operator’s name. The 
command will return 3 integers and a string.

Example :SERVice:CHECk:LAST?
String returned in this example: 2004,04,01,"John Williams".
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:SERVice:CHECk:NEXT

Syntax :SERVice:CHECk:NEXT?

Parameters There are no parameters.

Command There is only a query form of this command available.

Query Returns the current settings of the last calibration check and operator’s name. The 
command will return 3 integers and a string.
Returns the date of the next check to be performed on this device. The command will 
return 3 integers for year, month and date.

Example :SERVice:CHECk:NEXT?
String returned in this example: 2005,04,01.
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SCPI errors
The following table lists the error numbers that the 9101 may return in case of a 
problem.

Error 
number

Error description

Command errors

-100 Internal error only, for debugging purposes (Command error)

-101 Invalid character in command string

-102 SCPI syntax error: Command is not available as a query, or vice 
versa

-103 Invalid separator between parameters

-104 Data type error (mismatch between parameters and allowable 
data formats)

-108 Parameter not allowed (too many parameters)

-109 Missing parameter (too few parameters)

-111 Header separator error (probably colon missing between com-
mand keywords)

-112 Program mnemonic too long (i.e. longer than 12 characters)

-113 Keyword not found in command list

-114 Header suffix out of range (invalid character in command key-
word)

-121 Invalid character in number (not a digit, or exponent value 
missing)

-123 Exponent out of range

-128 Numerical data not allowed

-131 Invalid suffix (appended unit not found)

-134 Suffix too long (appended unit is longer than 12 characters)

-138 Suffix not allowed (parameter type is not real)

-141 Invalid character data (parameter expression is not in pre-
defined list)

-144 Character data too long (string data longer than allowed)

-158 String data not allowed for this parameter type

-160 Internal error only, for debugging purposes (Block data error)

-168 Internal error only, for debugging purposes (Block data not 
allowed)
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Execution errors

-201 Internal error only, for debugging purposes (SCPI execution 
function not defined)

-202 Internal error only, for debugging purposes (SCPI query function 
not defined)

-210 Internal error only, for debugging purposes (Out of memory)

-222 Data out of range

-230 Internal error only, for debugging purposes (Invalid token 
received by EXEC)

-231 Internal error only, for debugging purposes (Invalid index for 
parameter)

-232 Internal error only, for debugging purposes (Invalid parameter)

-233 Internal error only, for debugging purposes (Parameter has 
wrong type)

-234 Internal error only, for debugging purposes (Parameter missing)

-235 Internal error only, for debugging purposes (Index error)

-236 Parameter out of range

-260 File name not found in defined directory

-261 File creation failed in defined directory

-262 Internal error only, for debugging purposes (Label not found, 
config file)

-264 Error while saving or recalling trace file

Device-dependent errors

-300 SYSTEM_ERROR

-310 Internal error only, for debugging purposes (error no. not found)

-311 Internal error only, for debugging purposes (Function not yet 
supported)

-319 Error queue overflow (more than 10 entries)

-320 Wrong password

-321 Internal error only, for debugging purposes (Serial number error)

-322 Wrong option key

-323 Option not available

-330 Download command error

-331 Upload command error

Query errors

-400 Checkrule conflict, parameters outside limits

-401 Internal error only, for debugging purposes (EPROM write error)
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-402 Internal error only, for debugging purposes (EPROM read error)

-410 Result not valid
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Chapter 9 Programming Examples

This chapter provides examples how to use the SCPI commands to set up and 
control the 9101 Handheld Spectrum Analyzer.

– “Overview” on page 150

– “Command examples” on page 150

– “Application examples” on page 157
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Overview
This chapter describes how to control the 9101 from a personal computer via a 
serial or LAN connection. It explains the basic commands for the 9101 Handheld 
Spectrum Analyzer and describes a few typical applications together with the 
SCPI command sequence.

This documents does not show every command possible. It is assumed that the 
user has some basic knowledge about remote control and also some experience 
in the use of a spectrum analyzer.

Command examples

Introduction The whole command set can be divided into three categories: settings, measure-
ments and others. Each category is descriped in a separate section.

The word <val> stands for a numerical value.

The word <enum> is a placeholder for a string.

Prerequisites

Over serial interface The 9101 must be powered on. A serial cable (null modem cable with crossed 
lines) must connect the 9101 with the PC. The interface settings should be set to 
57600 bps, 8 bits per character, no parity, 1 stop bit.

Over LAN interface The 9101 must be powered on. A cross patch LAN cable must connect the 9101 
with the PC, or a normal LAN cable must connect the 9101 to a local area 
network. The 9101 must be programmed with its own IP address.

Settings Please note that the 9101 always tries to execute the commands. However under 
some circumstances, the 9101 must adjust or change other settings. If this 
happens, please check all previous settings and try to resolve this conflict.

Center frequency SENSe:FREQuency:CENTer <val>

Sets the center frequency in Hz.

Examples:

Long format:
SENSE:FREQUENCY:CENTER 96500000

Center frequency set to 96.5 MHz
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Short format:
SENS:FREQ:CENT 96.5E06 Center programmed to 96.5 MHz

Span SENSe:FREQuency:SPAN <val> Sets the span (dimension Hz)

Examples:

Long format:
SENSE:FREQUENCY:SPAN 20000000 Span programmed to 20 MHz

Short format:
SENS:FREQ:SPAN 20E06 Span programmed to 20 MHz

SENS:FREQ:SPAN:FULL Full span programmed

SENS:FREQ:SPAN 0 Zero span activated

Resolution bandwidth SENSe:BANDwidth:RESolution <val>
Sets the resolution bandwidth (dim. Hz)

Valid values for <val>: 10 kHz, 30 kHz, 100 kHz, 300 kHz or 1 MHz. 

Examples:

Long format:
SENSE:BANDWIDTH:RESOLUTION 30000 Resolution set to 30 kHz

Short format:
SENS:BAND:RES 30E03 Resolution set to 30 kHz

SENS:BAND:RES:AUTO ON Automatic selection active

Video bandwidth SENSe:BANDwidth:VIDeo <val> Sets the video bandwidth (dim. Hz)

Valid values for <val>: 100, 300 Hz. 1, 3, 10, 30, 100, 300 kHz or 1 MHz. 

Examples:

Long format:
SENSE:BANDWIDTH:VIDEO 300000 Video set to 300 kHz

Short format:
SENS:BAND:VID 10E03 Video set to 10 kHz

SENS:BAND:VID:AUTO ON Automatic selection active

Sweep time SENSe:SWEep:TIME <val> Sets the sweep time (dimension ms)

Valid values for <val>: 1, 2, 5, 10, 20, 50, 100, 200 or 500 ms; 1, 2, 5, 10 or 20 s. 
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Examples:

Long format:
SENSE:SWEEP:TIME 200 Sweep time set to 200 ms

Short format:
SENS:SWE:TIME 10 Sweep time set to 10 ms

SENS:SWE:TIME:AUTO ON Automatic selection active

Reference level SENSe:RFLevel <val> Defines the reference level (in dBm)

Examples:

Long format:
SENSE:RFLEVEL -30.0 Reference level set to -30.0 dBm

Short format
SENS:RFL 10 Reference level set to +10 dBm

Scale DISPlay:TRACe:Y <val> Defines scale per div. (in dB)

Examples:

Long format:
DISPLAY:TRACE:Y 10 Scale set to 10 dB per division

Short format:
DISPL:TRAC:Y 20 Scale set to 20 dB per div.

Input attenuation INPut:ATTenuation <val> Sets the input attenuation (in dB)

Valid input attenuation values: 0, 10, 20, 30, 40 or 50 dB. 

Examples:

Long format:
INPUT:ATTENUATION 10 10 dB attenuation

Short format:
INP:ATT 20 20 dB attenuation

Detector SENSe:DETector:FUNCtion <enum>
Sets the behavior of the detector

WARNING

Be careful with 0 dB. This value may damage the unit if the actual power is 
too high.
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Valid entries for <val>: POSNeg, SAMPle, POSitive or NEGative. 

Examples:

Long format:
SENSE:DETECTOR:FUNCTION POSITIVE Positive sampling

Short format:
SENS:DET:FUNC NEG Negative sampling

Trace SENSe:TRACe:<x> <enum> Sets the trace behavior for trace A or B

<x> is the trace (A or B)

Valid entries for <enum> are: ACTual, MAXHold, MINHold, HOLD, AVG or OFF. 

Examples:

Long format:
SENSE:TRACE:A ACTUAL Normal trace for A

Short format:
SENS:TRAC:B AVG Average trace for B

Marker CALCulate:MARKer:<x>:X <val> Sets the marker frequency (in Hz)

<x> is the trace (A to D)

Examples:

Long format:
CALCULATE:MARKER:B:X 98500000 Marker B set to 98.5 MHz

Short format:
CALC:MARK:A:X 1.2E09 Marker A set to 1.2 GHz

CALC:MARK:AOFF All markers disabled

CALC:MARK:C:OFF Only marker C disabled

CALC:MARK:MAXP Selected marker set to MaxPeak

CALC:MARK:NPE Selected marker set to NextPeak

Measurements

Trace SENSe:TRACe:<x>:FETCh? <enum>
Reads the trace data in a definable format
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<x> is the trace (A or B)

Valid entries for <enum>: ALL, MIN, MAX, FREQ, FMIN or FMAX. 

Examples:

Long format:
SENSE:TRACE:A:FETCH? ALL All measured data requested

Short format:
SENS:TRAC:B:FETC? MAX Trace B (only MAX) requested

Format examples:

ALL: <min level>, <max level>, <freq>, <min level>, …

MAX: <max level>, <max level>, ….

MIN: <min level>, <min level>, ….

FREQ: <freq>, <freq>, ….

FMAX: <max level>, <freq>, <max level>, <freq>, <max level>, ….

FMIN: <min level>, <freq>, <min level>, <freq>, <min level>, ….

Note: One trace contains 500 samples.

Sweep SENSe:SWEep:STATe <enum> Controls the sweep

Valid entries for <enum>: CONTinuous, SINGle or HOLD

Examples:

Long format:
SENSE:SWEEP:STATE SINGLE One sweep performed

Short format:
SENS:SWE:STAT CONT Repetitive sweeps started

Max Peak CALCulate:MARKer:MAXPeak Sets the marker to the maximum peak

Examples:

Long format:
CALCULATE:MARKER:MAXPEAK Marker set to max. peak

Short format:
CALC:MARK:MAXP Marker set to max. peak

Note: A marker must be activated first using the following command:
CALC:MARKer:<x>[:STATE] {NORMal|DELTa|NOISe}.
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Next Peak CALCulate:MARKer:NPEak Sets the marker to the next highest peak

Examples:

Long format:
CALCULATE:MARKER:NPEAK  Marker set to the next peak

Short format:
CALC:MARK:NPE Marker set to the next peak

Note: A marker must be activated first using the following command:
CALC:MARKer:<x>[:STATE] {NORMal|DELTa|NOISe}.

Marker level CALCulate:MARKer:<x>:Y?Reads the level at the actual marker position

<x> selects the trace (A to D)

Examples:

Long format:
CALCULATE:MARKER:B:Y?  Marker B level requested

Short format:
CALC:MARK:A:Y? Marker A level requested

Marker frequency CALCulate:MARKer:<x>:X? Reads the actual marker frequency

<x> selects the trace (A to D)

Examples:

Long format:
CALCULATE:MARKER:B:X?  Marker B frequency requested

Short format:
CALC:MARK:A:X? Marker A frequency requested

Others

Identity *IDN? Reads serial number of the instrument

Format returned: "<Manufacturer>, <Model>, <Serial number>, 
<Software version>"

Manufacturer: Willtek

Model: 9101

Serial number: (seven digits)
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Software version:  2.00 (for example)

Reset *RST Resets the unit

Example:

*RST Unit set to idle state

Error queue SYST:ERR? Queries the error queue

Format returned: <Error number>, "<Error description>"

If no error is present, 0,"No Error" is returned.

Note: The error queue can hold up to 10 error messages. Read always until the 
NO ERROR is given back.

Echo SYST:COMM:ECHO <enum> Enables/disables echo function

Range: ON or OFF.

Example:

SYST:COMM:ECHO ON Echo feature activated

Note: We recommend to always activate the echo. It gives back "OK" after a 
command was successfully executed or in case of errors "ERR".

The additional advantage of this is to create a kind of handshake mechanism.

Local mode SYST:COMM:LOCAL Switches unit back to local mode

Example:

SYST:COMM:LOCAL Remote session finished
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Application examples
The below application examples use three subroutines which transmit a 
command (Output9100), read a result (Input9100) or send a command and read 
the acknowledgement (OutAck9100). These subroutines are not printed here but 
available from Willtek on request. The program examples are written in BASIC.

Signal monitoring Task: Permanently monitor a signal and check if it is still present. The signal 
frequency is 97.3 MHz and the signal strength is around -40 dBm. 

OutAck9100 ("SENS:FREQ:CENT 97300000") ' set the center to the frequency 
OutAck9100 ("SENS:FREQ:SPAN 2E06") ' set span to 2 MHz

OutAck9100 ("SENS:REFL -30") ' set a sensitive ref level
OutAck9100 ("INP:ATT 10") ' set a low attenuation
OutAck9100 ("SENS:TRAC:A ACT") ' activate an normal trace
OutAck9100 ("SENS:DET:FUNC POS") ' use only positive samples

OutAck9100 ("CALC:MARK:AOFF") ' switch all markers off
OutAck9100 ("CALC:MARK:A NORM") ' activate marker A
SIG_FLAG = True

While SIG_FLAG = True
   OutAck9100 ("SENS:SWE:STAT SING") ' do one measurement

   OutAck9100 ("CALC:MARK:A:X 97.3E06") ' set marker to the signal

   Output9100 ("CALC:MARK:A:Y?") ' read the signal level
   Lvl  = Val(Input9100())

   If Lvl < -45 Then SIG_FLAG = False ' Signal lost
Wend 

Print "Signal disappeared!!!"
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Signal search Task: Search for transmitters within a frequency band. If a signal is present and 
higher than a level of -80 dBm, the frequency is printed.

OutAck9100 ("SENS:FREQ:SPAN 2000000") ' set span to 2 MHz
OutAck9100 ("SENS:FREQ:CENT 936000000") ' start with channel 0

OutAck9100 ("SENS:REFL -40") ' set a sensitive ref-level
OutAck9100 ("INP:ATT 0") ' remove any attenuation !!
OutAck9100 ("SENS:TRAC:A MAXH") ' activate a max hold trace
OutAck9100 ("SENS:DET:FUNC POS") ' use only positive samples

OutAck9100 ("CALC:MARK:AOFF") ' switch all markers off

channel = 1
For I = 9360 To 9594 Step 18 ' scan the gsm band in small portions
    Msg$ = "SENS:FREQ:CENT" & Str$(I) & "00000"
    OutAck9100 (Msg$) ' set frequeny
   
    For J = 0 To 4
        OutAck9100 ("SENS:SWE:STAT SING") ' do the measurements 5 times
    Next J

    Output9100 ("SENS:TRAC:A:FETC? MAX")
    MXdata$ = Input9100() ' read trace data
    
    For J = 0 To 499  ' isolate the data into an array
        P = InStr(MXdata$, ",") ' search for the COMMA between two values
        Yfeld(J) = Val(Mid$(MXdata$, 1, P))
        MXdata$ = Right$(MXdata$, Len(MXdata$) - P)

' remove the actual value
    Next J

    For J = 45 To 445 Step 50
        P = -120
        For K = 0 To 8 ' do a maximum search
            If Yfeld(J + K) > P Then
                P = Yfeld(J + K) ' store the new maximum
            End If
        Next K

        If P > -80 And channel < 125 Then  ' blocked channel found
            Print "Channel " & Str$(channel) & " = " & Str$(P) & " dBm."
        End If
        channel = channel + 1
    Next J
Next I
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Appendix A Menu Structure

This appendix provides an overview of the menu structure of the 9101 Handheld 
Spectrum Analyzer.
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Mode hardkey menus
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Application menus
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Appendix C Typical Application Examples

This appendix describes typical applications of spectrum analysis and how to 
solve a concrete measurement task. The topics discussed in this appendix are as 
follows:

– “Taking measurements on a sine wave signal” on page 168

– “Taking measurements on a burst or clocked signal” on page 172

– “Analyzing spurious signals, temporary spikes and glitches” on page 175
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Taking measurements on a sine wave signal
A sine wave is a typical signal being measured because it appears at many places 
in radio and electronic equipment. For example, a sine wave is the basic signal 
from which clock signals in computers are generated. Also, two sine waves can 
be the product of a carrier and a modulating audio tone.

Typical parameters of the sinusoidal (sine waveform) signal are level, frequency, 
and harmonics. These can be easily measured with the Willtek 9101 Handheld 
Spectrum Analyzer.

Frequency and level
measurements

The correct frequency is vital for radio and computer equipment to work properly. 
For computers, a deviation of 10% may be tolerable, but radio signals must apply 
frequencies with a tolerance of less than 1%.

In most cases it is also important that the level (power or voltage) of the sine 
wave is at least in the right order of magnitude. Before being able to take a 
measurement, the spectrum analyzer must be set up to display the signal in the 
right frequency range and with optimum reference level and attenuation.

In order to view a specific frequency range, for example close around the carrier 
frequency of the signal to be measured, the horizontal scale can be adjusted. The 
frequency range measured and displayed is usually called frequency span.

Any signal has its own amplitude. A very large signal may exceed the upper limit 
of the display, while a very low signal may be hidden in the noise floor at the 
bottom end of the display. The noise floor comes from the fact that any spectrum 
analyzer has a limited dynamic range, that is the range between the lowest and 
highest signal it can measure accurately. To reach the best dynamic range for the 
signal that you want to measure, it is important to adjust the reference level, 
that is the level at the top of the display. Most spectrum analyzers automatically 
adjust the internal attenuation when the user selects the reference level, so that 
the analyzer shows the best possible level range for the selected reference level.

Let’s assume that we expect a sine wave signal at 10 MHz. This frequency is 
comparatively low and it is sufficient to view the spectrum from 0 to 20 MHz 
which narrows down the displayed spectrum to the significant range and 
provides a reasonable frequency resolution. If the expected sine wave frequency 
is significantly higher, it is more useful to select a range of a couple of Megahertz 
around this frequency.

The following steps help to analyze the signal frequency and level:

1 Press PRESET to set the 9101 to a known state.
The start and stop frequencies are 0 and 3.6 GHz, respectively, so the spec-
trum in this range is visible, with a line representing the sine wave signal at 
10 MHz.

2 Set the stop frequency to 20 MHz by pressing the Stop softkey, entering 20 
on the numerical keypad and pressing the MHZ hardkey.
A signal curve appears in the right half of the display, with the peak at 
10 MHz. This is a view of the signal at a higher resolution of the bandwidth.
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3 It may be necessary to enhance the dynamic range displayed on the screen 
by adjusting the reference level (the maximum displayed level); this sets the 
internal attenuation of the 9101 accordingly:
Press the Ref. Level softkey and push the UP/DOWN cursor keys so that 
the signal peak appears about 5 to 10 dB below the top.
This leaves enough margin for temporary changes of the signal level.

4 You may see a relatively high noise floor. This can be decreased by averaging 
the measurements: Select Trace > Mode: A Average. 

5 One or several markers can be set to point to individual frequencies of the 
measured spectrum. The numerical values for level and frequency at these 
points are displayed at the top: 
Push the MKR hardkey to set a marker at the highest peak. 
If no higher signals are present, this will set a marker, indicated by a small 
triangle, at the peak of the signal to be measured.

6 If you need the frequency displayed with higher accuracy, select a smaller 
frequency span (range) around the signal:

– Press Marker to Center.
This centers the signal on the display.

– Press hardkey SPAN and enter a lower value, e.g. 1 MHz.
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Spurious and harmonics Side waves appear when the sine wave signal is of low spectral purity. In extreme 
cases, the signal has many strong side waves because the signal isn’t really a sine 
wave but e.g. a square wave. The signal is then composed of a main wave and 
side waves that are also called harmonics. These harmonics may be multiples of 
the main wave or multiples of a modulating frequency. This means they can be 
in the range of 100 kHz around the carrier or may be multiples of the original 
frequency. 

While a square wave generates wanted harmonics, unwanted side waves are 
called spurious emissions.

Frequencies with harmonics can best be tracked with the markers. Markers point 
to a displayed frequency (and level), so the resolution at which a point on the 
measurement curve is measured depends on the frequency resolution on the 
screen. The smaller the frequency span, the higher the frequency resolution on 
the display and hence of the marker. When reducing the span, it can be a good 
idea to readjust the markers to benefit from the higher frequency resolution.

To check spurious emissions and harmonics, proceed as follows (from the last 
example):

1 Select a small frequency span (range) of ±250 kHz around the signal:

– Press MKR > Marker to Center.
This centers the signal on the display.

– Press hardkey SPAN and enter a lower value, e.g. 500 kHz.

2 Add markers and place them on the next significant peaks (several dB above 
the slope of the signal):

– Press the MKR hardkey.

– Press softkeys M2, followed by several pushes on Next Peak until the 
marker is on the next significant peak.

– Press softkeys M3, followed by several pushes on Next Peak until the 
next significant peak is reached.

3 Turn the absolute markers M2 and M3 into delta markers indicating values 
relative to marker M1:

– Press softkeys Mkr Delta > Marker 3: rel.
– Press softkeys M2 > Marker 2: rel.

4 Check the spectrum and the markers: Are additional peaks high enough to 
seriously affect the signal quality? How high are they relative to the main 
signal (sine wave)? The pass/fail criteria for the spurious emissions depend 
on the actual signal requirements.
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5 Select a larger frequency span of at least five times the original signal to 
observe harmonics:
Select SPAN, enter 70 and close the input field with the MHZ key.

6 Place delta markers D2 and D3 on the second and third significant peak:

– Press hardkey MKR > D2 > Max Peak > Next Peak (repeat Next Peak if 
the peak found does not differ much from the surrounding level).

– Press D3 > Max Peak > Next Peak > Next Peak (repeat Next Peak if 
the peak found does not differ much from the surrounding level).

7 Check the spectrum and the markers: Are additional peaks high enough to 
seriously affect the signal quality? How high are they relative to the main 
signal (sine wave)? The pass/fail criteria for the harmonics emissions depend 
on the actual signal requirements.
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Taking measurements on a burst or clocked signal
Burst or clocked signals combine the characteristics of modulated signals with 
those of discontinuous signals. Modulated signals, on the one hand, have a wider 
spectrum that may vary to a certain extent. On the other hand, discontinuous 
signals appear and disappear, so the right moment for taking measurements is 
important.

The spectrum of a modulated signal does not have a constant, single peak but 
consists of a wider lobe (e.g. about 50 kHz for a typical FM radio signal, 800 kHz 
for a GSM signal or 1.2 MHz for an IS-95 CDMA signal). As the information 
transmitted on the carrier isn’t always the same, the spectrum slightly varies. So 
if the typical spectrum is of importance, it is a good idea to average the spectrum 
measurements. If, however, the worst-case spectral components shall be 
measured, you will want to view the peaks from several spectrum measurements 
and hence the max-hold mode should be selected.

Periodic, discontinuous signals can be measured, but require additional settings 
to ensure that the measurements include the active part of the signal; otherwise 
the Willtek 9101 Handheld Spectrum Analyzer could measure during time inter-
vals when the signal is not present. – In addition to the modulation spectrum, 
the burst length and shape are important parameters. These can be measured in 
the time domain, not in the frequency domain.

The following considerations should be made when measuring time-domain 
parameters:

– Measuring in the time domain means that the spectrum analyzer displays 
the signal over time, not over frequency, that means the frequency span is 
zero.

– The start of the measurement should be triggered by the rising edge of the 
signal, that means a signal level threshold must be defined that is above the 
noise floor and below the level when the signal is active (on).

– The duration of the measurement (sweep time) must be equal to or exceed 
the length of the burst, otherwise only a part of the burst will be shown.

Measuring frequency-domain parameters requires slightly different consider-
ations when setting up the spectrum analyzer:

– Defining a video trigger in the frequency domain makes no sense because 
the frequency observed by the spectrum analyzer is changing permanently.

– The duration of the measurement (sweep time) should be so high that for 
each measurement point, the interval of at least two bursts is measured to 
ensure that the measurement includes the wanted signal. Note that the 
spectrum measured this way includes both modulation and switching 
components.

The following example is the measurement of a burst signal from a GSM mobile 
phone transmitting on channel 63, that means on a carrier frequency of 
902.6 MHz. The signal level at the input of the 9101 Handheld Spectrum Analyzer 
is –10 dBm.
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To take measurements, proceed as follows:

1 Press PRESET to set the 9101 to a known state.
The start and stop frequencies are 0 and 3.6 GHz, respectively.

2 Press hardkey CENT and enter the center frequency of 902.6 MHz.

3 Press hardkey SPAN and enter a span of 1 MHz.
A chopped version of the spectrum appears.

4 Change the sweep time to the maximum: Select Main > SWT and enter 5 s.
The spectrum appears; the positive/negative peak detector is enabled and 
thus the display shows both values with a black line between peaks for each 
frequency point.

5 To eleminate the black lines, select the positive peak detector: Press Trace > 
Detect > Detector: Pos. Peak. 
A curve appears as shown below.

6 To measure the level over time, press SPAN and select 0 MHz.

7 Set a measurement bandwidth that includes the significant spectrum 
components: Press Main > RBW and enter 1 MHz.

8 Select a sweep time slightly higher than the burst length: Press Main > SWT 
and select 1 ms.

9 Set the video bandwidth to a high level to avoid smoothing to corrupt the 
signal shape: Press VBW and enter 1 MHz.
Burst measurements appear in arbitrary intervals.

10 Enable the video trigger with a trigger threshold of about 40 dB below the 
burst level: Press Freq > Trigger >  Video and enter –50 dBm.
Burst measurements appear frequently.

11 Burst flatness: Use a marker and a delta marker to view variations of the 
power level in the active part of the burst.
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12 Burst versus noise level: Use a marker and a delta marker to view the differ-
ence between the signal level and the noise level (in the picture below, the 
difference is 45.9 dB).

13 Burst length: Place a marker at the beginning of the burst and a delta 
marker at the end of the burst. Read the burst length (582 µs in the example 
below).
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Analyzing spurious signals, temporary spikes and glitches
Spurious signals are components close to or far from the desired frequency band. 
They are part of the overall signal, although usually outside the frequency range 
containing the desired signal, and can originate from crosstalk or active compo-
nents in the electronics.

Temporary spikes and glitches result in spectrum components that may not be 
observed immediately on the spectrum analyzer. It takes some time and a peak-
hold function to get them onto the screen.

Spurious signals and temporary spikes may be tolerable within certain limits, but 
may harm system performance when they exceed the limits. On the 9101, limit 
lines can be used to mark go/nogo areas and a pass/fail verdict clearly indicates 
if the signal is inside or outside limits.

Markers and delta markers can indicate the frequencies at which critical signal 
components occur and can be used to read absolute levels as well as levels rela-
tive to the main signal component.

These unwanted signal components can be analyzed as follows:

1 Press PRESET to set the 9101 to a known state.
The start and stop frequencies are 0 and 3.6 GHz, respectively.

2 Press CENT and enter the center frequency of the signal to be observed.

3 Press SPAN and enter a frequency range to be observed, e.g. 100 MHz.

4 Select Main > Trace > Mode: A Max hold to catch intermittent signals.
After some time, the display may look like as follows (wanted signal at the 
center frequency, two spurious or unwanted signals).
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5 If you need this measurement frequently, it might be a good idea to define a 
template, that means limit lines. These can form the basis for a clear pass/
fail statement that is easy to read and understand. 
The limit lines (template) can be defined on a PC, see section “91xx Data 
Exchange Software” on page 83.

6 To load the template (limit lines) from the PC to the 9101, first save it locally 
on the PC and then push the Send to 91xx button.

7 Press Level > Memory > Recall Limits to select one out of a number of 
available templates.

8 Select Limits Evaluation > Upper Limit to enable the limits (upper limit).
The template or upper limit is drawn and the 9101 displays a pass or fail 
indication at the upper left-hand corner.

9 Enable markers and place them on the wanted signal and the spurious 
signals: Press hardkey MKR to enable the marker menu and the first marker, 
which is placed on the highest peak. Press M2 and move it to the spurious 
signal by pressing Next Peak several times. Repeat this step with M3 and 
the next spurious signal.
Frequency and level of the spuriuos signals are indicated at the top.

10 In the Mkr Delta menu, enable delta markers for M2 and M3 (softkey rel). 
You can now view the frequency and level of each spurious signal relative to 
the wanted signal, which is required in many specifications and signal 
comparisons.
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Appendix D Warranty and Repair

This chapter describes the customer services available through Willtek. Topics 
discussed in this chapter include the following:

– “Warranty information” on page 180

– “Equipment return instructions” on page 181
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Warranty information
Willtek warrants that all of its products conform to Willtek's published specifi-
cations and are free from defects in materials and workmanship for a period of 
one year from the date of delivery to the original buyer, when used under normal 
operating conditions and within the service conditions for which they were 
designed. This warranty is not transferable and does not apply to used or demon-
stration products.

In case of a warranty claim, Willtek's obligation shall be limited to repairing, or 
at its option, replacing without charge, any assembly or component (except 
batteries) which in Willtek’s sole opinion proves to be defective within the scope 
of the warranty. In the event Willtek is not able to modify, repair or replace 
nonconforming defective parts or components to a condition as warranted 
within a reasonable time after receipt thereof, the buyer shall receive credit in 
the amount of the original invoiced price of the product.

It is the buyer's responsibility to notify Willtek in writing of the defect or noncon-
formity within the warranty period and to return the affected product to 
Willtek’s factory, designated service provider, or authorized service center within 
thirty (30) days after discovery of such defect or nonconformity. The buyer shall 
prepay shipping charges and insurance for products returned to Willtek or its 
designated service provider for warranty service. Willtek or its designated service 
provider shall pay costs for return of products to the buyer.

Willtek’s obligation and the customer’s sole remedy under this hardware 
warranty is limited to the repair or replacement, at Willtek’s option, of the defec-
tive product. Willtek shall have no obligation to remedy any such defect if it can 
be shown: (a) that the product was altered, repaired, or reworked by any party 
other than Willtek without Willtek’s written consent; (b) that such defects were 
the result of customer’s improper storage, mishandling, abuse, or misuse of the 
product; (c) that such defects were the result of customer’s use of the product in 
conjunction with equipment electronically or mechanically incompatible or of an 
inferior quality; or (d) that the defect was the result of damage by fire, explosion, 
power failure, or any act of nature.

The warranty described above is the buyer’s sole and exclusive remedy and no 
other warranty, whether written or oral, expressed or implied by statute or course 
of dealing shall apply. Willtek specifically disclaims the implied warranties of 
merchantability and fitness for a particular purpose. No statement, representa-
tion, agreement, or understanding, oral or written, made by an agent, distributor, 
or employee of Willtek, which is not contained in the foregoing warranty will be 
binding upon Willtek, unless made in writing and executed by an authorized 
representative of Willtek. Under no circumstances shall Willtek be liable for any 
direct, indirect, special, incidental, or consequential damages, expenses, or 
losses, including loss of profits, based on contract, tort, or any other legal theory.
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Equipment return instructions
Please contact your local service center for Willtek products via telephone or web 
site for return or reference authorization to accompany your equipment. For each 
piece of equipment returned for repair, attach a tag that includes the following 
information:

– Owner’s name, address, and telephone number.

– Serial number, product type, and model.

– Warranty status. (If you are unsure of the warranty status of your instru-
ment, include a copy of the invoice or delivery note.)

– Detailed description of the problem or service requested.

– Name and telephone number of the person to contact regarding questions 
about the repair.

– Return authorization (RA) number or reference number.

If possible, return the equipment using the original shipping container and mate-
rial. Additional Willtek shipping containers are available from Willtek on request. 
If the original container is not available, the unit should be carefully packed so 
that it will not be damaged in transit. Willtek is not liable for any damage that 
may occur during shipping. The customer should clearly mark the Willtek-issued 
RA or reference number on the outside of the package and ship it prepaid and 
insured to Willtek.
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Appendix E Software License

This chapter contains the license conditions for use of the 9101 Handheld Spec-
trum Analyzer and the 91xx Data Exchange Software.
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End-user license agreement
All copyrights in and to the software product are owned by Willtek Communica-
tions or its licensors. The software is protected by copyright laws and interna-
tional copyright treaties, as well as other intellectual property laws and treaties.

This end-user license agreement grants you the right to use the software 
contained in this product subject to the following restrictions. You may not:

(i) use the software and/or any copy of the software in different computers 
concurrently, unless the software is an update that has been downloaded 
from the Internet at www.willtek.com;

(ii) copy the software, except for archive purposes consistent with your stan-
dard archive procedures;

(iii) transfer the software to a third party apart from the entire product;

(iv) modify, decompile, disassemble, reverse engineer or otherwise attempt 
to derive the source code of the software;

(v) export the software in contravention of applicable export laws and regu-
lations of the country of purchase;

(vi) use the software other than in connection with operation of the product.

The licensor's suppliers do not make or pass on to end users or any other third 
party, any express, implied or statutory warranty or representation on behalf of 
such suppliers, including but not limited to the implied warranties of nonin-
fringement, title, merchantability or fitness for a particular purpose.

Willtek Communications shall not be held liable for any damages suffered or 
incurred by you or any other third party (including, but not limited to, general, 
special, consequential or incidental damages including damages for loss of busi-
ness profits, business interruption, loss of business information and the like), 
arising out of or in connection with the delivery, use or performance of the soft-
ware.



Publication History

Willtek and its logo are trademarks of Willtek Communications GmbH. All other 
trademarks and registered trademarks are the property of their respective owners.

Specifications, terms and conditions are subject to change without notice.

© Copyright 2004 Willtek Communications GmbH. All rights reserved.

No part of this manual may be reproduced or transmitted in any form or by any 
means (printing, photocopying or any other method) without the express written 
permission of Willtek Communications GmbH.

Revision Comment

0303-100-A First revision.

0312-210-A Redesigned user interface; channel power measurements, 
AM/FM demodulation, video trigger, limit template, addi-
tional marker functions added.

0404-220-A New features of software version 2.20; new chapters Spec-
trum Analysis and Channel Power Operation, Menu Struc-
ture, Typical Application Examples.

0406-221-A Additional battery icons; IP address of PC not required; max-
imum input power level must not exceed 30 dBm at any 
attenuator setting.

0409-221-A New chapters: Troubleshooting and Updating the Instru-
ment’s Software.



Willtek Worldwide Offices

West Europe/Middle East/Africa

Willtek Communications GmbH
Gutenbergstr. 2–4
85737 Ismaning
Germany

info@willtek.com

Willtek Communications SARL
Aéropôle – Bâtiment Aéronef
Rue de Copenhague – BP 9001
95728 Roissy CDG Cédex
France

willtek.fr@willtek.com

Willtek Communications Ltd.
Roebuck Place, Roebuck Road
Chessington
Surrey KT9 1EU
United Kingdom

willtek.uk@willtek.com

North America/Latin America Asia Pacific

Willtek Communications Inc.
7369 Shadeland Station Way, Suite 200
Indianapolis, IN 46256
USA

willtek.us@willtek.com
willtek.cala@willtek.com

Willtek Communications
22, Malacca Street
#09-00, Royal Brothers Building
Raffles Place
Singapore 048980

willtek.ap@willtek.com

Manual ident no. M 290 004
Manual version 0409-221-A
English


	About This Guide
	Purpose and scope
	Assumptions
	Related information
	Hardware-related changes
	Technical assistance
	Conventions

	Safety Notes
	Safety warnings

	Chapter�1�� Overview
	About the 9101 Handheld Spectrum Analyzer
	What’s new in version 2.21
	New in version 2.20
	New in version 2.10
	New in version 1.54

	Features and capabilities
	Options
	Physical description
	Maintaining your unit

	Chapter�2�� General Operation
	Connecting the 9101 Handheld Spectrum Analyzer
	DC in connector
	RF in connector
	Ext. Trig. connector
	Serial (RS�232) connector
	LAN connector

	Powering up the unit
	Starting measurements
	Using the front panel
	Overview
	Battery status LED
	Display
	Results area
	Result area (graph)
	Horizontal axis
	Vertical axis
	Symbols (icons)
	Other screen elements

	Marker field
	Input field
	Softkey descriptions

	Keypad
	Function keys
	Cursor keys
	Numeric keys
	Enter keys
	Escape key
	Backspace key
	Softkeys
	Horizontal (menu) softkeys
	Vertical (function) softkeys


	Entering numbers and text
	Filling in a numerical input field
	Acoustical reaction on inputs

	Filling in a text input field
	Changing the input


	Selecting the measurement mode
	Working with the markers
	Enabling and moving a marker
	Disabling a marker
	Enabling a delta marker
	Disabling a delta marker
	Setting a marker on a frequency relative to marker�M1
	Changing the center frequency with a marker
	Changing the reference level with the marker
	Assigning the marker frequency to FStep

	Using limit lines
	Overview
	Using simple limits
	Switching simple limits on and off
	Defining upper and lower limits

	Using limit templates
	Selecting limit lines within the�9101
	Activating and deactivating limit templates
	Deleting limit files in the�9101

	Counting limit failures
	Resetting the counter
	Enabling a beep upon failures
	Viewing a failed measurement

	Controlling the 9101 from a PC
	Returning from remote control to local mode
	Checking general settings
	Reading the serial number
	Reading the software version number
	Reviewing the calibration
	Checking installed options
	Installing a new option
	Changing the display brightness
	Enabling and disabling beeps
	Assigning a device name to the instrument
	Adjusting date and time in the instrument
	Changing the bit rate on the RS-232 port
	Changing the IP address of the 9101
	Changing the IP address of the PC
	Changing the IP port used by the 9101
	Selecting user interface colors

	Working with stored settings
	Storing settings on the 9101
	Using previously stored settings


	Chapter�3�� Spectrum Analysis Operation
	Selecting the measurement mode
	Changing the frequency settings
	Setting start and stop frequency
	Setting center frequency and span
	Changing the main menu for different frequency parameters
	Viewing the complete frequency band
	Performing measurements in the time domain
	Selecting the step size for the frequency input
	Manually setting the frequency step size
	Setting the frequency step size selection to automatic


	Selecting RBW, VBW and SWT
	Changing between automatic and manual mode

	Setting up the level parameters
	Setting the reference level
	Setting the hardware attenuation
	Changing the vertical scale
	Selecting the level unit for input and output
	Compensating gains and losses
	Enabling external device compensation
	Turning external device compensation off
	Deleting files for external device compensation


	Changing the input impedance
	Applying special functions on the signal
	Using a signal trigger
	Selecting untriggered signal analysis
	Selecting a trigger threshold in the RF signal

	Performing a limited number of measurements
	Demodulating an AM or FM signal

	Setting up the trace
	Selecting the trace mode
	Turning the second trace on and off
	Defining the number of measurements for averaging
	Selecting the detection method
	Copying traces inside the 9101

	Storing and loading traces
	Storing a trace
	Reusing a trace name
	Reloading a trace
	Deleting a trace
	Deleting all traces
	Storing and loading instrument settings

	Special measurement functions
	Channel power
	Adjacent channel power ratio (ACPR)
	Occupied bandwidth (OBW)
	Selecting the measurement type
	Switching special measurement functions off
	Changing the channel width
	Changing the channel spacing
	Reading the channel power
	Changing the occupied bandwidth percentage
	Changing general analyzer parameters


	Chapter�4�� Channel Power Operation
	About measurement modes and types
	Channel power
	Adjacent channel power ratio (ACPR)
	Occupied bandwidth (OBW)

	Selecting the measurement mode
	Operating in channel power mode
	Reading the channel power
	Changing the occupied bandwidth percentage
	Working with communication systems and frequency settings
	Selecting a communication system on the 9101
	Setting up a new communication system
	Deleting a communication system
	Deleting all communication systems
	Undeleting default communication systems
	Using the 91xx Data Exchange Software with communication systems
	Defining the frequency span
	Changing the channel

	Changing the sweep time
	Setting up the level parameters
	Setting the reference level
	Setting the hardware attenuation
	Changing the vertical scale
	Selecting the level unit for input and output
	Compensating gains and losses
	Enabling external device compensation
	Turning external device compensation off
	Deleting files for external device compensation


	Changing the input impedance
	Setting up the trace
	Selecting the trace mode
	Turning the second trace on and off
	Defining the number of measurements for averaging
	Selecting the detection method
	Copying traces inside the 9101

	Storing and loading traces
	Storing a trace
	Reusing a trace name
	Reloading a trace
	Deleting a trace
	Deleting all traces
	Storing and loading instrument settings


	Chapter�5�� Troubleshooting
	Handling system errors

	Chapter�6�� Updating the Instrument’s Software
	The Setup Application Software menu
	Performing a serial update
	Performing a LAN update
	Determining the Host IP address

	Chapter�7�� 91xx Data Exchange Software
	About the 91xx Data Exchange Software
	Installation requirements
	Understanding the license conditions
	Installing the software
	Starting the software
	Connecting the PC to the 9101
	Using a predefined configuration for the connection
	Serial interface connection
	LAN (TCP/IP) connection
	Saving the configuration

	Loading measurement results from the 9101
	Viewing the actual trace on the PC
	Transferring a saved trace to the PC

	Saving, loading and printing results on the PC
	Storing results on the PC
	Loading a trace file on the PC
	Printing measurement results
	Saving results to a graphics file
	Saving results to a text file

	Working with measurement results
	Adding a marker
	Using a grid
	Entering text

	Defining and loading limit templates
	Defining limits
	Changing limit lines
	Displaying an example trace in the limits editing menu
	Storing a template on the PC
	Loading a template from the PC
	Transferring a template to the 9101

	Defining and loading external coupling parameters
	Defining the external coupling factor
	Loading an external coupling loss file to the 9101

	Managing communication systems for channel power measurements
	Editing communication system parameters on the PC

	Working with settings
	Exchanging a settings file between 9101 and PC
	Changing 9101 settings on the PC

	Managing files on the PC and on the 9101
	File types and directory structure
	Starting the file manager menu
	Copying configuration files from the 9101 to the PC
	Deleting files


	Chapter�8�� SCPI Command Reference
	Overview
	General commands
	Commands affecting the event status register
	Commands affecting the service register

	System commands
	Sense commands
	Input commands
	MMemory commands
	Instrument commands
	Display commands
	Calculate commands
	Format commands
	Service commands
	SCPI errors

	Chapter�9�� Programming Examples
	Overview
	Command examples
	Introduction
	Prerequisites
	Over serial interface
	Over LAN interface

	Settings
	Center frequency
	Span
	Resolution bandwidth
	Video bandwidth
	Sweep time
	Reference level
	Scale
	Input attenuation
	Detector
	Trace
	Marker

	Measurements
	Trace
	Sweep
	Max Peak
	Next Peak
	Marker level
	Marker frequency

	Others
	Identity
	Reset
	Error queue
	Echo
	Local mode


	Application examples
	Signal monitoring
	Signal search


	Appendix�A�� Menu Structure
	Mode hardkey menus
	Application menus

	Appendix�B�� Index of SCPI Commands
	Appendix�C�� Typical Application Examples
	Taking measurements on a sine wave signal
	Frequency and level measurements
	Spurious and harmonics

	Taking measurements on a burst or clocked signal
	Analyzing spurious signals, temporary spikes and glitches

	Appendix�D�� Warranty and Repair
	Warranty information
	Equipment return instructions

	Appendix�E�� Software License
	End-user license agreement

	Publication History


<<
  /ASCII85EncodePages false
  /AllowTransparency false
  /AutoPositionEPSFiles true
  /AutoRotatePages /None
  /Binding /Left
  /CalGrayProfile (Dot Gain 20%)
  /CalRGBProfile (sRGB IEC61966-2.1)
  /CalCMYKProfile (U.S. Web Coated \050SWOP\051 v2)
  /sRGBProfile (sRGB IEC61966-2.1)
  /CannotEmbedFontPolicy /Error
  /CompatibilityLevel 1.4
  /CompressObjects /Tags
  /CompressPages true
  /ConvertImagesToIndexed true
  /PassThroughJPEGImages true
  /CreateJDFFile false
  /CreateJobTicket false
  /DefaultRenderingIntent /Default
  /DetectBlends true
  /ColorConversionStrategy /LeaveColorUnchanged
  /DoThumbnails false
  /EmbedAllFonts true
  /EmbedJobOptions true
  /DSCReportingLevel 0
  /EmitDSCWarnings false
  /EndPage -1
  /ImageMemory 1048576
  /LockDistillerParams false
  /MaxSubsetPct 100
  /Optimize true
  /OPM 1
  /ParseDSCComments true
  /ParseDSCCommentsForDocInfo true
  /PreserveCopyPage true
  /PreserveEPSInfo true
  /PreserveHalftoneInfo false
  /PreserveOPIComments false
  /PreserveOverprintSettings true
  /StartPage 1
  /SubsetFonts true
  /TransferFunctionInfo /Apply
  /UCRandBGInfo /Preserve
  /UsePrologue false
  /ColorSettingsFile ()
  /AlwaysEmbed [ true
  ]
  /NeverEmbed [ true
  ]
  /AntiAliasColorImages false
  /DownsampleColorImages true
  /ColorImageDownsampleType /Bicubic
  /ColorImageResolution 300
  /ColorImageDepth -1
  /ColorImageDownsampleThreshold 1.50000
  /EncodeColorImages true
  /ColorImageFilter /DCTEncode
  /AutoFilterColorImages true
  /ColorImageAutoFilterStrategy /JPEG
  /ColorACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /ColorImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000ColorACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000ColorImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasGrayImages false
  /DownsampleGrayImages true
  /GrayImageDownsampleType /Bicubic
  /GrayImageResolution 300
  /GrayImageDepth -1
  /GrayImageDownsampleThreshold 1.50000
  /EncodeGrayImages true
  /GrayImageFilter /DCTEncode
  /AutoFilterGrayImages true
  /GrayImageAutoFilterStrategy /JPEG
  /GrayACSImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /GrayImageDict <<
    /QFactor 0.15
    /HSamples [1 1 1 1] /VSamples [1 1 1 1]
  >>
  /JPEG2000GrayACSImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /JPEG2000GrayImageDict <<
    /TileWidth 256
    /TileHeight 256
    /Quality 30
  >>
  /AntiAliasMonoImages false
  /DownsampleMonoImages true
  /MonoImageDownsampleType /Bicubic
  /MonoImageResolution 1200
  /MonoImageDepth -1
  /MonoImageDownsampleThreshold 1.50000
  /EncodeMonoImages true
  /MonoImageFilter /CCITTFaxEncode
  /MonoImageDict <<
    /K -1
  >>
  /AllowPSXObjects false
  /PDFX1aCheck false
  /PDFX3Check false
  /PDFXCompliantPDFOnly false
  /PDFXNoTrimBoxError true
  /PDFXTrimBoxToMediaBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXSetBleedBoxToMediaBox true
  /PDFXBleedBoxToTrimBoxOffset [
    0.00000
    0.00000
    0.00000
    0.00000
  ]
  /PDFXOutputIntentProfile ()
  /PDFXOutputCondition ()
  /PDFXRegistryName (http://www.color.org)
  /PDFXTrapped /Unknown

  /Description <<
    /ENU (Use these settings to create PDF documents with higher image resolution for high quality pre-press printing. The PDF documents can be opened with Acrobat and Reader 5.0 and later. These settings require font embedding.)
    /JPN <FEFF3053306e8a2d5b9a306f30019ad889e350cf5ea6753b50cf3092542b308030d730ea30d730ec30b9537052377528306e00200050004400460020658766f830924f5c62103059308b3068304d306b4f7f75283057307e305930023053306e8a2d5b9a30674f5c62103057305f00200050004400460020658766f8306f0020004100630072006f0062006100740020304a30883073002000520065006100640065007200200035002e003000204ee5964d30678868793a3067304d307e305930023053306e8a2d5b9a306b306f30d530a930f330c8306e57cb30818fbc307f304c5fc59808306730593002>
    /FRA <>
    /DEU <>
    /PTB <>
    /DAN <>
    /NLD <>
    /ESP <>
    /SUO <>
    /ITA <>
    /NOR <>
    /SVE <>
  >>
>> setdistillerparams
<<
  /HWResolution [2400 2400]
  /PageSize [612.000 792.000]
>> setpagedevice


